Manjaro wont boot after kernel switch

Hi !

The issue
Recently, my laptop (Lenovo ThinkPad P14s Gen 1, AMD) started to reboot randomly; and sometimes it didnt even wake up from sleep.
So i tried to change kernel. I removed the active kernel and installed a new one (huge mistake, now i know it)
But after that, manjaro wasnt booting anymore.

What i already tried
I booted on live usb and did the following :
pacman-mirrors -f5
pacman -Syu
then ctrl+alt+f2
then logged in
sudo mhwd-kernel -linux54
all downloaded correctly but at the end, an error occurred :
usr/bin/grub-probe: error: failed to get cannonical path of ‘overlay’.
error: command failed to execute correctly

If your list of commands is complete, you updated the Live-USB media and not your actual system. You have to chroot ([How To] Save your Manjaro installation when it breaks or [HowTo] Chroot from or into any Linux distribution) into your actual installation and recover from there.

Tx for your answer. Im following the first page you linked, and when i type “lsblk” to know my Manjaro partition, here is the answer :
So my Manjaro partition is “nvmeOn1p2” ?

Hi @arnonyme, and welcome!

Glad you learnt something, at least then. Anyway, you should never try and remove your current kernel. Also, It’s recommended you keep at least 2 kernels installed, of which one should be an LTS version. That way you can use a different one to test, or work with or use to recover your system if something goes wrong with your current one.

What you tried looks good, except that you haven’t chrooted into your install so all the commands are excuted for the Live ISO and not your installed system. Tr6y the following:

  1. Boot into the live ISO environment and open a terminal.
  2. Enter a chroot environment of your system:
manjaro-chroot -a

Depending on the age of the Live ISO, there might be an error if you are asked which environment to enter. If thee one you selected doesn’t work, try the same one minus 1 again.

  1. Once successfully in the chroot environment, update the mirrors again:
pacman-mirrors -f5
  1. Once that is successful, you can go ahead and install a new kernel.
sudo mhwd-kernel --install linux54

That will install the 5.4 LTS kernel. While you’re at it, install 5.10 LTS as well:

sudo mhwd-kernel --install linux510

When it’s done, you can exit the chroot environment.


And, at least in theory, you should be able to reboot safely using the new kernel.

1 Like

Hi, thanks a lot for your answer !
When entering chroot, i get this error :

That’s fine! No need to worry at all!

This is a bad combination. After updating the mirrors use

sudo pacman -Syyu


ok heres what happens when i type “sudo mhwd-kernel --install linux54”

Please provide the output of

mhwd-kernel --list


As per Pacman-mirrors - Manjaro


Tip: Every run of pacman-mirrors requires you to syncronize your database and update your system.

$ sudo pacman -Syyu

So, after running the pacman-mirrors command, sync the database again, first:

$ sudo pacman -Syyu

And then try and install the kernel again.


EDIT to answer your EDIT :
the same error appears even if i type “sudo pacman -Syyu” after running “pacman-mirrors -f5”

In this case I would try

sudo pacman -S linux54 linux54-headers linux54-extramodules
sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')
sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-extramodules"}' ORS=' ')

Ok i tried, according to your message before you edited it, to install linux54-headers

And that worked ! I did it for linux510 too
My laptop booted correctly, problem solved !

1 Like

The second and third command are only useful to install headers and extramodules for all other potentially installed kernels, just in case you need it next time. :smiley:

1 Like