Manjaro with Nvidia GPU in Razer Core X Chroma - Can't Fully Boot

Hello everyone,

I am struggling getting my 3090 working with Manjaro in the Razer Core X Chroma enclosure.
It works fine with Windows (so the hardware is good) but in Manjaro wont let me fully boot.

Here is my inxi -Fazy

System:
  Kernel: 5.19.1-3-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.19-x86_64
    root=UUID=45bbb7b8-3052-400b-a281-2c260598cd3e rw rootflags=subvol=@ quiet
    cryptdevice=UUID=f4b6f1c0-1866-48b5-bb34-cbc1810a1054:luks-f4b6f1c0-1866-48b5-bb34-cbc1810a1054
    root=/dev/mapper/luks-f4b6f1c0-1866-48b5-bb34-cbc1810a1054 splash
    apparmor=1 security=apparmor udev.log_priority=3 mem_sleep_default=deep
    nvme.noacpi=1
  Desktop: GNOME v: 42.4 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 42.0
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Framework product: Laptop (12th Gen Intel Core) v: A8
    serial: <superuser required>
  Mobo: Framework model: FRANGACP08 v: A8 serial: <superuser required>
    UEFI: INSYDE v: 03.04 date: 07/15/2022
Battery:
  ID-1: BAT1 charge: 51.1 Wh (100.0%) condition: 51.1/55.0 Wh (92.9%)
    volts: 17.4 min: 15.4 model: NVT Framewo type: Li-ion serial: <filter>
    status: not charging cycles: 80
CPU:
  Info: model: 12th Gen Intel Core i7-1280P bits: 64 type: MST AMCP
    arch: Alder Lake level: v3 built: 2021+ process: Intel 7 (10nm ESF)
    family: 6 model-id: 0x9A (154) stepping: 3 microcode: 0x421
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 1861 high: 2000 min/max: 400/4800:3600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2000 2: 2000 3: 2000
    4: 2000 5: 2000 6: 2000 7: 2000 8: 2000 9: 2000 10: 2000 11: 479 12: 2000
    13: 2000 14: 2000 15: 2000 16: 2000 17: 2000 18: 2000 19: 2000 20: 749
    bogomips: 79900
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Alder Lake-P Integrated Graphics driver: i915 v: kernel
    arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports: active: eDP-1
    empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 00:02.0 chip-ID: 8086:46a6
    class-ID: 0300
  Device-2: NVIDIA GA102 [GeForce RTX 3090] vendor: eVga.com.
    driver: nouveau v: kernel non-free: 515.xx+ status: current (as of 2022-08)
    arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-22 pcie:
    gen: 3 speed: 8 GT/s lanes: 4 link-max: gen: 4 speed: 16 GT/s lanes: 16
    ports: active: HDMI-A-1 empty: DP-5,DP-6,DP-7 bus-ID: 56:00.0
    chip-ID: 10de:2204 class-ID: 0300
  Display: wayland server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: X: loaded: modesetting alternate: fbdev,vesa
    gpu: i915,nouveau display-ID: 0
  Monitor-1: HDMI-A-1 model: Acer XF270H B serial: <filter> built: 2018
    res: 1920x1080 dpi: 82 gamma: 1.2 size: 598x336mm (23.54x13.23")
    diag: 686mm (27") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 model: BOE Display 0x095f built: 2019 res: 2256x1504
    dpi: 201 gamma: 1.2 size: 285x190mm (11.22x7.48") diag: 343mm (13.5")
    ratio: 3:2 modes: 2256x1504
  OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 22.1.6
    direct render: Yes
Audio:
  Device-1: Intel Alder Lake PCH-P High Definition Audio driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0403
  Device-2: NVIDIA GA102 High Definition Audio vendor: eVga.com.
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 4
    link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 56:00.1
    chip-ID: 10de:1aef class-ID: 0403
  Sound Server-1: ALSA v: k5.19.1-3-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: a6:00.0 chip-ID: 8086:2725
    class-ID: 0280
  IF: wlp166s0 state: up mac: <filter>
  Device-2: ASIX AX88179 Gigabit Ethernet type: USB driver: ax88179_178a
    bus-ID: 10-1:2 chip-ID: 0b95:1790 class-ID: ff00 serial: <filter>
  IF: enp91s0u1 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:4 chip-ID: 8087:0032 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Drives:
  Local Storage: total: 1.82 TiB used: 353.19 GiB (19.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WDS200T1X0E-00AFY0 size: 1.82 TiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 613200WD temp: 36.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 952.85 GiB size: 952.85 GiB (100.00%) used: 353.15 GiB
    (37.1%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-f4b6f1c0-1866-48b5-bb34-cbc1810a1054
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 34.8 MiB
    (6.8%) fs: vfat dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-3: /home raw-size: 952.85 GiB size: 952.85 GiB (100.00%) used: 353.15
    GiB (37.1%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-f4b6f1c0-1866-48b5-bb34-cbc1810a1054
  ID-4: /var/log raw-size: 952.85 GiB size: 952.85 GiB (100.00%) used: 353.15
    GiB (37.1%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-f4b6f1c0-1866-48b5-bb34-cbc1810a1054
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 38.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 482 Uptime: 2h 13m wakeups: 9283 Memory: 62.52 GiB used: 5.59 GiB
  (8.9%) Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.1.1 clang: 14.0.6 Packages: pm: pacman pkgs: 1640 libs: 459
  tools: gnome-software,pamac pm: flatpak pkgs: 0 Shell: Zsh v: 5.9
  running-in: tilix inxi: 3.3.21

So using the open-source drivers I can boot fine and both cards (3090 and intel iris xe) are available. However the trouble begins when I install the video-hybrid-nvidia-intel-prime drivers. The installation goes fine but when I reboot I cannot fully boot. It appears as though everything just hangs. I am able to boot to run level 3 if I set it in the kernel, but startx just freezes everything again. No TTY switching or anything. It feels like either GDM tries and gets stuck or something similar however I am no knowledgeable enough in this area to work past it. I found some stuff online but nothing that fully matched my issues.

Thanks for your help.

Hello,

From my understanding the eGPU is not a prime/hybrid setup. You need the video-nvidia drivers for the eGPU and whatever you use so your laptop can boot and use the iGPU: video-linux or video-modesetting
Then you make use of the switcher GitHub - hertg/egpu-switcher: 🖥🐧 Setup script for eGPUs in Linux (Xorg)
Mind you, this switcher is for Xorg and you are running

So, you might need in that case the GitHub - dangreco/gnome-egpu: eGPU switcher for GNOME using udev rules

You can also consult this https://egpu.io/forums/thunderbolt-linux-setup/ubuntu-19-04-easy-to-use-setup-script-for-your-egpu/ as a reference and clarification how eGPU setup works …

I gave that a shot but had the exact same issue. Thanks for trying. :slight_smile: