Manjaro will not launch or install on ASUS M409

Trying to install Manjaro Plasma on this laptop I just picked up for work but after I picked either open-source or proprietary drivers (doesn’t matter which I pick), it takes me to a black screen that just says
“Starting version 251.2-3-manjaro” in the top left corner, with a blinking cursor for about 30 seconds, then the cursor stops blinking and the whole thing freezes and never progresses.

Total noobie here, so I haven’t got a clue. There are no error codes and countless Google searches has yielded no results for me.

does it have installed windows?

… Yes…

so disable secure boot from bios, disable fast boot in windows, and its possible that fast boot setting may be in bios also, enable AHCI in bios…
donwload latest iso from here
and use Ventoy to flash the iso onto usb

Secure boot is disabled, fast boot is disabled, AHCI is enabled, downloaded the latest version and created the bootable USB drive using Ventoy, with a fresh copy of “manjaro-kde-21.3.0-220617-linux515.iso” , plugged it in to the laptop and got the exact same issue. :confused:

it looks like some bios setting is preventing it from booting…
check this list:

Firmware checklist for BIOS systems

  • :white_small_square: Use latest available firmware
  • :white_small_square: Disable EFI
  • :white_small_square: Disable RAID option
  • :white_small_square: Enable AHCI

Firmware checklist for EFI Systems

  • :white_small_square: Disable CSM (Legacy) boot
  • :white_small_square: Disable Secure Boot
  • :white_small_square: Enable AHCI
  • :white_small_square: Disable Optane Memory and Rapid Storage Technology (RST)
  • :white_small_square: Disable RAID option
  • :white_small_square: Disable Fast Boot (if unable to boot from USB)

some of these settings may not be available in your bios

Checked over all of this as well, still nothing. :confused:
I’ve also tested other distros, perhaps this can help…

Mint let me launch in to the OS, but when I went to install, it didn’t show me my laptops hard drive, only the USB. When I clicked on any of the buttons on the partition editing screen, it crashed the installer.

Ubuntu went to the ASUS POST screen, with the Ubuntu logo at the bottom and a loading icon/circle. It eventually freezes completely similar to Manjaro.

there must be some setting in bios or windows causing it… can you boot again into mint, and in the live session close the lid to suspend your pc, open it, and wake up your pc and check if the disk is detected
also check in mints journal if you dont have any spam log

Done. I did notice before booting Mint, it says “AMD-Vi: Unable to read/write to IOMMU perf counter”

I tried what you said and it ended up completely breaking my bootable drive. It just stopped working. Would things go smoother if I were to completely remove Windows and just have an empty SSD?

Edit: Tried completely wiping the SSD of everything and the problem persists.

rhis message:
AMD-Vi: Unable to read/write to IOMMU perf counter
is related to bios, you can search for VM and iommu in the bios setting and change its setting do disable and try booting the usb
edit: also try updating your bios

Nothing in my BIOS for those things. :confused:

Also, I looked at the BIOS updates that were released for my laptop and they only say performance updates. No updates to anything regarding UEFI, security, BIOS, etc.

Which? Nevermind, I can’t read titles. :smiley:

so did you updated your bios with the performance update?
there must be something in your bios regarding virtualization, so check again

I just finished updating my BIOS to the latest version, and it unfortunately changed nothing. :confused:

edit: I have a video of my BIOS but can’t share it because for some reason on this site you can’t share links… on a support website??? But that’s cool. I guess I can always type out every word on each page? Lmao. What a joke that is. :confused:

did you disable the virtualization

Sorry I should have mentioned, the point of the video I mentioned above was to show that I am not crazy and that there is no virtualization option in the BIOS. I am 100% certain of it, going through the BIOS as I type this.

this is from asus site:
AMD Platform

  1. Power on the system and press[delete] key to enter BIOS [Advanced Mode]

  1. Select [Advanced] page and click [CPU Configuration] item

  1. click [SVM Mode] item and set to [Enabled]

  1. Press [F10] key and click [OK] ,the system will auto reboot

so disable it if its enabeld, if its disabled enable it and try

My BIOS is not like this at all. It’s a simple old fashioned blue screen with a lot less options. :confused:

so under cpu configuration you dont have any SVM Mode?