Manjaro VMware guest: Copying in Thunar to cifs-mounted Windows locations fails

I am using Manjaro Stable Branch in virtual mahcines in VMWare Workstation (running in Windows 11–added per comment).

The problem: In Thunar, copying (but not moving) a file into a cifs-mounted Windows location raises a “File Operation Progress” popup (which never goes away) and outputs an error to screen.

How I could reproduce the problem. (For you, it would require setting up the VM etc.)

  1. Update VM to the “23-12-15” (or now “23-12-23”) update > start VM > log into GUI (my desktop is Xfce).
  2. Mount a windows location, using something like:
sudo mount -t cifs -o username=tuna,password=domi,uid=1000,gid=1000 // /home/luna/mnt/daisy/have
  1. Start Thunar.
  2. Using Thunar, create a folder in the Windows location. It’s address may be: /home/luna/mnt/daisy/have/0/test/ (hereinafter just 0/test/).
  3. Drag and drop a file, e.g. jar-d.jpg from 0/ to 0/test/ > see that the moving of the file works just fine.
  4. But now, keep down the Ctrl key and do the same drag and drop > see that the copying the file fails. I can see it fails because I get a “File Operation Progress” pop-up (which never goes away unless I click “x” too close) and the copy of jar-d.jpg in the target directory is 0 bytes.


The error output at this point looks like the following:

How I got the error output.

  1. Update as before > start VM > log into terminal (Ctrl+Alt+F2) > get a VNC server going > from another computer, VNC into VM.
  2. Steps 3 through 6 are the same as above, and so is the result.
  3. (This should be step 7.) But on the actual VM terminal, I got the error output as above (I know I captured the whole thing because I was watching and the screen did not have roll over. I am sorry I don’t know how to capture that terminal except as a picture. If there is a log that will say the same, let me know and I will attach a searchable version.)

Here are facts that relate the failure to Manjaro updates.

  • The failure did not happen when I was updated only to the “2023-12-10” update.
  • I updated VM1 to the “2023-12-15” update on Dec 18 and VM2 to the same on Dec 23.
  • There was no problem until Dec 24 about noon (I am in GMT +9).
  • Suddenly, the problem began to occur in both VM1 and VM2.
  • If I restore the VMs to a snapshot reflecting only the “2023-12-10” update (but no later), then the problem disappears.
  • If I restore the VMs to a snapshot reflecting the “2023-12-15” update, then the problem immediately recurs.
  • VM3, updated to the “2023-12-13,” does not have this problem.
  • Conclusion: I am tempted to say the “2023-12-15” update causes the problem, but that flies counter to my having had no problem in VM1 and VM2 after that update until Dec 24 noon.

Well, for now, I have restored the VMs to their “2023-12-10” updated state and can use them no problem.

But I could I fix the problem in their later update states? Thank you.

As there is no general issue with Samba - something else must be causing your issue and I had to think hard to get an idea of what may be happening.

I renamed the topic to make clear that Manjaro VMware guest is an important key and - as you have been around for quite some time - you know VMware is unsupported in every possible aspect.

All communication to and from a virtual guest - goes through the host - using a set of virtual components provided by the host.

When you the update your guest Manjaro OS, the software communicating with the virtual components changes and this could create an inconsistency between the virtual components provided by the host and the virtual machine OS.


You make no mention of your host system so I will just say - ensure your host is fully up-to-date.


I note that you run you vm on stable branch - and in doing so you may inadvertently be causing the issue.

So for the guest I suggest you change to use Manjaro unstable. Then fully sync the system with an up-to-date mirror and restart the guest.

Then recheck if the issue persist.

Since it has worked before, this is most likely not involved, but could be something you could throw a glance at.

I don’t remember exactly how it worked, all I remember is that you had to do something to give vmware access to the network. I did not WANT the vm to have access so I never did, but I clearly recall there was a systemd service or something that needed to be started.

Also make sure the mkinitcpio hook to the vmware module goes through correctly when you update your system.


[2023-12-23T13:57:54+0100] [ALPM] running '70-dkms-install.hook'...
[2023-12-23T13:57:54+0100] [ALPM-SCRIPTLET] ==> dkms install --no-depmod vmware-workstation/17.5.0_22583795 -k 6.6.8-2-MANJARO
[2023-12-23T13:57:57+0100] [ALPM-SCRIPTLET] ==> dkms install --no-depmod vmware-workstation/17.5.0_22583795 -k 6.1.69-1-MANJARO
[2023-12-23T13:57:59+0100] [ALPM-SCRIPTLET] ==> depmod 6.6.8-2-MANJARO
[2023-12-23T13:58:00+0100] [ALPM-SCRIPTLET] ==> depmod 6.1.69-1-MANJARO
[2023-12-23T13:58:02+0100] [ALPM] running '90-mkinitcpio-install.hook'...
[2023-12-23T13:58:02+0100] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux61.preset: 'default'
[2023-12-23T13:58:02+0100] [ALPM-SCRIPTLET] ==> Using default configuration file: '/etc/mkinitcpio.conf'
[2023-12-23T13:58:02+0100] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-6.1-x86_64 -g /boot/initramfs-6.1-x86_64.img --microcode /boot/amd-ucode.img
[2023-12-23T13:58:02+0100] [ALPM-SCRIPTLET] ==> Starting build: '6.1.69-1-MANJARO'

I do not expect this to actually be the reason, but it never hurts to take an extra look.

Thanks for giving my problem a “hard” thought.

I did it per Switching Branches - Manjaro, or using these three commands

$ sudo pacman-mirrors --api --set-branch unstable
$ sudo pacman-mirrors --fasttrack 5
$ sudo pacman -Syu

Unfortunately, the problem persists.

My host is Windows 11. It’s been updated.

Is there nothing more to be done except to hope future updates might fix the problem?

My VM does have access to the LAN, and Thunar can even move files. It’s only copying that fails.

On mkinitcpio hook, what is the path to the log from which you have quoted? Thanks.

Impossible to say …

I used VMware when I used esxi to run virtual machines. I migrated my microservices to raspberry pi when the laptop I used as esxi host gave in.

In the meantime I tried run VMware on Arch and Manjaro with varying success until I made the decision to drop VMware in favor of VirtualBox and qemu/libvirt.

Besides Asahi Linux - I have parallels and vmware fusion on my macBook M1 - mostly for testing how to get Manjaro ARM functional.

Yeah, it’s strange. If it was the opposite, I would understand.
Have you tried using NFS instead of samba?
There is obv something not correct here, but I would argue for NFS over samba if all is on linux anyway.
Stick your head in the sand, pretend nothing is wrong. xD

That is just the pacman log: /var/log/pacman.log


Manjaro VMware guest: Copying in Thunar to cifs-mounted Windows locations fails


I’ll just go back to bed again mmmmkay?

Merry xmas! :christmas_tree: :christmas_tree: :christmas_tree:

Edit 2
This annoys me for some reason. xD

Are you sure you are running the latest version of smb (smb3)? Both on your windows share and make sure to include vers=3 in the mounting options.
And while you are at it, throw in rw,_netdev too, ie:

sudo mount -t cifs -o vers=3,rw,_netdev,username=tuna,password=domi,uid=1000,gid=1000 // /home/luna/mnt/daisy/have

I tried your amended command, and it made no difference.

As for running the latest smb, I never had to choose a version. Therefore I assume that I am using whichever version Windows 11 and Manjaro would have me use by default and that that would be the latest. (?)

I installed Nautilus to the Manjaro VM, and file copying works fine there.

So it would appear the problem is with Thunar rather than smb.

Or maybe I spoke too soon. Copying worked for a while and then failed again (in Nautilus). But working for a while is strange too.

And I restarted the machine, and copying in Nautilus works again.

Installed Caja > copying fails from the get-go.

Installed Dolphin > copying fails from the get-go.

I saw your reply to the effect that you have no more suggestions. Thank you for the idea of trying a different kernel. I completed the above list for anybody else who might take interest.

If it accepts vers=3 you are running smb3.

Sorry, I have no more input other than to try on other kernels.

That worked! Thank you so much.

I went from 6.1 to 6.6, and that took care of it.

Previously I had to go from 6.6 to 6.1 because on 6.6 booting sometimes hung at the “three dots” animation. But I don’t reboot very often, and having to re-reboot after a hang is something I can live with. Besides, I still have the uninstalling of plymouth I could try (which may fix the hang, per linux-aarhus’s suggestion).

Merry Xmas to you too!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.