Manjaro Unstable: KDE: Power management configuration module could not be loaded aka new monitors lag and are stuttering

Hey there guys,

As the title suggests I’m having issues with my brand new monitors. They’re stuttering and lagging quite a lot, which wasn’t the case on my previous 2 monitors (Upgraded from 2x60Hz to 2x165hz).

So, I’ve dug through the settings when I found this, so I presume it might have something to do with it?

I have no idea why, but the power module daemon seems to be started as sudo systemctl status upower returns:

     Loaded: loaded (/usr/lib/systemd/system/upower.service; disabled; preset: disabled)
     Active: active (running) since Wed 2023-11-29 18:49:08 CET; 3min 50s ago
       Docs: man:upowerd(8)
   Main PID: 1231 (upowerd)
      Tasks: 4 (limit: 77037)
     Memory: 5.7M
        CPU: 115ms
     CGroup: /system.slice/upower.service
             └─1231 /usr/lib/upowerd

Nov 29 18:49:08 PowerTower systemd[1]: Starting Daemon for power management...
Nov 29 18:49:08 PowerTower systemd[1]: Started Daemon for power management.

But it’s completely missing as a startup service from System Settings → Startup and Shutdown → Service Manager → Startup Service. It just isn’t there.

Any help to get this working would be greatly appreciated. Oh and I’m running KDE with Wayland + Nvidia, I’m gonna try and see how this goes with X11.

Have a great day y’All!

Hah, I was just dealing with this not 10 minutes ago on one of my desktops. Did you search? There’s a thread on it:

First I tried the advice to downgrade powerdevil and ddcutil to the last known working versions. But the renaming of KDE packages has caused the dependency check to fail for the older packages.

Rather than try to force it, I tried out the workaround in this thread, editing the plasma-powerdevil.service file:

Immediately after reboot, the problem is gone. I haven’t done any long term testing to see if it stays fixed with this change.

There is a different workaround documented in the KDE bug report for this issue, changing the service’s .desktop file. I haven’t tried that one.

1 Like

Hey, ma man! :smiley: Thank you so much for your quick and detailed solution.

I’ve done this workaround and this fixed my issue as well after a simple reboot!

Lags and stuttering is gone, power management module loading, can’t say much more than: Perfectly solved, thank you!

EDIT: The only thing I’ve noticed is that it seems that the option to put the screen(s) into sleep mode after time x is gone. Can be completely unrelated though

Editing Edit: To be more precise, the option to have the screen go dim before they eventually go to sleep mode is missing

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.