Manjaro Unreal-Enginge "Vulkan Device Not Available"

I am trying to work in the Unreal game engine and have run into some problems. I have installed unreal-engine AUR through the add/remove software utility. When I try to run the program I get an error saying Vulkan Device Not Available. I have been researching this and saw where other have had success doing ./UE4Editor -opengl4. Unfortunately this has not solved the issue for me. I have tried to include some relevant information below that I have seen people do in other forums.


  • Ryzen 7 3700x

  • EVGA GTX 1650 Super

  • Asus B550M - Plus

      $ vulkaninfo                                                           
      ERROR: [Loader Message] Code 0 : loader_scanned_icd_add: Could not get 'vkCreateInstance' via 'vk_icdGetInstanceProcAddr' for ICD
      ERROR: [Loader Message] Code 0 : /usr/lib32/ wrong ELF class: ELFCLASS32
      ERROR: [Loader Message] Code 0 : /usr/lib32/ wrong ELF class: ELFCLASS32
      ERROR at /build/vulkan-tools/src/Vulkan-Tools-1.2.162/vulkaninfo/vulkaninfo.h:248:vkEnumerateInstanceExtensionProperties failed with ERROR_INITIALIZATION_FAILED
      $ pacman -Q | grep headers                                                        
      linux-api-headers 5.8-1
      linux-latest-headers 5.10-1
      linux414-headers 4.14.215-1
      linux510-headers 5.10.7-3
      linux59-headers 5.9.16-1
      vulkan-headers 1:1.2.166-1

What’s the output of:

pacman -Qs vulkan
   $ pacman -Qs vulkan                                               
    local/lib32-nvidia-utils 460.32.03-1
        NVIDIA drivers utilities (32-bit)
    local/lib32-vulkan-intel 20.3.3-1
        Intel's Vulkan mesa driver (32-bit)
    local/lib32-vulkan-radeon 20.3.3-1
        Radeon's Vulkan mesa driver (32-bit)
    local/nvidia-utils 460.32.03-1
        NVIDIA drivers utilities
    local/vulkan-headers 1:1.2.166-1 (vulkan-devel)
        Vulkan header files
    local/vulkan-icd-loader 1.2.166-1
        Vulkan Installable Client Driver (ICD) Loader
    local/vulkan-intel 20.3.3-1
        Intel's Vulkan mesa driver
    local/vulkan-radeon 20.3.3-1
        Radeon's Vulkan mesa driver
    local/vulkan-tools 1.2.162-1 (vulkan-devel)
        Vulkan Utilities and Tools

I’m at a loss why that’s happening, sorry. That’s strange the error is referencing the build directory.

Tip: For pasting terminal output, paste it, highlight it, click the Preformatted text button </>. Please edit your post, remove the Quote indentation and fix the formatting.

I also have this error. Except that vkcube utility crashes for me with SIGSEGV (due to ENOMEM) and vkcubepp terminates due to bad alloc.