Manjaro-Tools: Fail to create ISO, after aborting last image creation

Ok, so I want to create a ISO again with manjaro-tools. Which in its simple form, I have done multiple times already over the years.

Also this time, after some config issues to set up the toolchain again, it worked again. Meaning I successfully created a manjaro ISO.
But then I changed some things in the package list, started it again … but aborted it, to change something more.
But now it does not finish anymore.

Generation complete.
→ Restoring [/var/lib/manjaro-tools/buildiso/xfce/x86_64/rootfs/etc/pacman.conf] …
→ Configuring lsb-release
→ Cleaning [rootfs]
==> Done [Base installation] (rootfs)
→ Loading Packages: [Packages-Desktop] …
==> Prepare [Desktop installation] (desktopfs)
→ overlayfs mount: [/var/lib/manjaro-tools/buildiso/xfce/x86_64/desktopfs]
mount: /var/lib/manjaro-tools/buildiso/xfce/x86_64/desktopfs: mount(2) system call failed: Stale file handle.
==> ERROR: A failure occurred in make_image_desktop().

I found another post, where someone had the problem of not enough space, but I have 200 GB left.
I suspect I need to fire up some cleanup routine.

p.s. was there a major forum change? My old account seems to no longer exist? I have not logged in for some months.

Yes, there was… :arrow_down:

Oha, that sounds bad.
Was the rootproblem found, or can the forum crash happen anytime again?

And my problem seems to be solved, it is in the process of creating the image again.
I had to do:

sudo rm -r /var/lib/manjaro-tools/buildiso/

1 Like

I’m not sure, but I think it was due to an update to the forum software that caused database corruption. As for whether it could happen again… :arrow_down:


Yup, let’s hope for the best.

(and my image was created successfully)

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.