Manjaro Tools broken again with non-free drivers

Guess this is something to do with the new 455 driver.

Moved from comment to OT by mod

If you boot the iso and choose non free drivers it does not boot and lightdm crashes.
Choosing free the iso boots. I use cinnamon on unstable and always build my own iso’s .

Please be specific in what situation you find it broken and how you concluded that, in regard with what Manjaro Tools, what do you want to achieve:

manjaro-tools-base	
manjaro-tools-base-git	
manjaro-tools-iso	
manjaro-tools-iso-git	
manjaro-tools-pkg	
manjaro-tools-pkg-git	
manjaro-tools-yaml	
manjaro-tools-yaml-git

Also, please read this:

1 Like

:+1: Welcome to Manjaro! :+1:

Please read this:


and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

:+1:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU you have and other details that will help us help you!

If you boot the iso and choose non free drivers it does not boot and lightdm crashes.
Choosing free the iso boots. I use cinnamon on unstable and always build my own iso’s .

I noted that yesterday at some point the mhwd database got updated witth nvidia 455 - maybe this is what you are looking for?

[2020-10-11T11:45:06+0200] [ALPM] upgraded mhwd-nvidia-455xx (455.28-1 -> 455.28-2)

1 Like

I’m pretty sure it was after that update but I can try again and report back.

Just tried again and still broken, perhaps the boot script also needs updating.

I don’t think the ISOs include driver 455 yet? Also, please don’t ignore @Fabby’s request for additional information.

1 Like

20.2-pre1 of KDE has 455xx drivers enabled, as we ship with 5.9 kernel there.

I do build - regularly - an ISO - I don’t have issues.

While any package suggests the non-git version as dependency - you must use either the normal versions or the git versions as mixing them most certainly will produce unspeakable horror to your system.

1 Like

455 is in the packages Mhwd

You have a GeForce GT 1030 so unless you have a compelling reason to be on 455, I’d suggest you downgrade to the 440 series which is much stabler.

2020-09-22_13-27

It all works Now Many Thanks obviously the 455 drivers were missing in Packages Mhwd.

Oh, I understand now, you were building your own ISO files, but the Manjaro ISO tools are missing the package check for NVIDIA 455. This means that MHWD can never install NVIDIA 455 and will instead install no config at all.

The last time this happened, @philm fixed it: [util-iso-image] make 440 Nvidia driver optional (d7c6bae8) · Commits · Tools / development-tools / manjaro-tools · GitLab

@philm maybe consider adding these checks for NVIDIA 450 and 455

The drivers have been added back to Packages Mhwd 3 days ago.

I’m still of the opinion that it should be fixed properly in manjaro-tools.

It already works in manjaro-tools. If Packages-Mhwd Contains the latest nvidia driver it will work.

So what. Now consider a Manjaro edition maintainer not wanting to ship any NVIDIA drivers. What will happen? MHWD will fail to install the NVIDIA 455 config and will then refuse to install nouveau either. This needs to be fixed in manjaro-tools like this, but for 450 and 455: [util-iso-image] make 440 Nvidia driver optional (d7c6bae8) · Commits · Tools / development-tools / manjaro-tools · GitLab

That is true if or when the drivers disappear for linux.