Manjaro takes 5 mins to boot

Manjaro takes ages to boot on my computer

chris@chris ~]$ systemd-analyze blame
5min 12.726s systemd-fsck@dev-disk-by\x2duuid-cc1265a1\x2d3a30\x2d4626\x2d8605\x2dccf1db077266.service
      3.849s NetworkManager-wait-online.service
      3.826s systemd-modules-load.service
       841ms docker.service
       759ms dev-nvme0n1p4.device
       561ms data.mount
       336ms containerd.service
       307ms NetworkManager.service
       297ms systemd-udev-trigger.service
       287ms udisks2.service
       180ms systemd-journal-flush.service
       159ms systemd-rfkill.service
       157ms user@1000.service
       157ms ldconfig.service
       148ms systemd-remount-fs.service
       143ms cups.service
       138ms plymouth-quit-wait.service
       118ms plymouth-start.service
       109ms lvm2-monitor.service
       103ms upower.service
       100ms modprobe@fuse.service
        93ms systemd-tmpfiles-setup.service
        89ms systemd-fsck@dev-disk-by\x2duuid-2210\x2d1829.service
        77ms polkit.service
        76ms systemd-journald.service
        76ms systemd-tmpfiles-clean.service
        74ms systemd-udevd.service
        70ms systemd-journal-catalog-update.service
        66ms systemd-vconsole-setup.service
        64ms plymouth-quit.service
        61ms systemd-logind.service
        56ms systemd-user-sessions.service
        54ms systemd-tmpfiles-setup-dev-early.service
        53ms modprobe@drm.service
        51ms dbus-broker.service
        50ms systemd-sysusers.service
        48ms dev-hugepages.mount
        48ms kmod-static-nodes.service
        47ms dev-mqueue.mount
        46ms modprobe@configfs.service
        46ms systemd-tmpfiles-setup-dev.service
        46ms systemd-timesyncd.service
        45ms sys-kernel-debug.mount
        44ms logrotate.service
        40ms ModemManager.service
        40ms systemd-update-done.service
        38ms plymouth-read-write.service
        38ms sys-kernel-tracing.mount
        36ms systemd-sysctl.service
        33ms boot-efi.mount
        30ms bluetooth.service
        29ms alsa-restore.service
        26ms user-runtime-dir@1000.service
        23ms systemd-update-utmp.service
        23ms systemd-random-seed.service
        21ms modprobe@loop.service
        19ms docker.socket
        16ms sys-fs-fuse-connections.mount
        15ms power-profiles-daemon.service
        13ms nordvpnd.socket
        11ms tmp.mount
         9ms sys-kernel-config.mount
         7ms rtkit-daemon.service
         5ms modprobe@dm_mod.service
         3ms proc-sys-fs-binfmt_misc.mount

I have no idea what systemd-fsck@dev-disk-by\x2duuid-cc1265a1\x2d3a30\x2d4626\x2d8605\x2dccf1db077266.service is.

Random other info that might help

[chris@chris ~]$ inxi --full --admin --filter --width
  Kernel: 6.6.16-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=7979a6d6-d005-47e1-ad73-56e8f5bef7ab rw quiet splash
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B360-F GAMING v: Rev 1.xx
    serial: <superuser required> part-nu: ASUS_MB_CNL uuid: <superuser required>
    UEFI: American Megatrends v: 0904 date: 09/14/2018
  Info: model: Intel Core i3-8350K bits: 64 type: MCP arch: Coffee Lake
    gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xB (11) microcode: 0xF4
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 8 MiB
    desc: 1x8 MiB
  Speed (MHz): avg: 800 min/max: 800/4000 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 bogomips: 32013
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: disabled, RSB
    filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP104 [GeForce GTX 1070] driver: nvidia v: 545.29.06
    alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current (as of
    2024-02; EOL~2026-12-xx) arch: Pascal code: GP10x process: TSMC 16nm
    built: 2016-2021 pcie: gen: 3 speed: 8 GT/s lanes: 2 link-max: lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1b81 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.11 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3440x1440 s-dpi: 109 s-size: 802x333mm (31.57x13.11")
    s-diag: 868mm (34.19")
  Monitor-1: Unknown-1 mapped: HDMI-0 res: 3440x1440 hz: 50 dpi: 110
    size: 797x333mm (31.38x13.11") modes: 3440x1440
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: kms_swrast surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GTX 1070/PCIe/SSE2
    memory: 7.81 GiB
  API: Vulkan v: 1.3.276 layers: 5 device: 0 type: discrete-gpu
    name: NVIDIA GeForce GTX 1070 driver: nvidia v: 545.29.06
    device-ID: 10de:1b81 surfaces: xcb,xlib
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 2 link-max: lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f0 class-ID: 0403
  Device-3: Razer USA Barracuda Pro 2.4
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-14.1:4 chip-ID: 1532:053a class-ID: 0301
    serial: <filter>
  API: ALSA v: k6.6.16-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 17.0 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  IF-ID-1: br-617af164e82b state: down mac: <filter>
  IF-ID-2: br-ecd3e317c94b state: down mac: <filter>
  IF-ID-3: docker0 state: down mac: <filter>
  Info: services: NetworkManager,systemd-timesyncd
  Device-1: TP-Link UB500 Adapter driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-11:2 chip-ID: 2357:0604
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 2.73 TiB used: 693.57 GiB (24.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WDS100T2B0C-00PXH0 size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 211070WD temp: 38.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD20EURX-63T0FY0
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 0A80
  ID-1: / raw-size: 833.56 GiB size: 819.4 GiB (98.30%)
    used: 225.29 GiB (27.5%) fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 25.6 MiB (8.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 35.0 C mobo: N/A gpu: nvidia temp: 48 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 0%
  Memory: total: 32 GiB available: 31.26 GiB used: 13.24 GiB (42.4%)
  Processes: 264 Power: uptime: 2h 25m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 12.49 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: pm: pacman pkgs: 1360 libs: 431 tools: pamac pm: flatpak pkgs: 0
    Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Bash v: 5.2.26
    running-in: konsole inxi: 3.3.33

Not sure if there are any other logs I should be aweare of that might be helpful in this situation

1 Like

Seems like filesystem check to me. The question is why and which disk. But you can at least research in that direction. Smartctl status, fsck from live usb, search the journal for related events or errors, stuff like that.

1 Like

Not exactly sure what im checking for tbh, but

journalctl | grep -i filesystem
Feb 27 19:37:07 chris systemd[1]: Stopped Discard unused filesystem blocks once a week.
Feb 27 19:37:12 chris kernel: EXT4-fs (sda): unmounting filesystem cc1265a1-3a30-4626-8605-ccf1db077266.
Feb 27 19:37:12 chris systemd[1]: Reached target Unmount All Filesystems.
Feb 27 19:37:13 chris systemd-shutdown[1]: Syncing filesystems and block devices.
Feb 27 19:37:31 chris kernel: EXT4-fs (nvme0n1p4): mounted filesystem 7979a6d6-d005-47e1-ad73-56e8f5bef7ab r/w with ordered data mode. Quota mode: none.
Feb 27 19:37:32 chris kernel: EXT4-fs (sda): mounted filesystem cc1265a1-3a30-4626-8605-ccf1db077266 r/w with ordered data mode. Quota mode: none.
Feb 27 19:37:34 chris systemd[1]: Started Discard unused filesystem blocks once a week.
Feb 27 19:37:35 chris containerd[520]: time="2024-02-27T19:37:35.615038819Z" level=info msg="skip loading plugin \"io.containerd.snapshotter.v1.btrfs\"..." error="path /var/lib/containerd/io.containerd.snapshotter.v1.btrfs (ext4) must be a btrfs filesystem to be used with the btrfs snapshotter: skip plugin" type=io.containerd.snapshotter.v1
Feb 27 19:37:35 chris containerd[520]: time="2024-02-27T19:37:35.615808926Z" level=info msg="skip loading plugin \"io.containerd.snapshotter.v1.zfs\"..." error="path /var/lib/containerd/io.containerd.snapshotter.v1.zfs must be a zfs filesystem to be used with the zfs snapshotter: skip plugin" type=io.containerd.snapshotter.v1
Feb 27 19:37:35 chris containerd[520]: time="2024-02-27T19:37:35.628770435Z" level=info msg="Get image filesystem path \"/var/lib/containerd/io.containerd.snapshotter.v1.overlayfs\""

This seems like its cleaning up some discs (and is roughly when I restarted my pc) but the timestamps show it only did so for a couple of seconds

[chris@chris ~]$ systemctl status
● chris
    State: running
    Units: 396 loaded (incl. loaded aliases)
     Jobs: 0 queued
   Failed: 0 units
    Since: Tue 2024-02-27 19:37:29 GMT; 15min ago
  systemd: 255.3-1-manjaro
   CGroup: /
           β”‚ └─1 /sbin/init splash
           β”‚ β”œβ”€ModemManager.service
           β”‚ β”‚ └─500 /usr/bin/ModemManager
           β”‚ β”œβ”€NetworkManager.service
           β”‚ β”‚ └─438 /usr/bin/NetworkManager --no-daemon
           β”‚ β”œβ”€bluetooth.service
           β”‚ β”‚ └─440 /usr/lib/bluetooth/bluetoothd
           β”‚ β”œβ”€containerd.service
           β”‚ β”‚ └─520 /usr/bin/containerd
           β”‚ β”œβ”€cronie.service
           β”‚ β”‚ └─523 /usr/sbin/crond -n
           β”‚ β”œβ”€cups.service
           β”‚ β”‚ β”œβ”€514 /usr/bin/cupsd -l
           β”‚ β”‚ └─530 /usr/lib/cups/notifier/dbus dbus://
           β”‚ β”œβ”€dbus-broker.service
           β”‚ β”‚ β”œβ”€436 /usr/bin/dbus-broker-launch --scope system --audit
           β”‚ β”‚ └─437 dbus-broker --log 4 --controller 9 --machine-id 51e6aae056ed433e9f46134ad97ebb73 --max-bytes 536870912 --max-fds 4096 --max-matches 131072 --audit
           β”‚ β”œβ”€docker.service
           β”‚ β”‚ └─547 /usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock
           β”‚ β”œβ”€nordvpnd.service
           β”‚ β”‚ └─548 /usr/sbin/nordvpnd
           β”‚ β”œβ”€ollama.service
           β”‚ β”‚ └─549 /usr/local/bin/ollama serve
           β”‚ β”œβ”€polkit.service
           β”‚ β”‚ └─441 /usr/lib/polkit-1/polkitd --no-debug
           β”‚ β”œβ”€power-profiles-daemon.service
           β”‚ β”‚ └─1629 /usr/lib/power-profiles-daemon
           β”‚ β”œβ”€rtkit-daemon.service
           β”‚ β”‚ └─1489 /usr/lib/rtkit-daemon
           β”‚ β”œβ”€sddm.service
           β”‚ β”‚ β”œβ”€539 /usr/bin/sddm
           β”‚ β”‚ └─541 /usr/lib/Xorg -nolisten tcp -background none -seat seat0 vt2 -auth /run/sddm/xauth_lTWbSG -noreset -displayfd 16
           β”‚ β”œβ”€systemd-journald.service
           β”‚ β”‚ └─228 /usr/lib/systemd/systemd-journald
           β”‚ β”œβ”€systemd-logind.service
           β”‚ β”‚ └─442 /usr/lib/systemd/systemd-logind
           β”‚ β”œβ”€systemd-timesyncd.service
           β”‚ β”‚ └─331 /usr/lib/systemd/systemd-timesyncd
           β”‚ β”œβ”€systemd-udevd.service
           β”‚ β”‚ └─udev
           β”‚ β”‚   └─229 /usr/lib/systemd/systemd-udevd
           β”‚ β”œβ”€udisks2.service
           β”‚ β”‚ └─1162 /usr/lib/udisks2/udisksd
           β”‚ └─upower.service
           β”‚   └─1177 /usr/lib/upowerd
               β”‚ β”œβ”€1403 /usr/lib/sddm/sddm-helper --socket /tmp/sddm-auth-bfc60aaa-99ce-4bdb-8c7d-379b417c934d --id 1 --start /usr/bin/startplasma-x11 --user chris
               β”‚ β”œβ”€1426 /usr/bin/kwalletd5 --pam-login 12 14
               β”‚ └─1427 /usr/bin/startplasma-x11
                 β”‚ β”œβ”€app-Discord-3db1febdbfa845ffb85b8683f6855936.scope
                 β”‚ β”‚ β”œβ”€2615 /opt/Discord/Discord
                 β”‚ β”‚ β”œβ”€2630 "/opt/Discord/Discord --type=zygote --no-zygote-sandbox"
                 β”‚ β”‚ β”œβ”€2631 "/opt/Discord/Discord --type=zygote"
                 β”‚ β”‚ β”œβ”€2633 "/opt/Discord/Discord --type=zygote"
                 β”‚ β”‚ β”œβ”€2710 /opt/Discord/chrome_crashpad_handler --monitor-self-annotation=ptype=crashpad-handler --no-rate-limit --database=/home/chris/.config/discord/Crashpad --url=https://f.a.k/e --annotation=_productName=discord --annotation=_version=0.0.43 "--annotation=lsb-release=Manjaro Linux" --annotation=plat=Linux --annotation=prod=Electron --annotation=ver=22.3.26 --initial-client-fd=43 --shared-client-connection
                 β”‚ β”‚ β”œβ”€2743 "/opt/Discord/Discord --type=gpu-process --crashpad-handler-pid=2710 --enable-crash-reporter=88b141fa-1536-4547-84ee-028d859195ab,no_channel --user-data-dir=/home/chris/.config/discord --gpu-preferences=WAAAAAAAAAAgAAAIAAAAAAAAAAAAAAAAAABgAAAAAAA4AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAACAAAAAAAAAAIAAAAAAAAAABAAAAAAAAAAgAAAAAAAAACAAAAAAAAAAIAAAAAAAAAA== --shared-files --field-trial-handle=0,i,8393889450872579866,8767442095313646817,131072 --disable-features=HardwareMediaKeyHandling,MediaSessionService,SpareRendererForSitePerProcess,WinRetrieveSuggestionsOnlyOnDemand"
                 β”‚ β”‚ β”œβ”€2748 "/opt/Discord/Discord --type=utility --utility-sub-type=network.mojom.NetworkService --lang=en-GB --service-sandbox-type=none --crashpad-handler-pid=2710 --enable-crash-reporter=88b141fa-1536-4547-84ee-028d859195ab,no_channel --user-data-dir=/home/chris/.config/discord --standard-schemes --secure-schemes=disclip --bypasscsp-schemes --cors-schemes --fetch-schemes=disclip --service-worker-schemes --streaming-schemes --shared-files=v8_context_snapshot_data:100 --field-trial-handle=0,i,8393889450872579866,8767442095313646817,131072 --disable-features=HardwareMediaKeyHandling,MediaSessionService,SpareRendererForSitePerProcess,WinRetrieveSuggestionsOnlyOnDemand"
                 β”‚ β”‚ β”œβ”€2781 "/opt/Discord/Discord --type=broker"
                 β”‚ β”‚ β”œβ”€2813 "/opt/Discord/Discord --type=renderer --crashpad-handler-pid=2710 --enable-crash-reporter=88b141fa-1536-4547-84ee-028d859195ab,no_channel --user-data-dir=/home/chris/.config/discord --standard-schemes --secure-schemes=disclip --bypasscsp-schemes --cors-schemes --fetch-schemes=disclip --service-worker-schemes --streaming-schemes --app-path=/opt/Discord/resources/app.asar --no-sandbox --no-zygote --autoplay-policy=no-user-gesture-required --lang=en-GB --num-raster-threads=2 --enable-main-frame-before-activation --renderer-client-id=6 --time-ticks-at-unix-epoch=-1709062648037669 --launch-time-ticks=62886608 --shared-files=v8_context_snapshot_data:100 --field-trial-handle=0,i,8393889450872579866,8767442095313646817,131072 --disable-features=HardwareMediaKeyHandling,MediaSessionService,SpareRendererForSitePerProcess,WinRetrieveSuggestionsOnlyOnDemand --enable-node-leakage-in-renderers"
                 β”‚ β”‚ └─2989 "/opt/Discord/Discord --type=utility --utility-sub-type=audio.mojom.AudioService --lang=en-GB --service-sandbox-type=none --crashpad-handler-pid=2710 --enable-crash-reporter=88b141fa-1536-4547-84ee-028d859195ab,no_channel --user-data-dir=/home/chris/.config/discord --standard-schemes --secure-schemes=disclip --bypasscsp-schemes --cors-schemes --fetch-schemes=disclip --service-worker-schemes --streaming-schemes --shared-files=v8_context_snapshot_data:100 --field-trial-handle=0,i,8393889450872579866,8767442095313646817,131072 --disable-features=HardwareMediaKeyHandling,MediaSessionService,SpareRendererForSitePerProcess,WinRetrieveSuggestionsOnlyOnDemand"
                 β”‚ β”œβ”€app-dbus\x2d:1.56\x2dorg.a11y.atspi.Registry.slice
                 β”‚ β”‚ └─dbus-:1.56-org.a11y.atspi.Registry@0.service
                 β”‚ β”‚   └─2053 /usr/lib/at-spi2-registryd --use-gnome-session
                 β”‚ β”œβ”€app-firefox-f1bcfc41dff64cf8aba6ee3ca4f4c3e5.scope
                 β”‚ β”‚ β”œβ”€5581 /usr/lib/firefox/firefox
                 β”‚ β”‚ β”œβ”€5660 /usr/lib/firefox/firefox -contentproc -parentBuildID 20240219145322 -prefsLen 36631 -prefMapSize 238547 -appDir /usr/lib/firefox/browser {a306bca7-b299-4ec0-ba87-d1aa7d7aafd1} 5581 true socket
                 β”‚ β”‚ β”œβ”€5678 /usr/lib/firefox/firefox -contentproc -childID 1 -isForBrowser -prefsLen 36772 -prefMapSize 238547 -jsInitLen 235124 -parentBuildID 20240219145322 -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appDir /usr/lib/firefox/browser {ee2ecc0c-df0d-4609-97e7-cb6615b59910} 5581 true tab
                 β”‚ β”‚ β”œβ”€5735 /usr/lib/firefox/firefox -contentproc -childID 2 -isForBrowser -prefsLen 41916 -prefMapSize 238547 -jsInitLen 235124 -parentBuildID 20240219145322 -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appDir /usr/lib/firefox/browser {18d10266-1a75-458e-a6b3-ce51f2a561ff} 5581 true tab
                 β”‚ β”‚ β”œβ”€5803 /usr/lib/firefox/firefox -contentproc -parentBuildID 20240219145322 -sandboxingKind 0 -prefsLen 42010 -prefMapSize 238547 -appDir /usr/lib/firefox/browser {0794c6ec-367e-4e80-955a-bd7f02d52342} 5581 true utility
                 β”‚ β”‚ β”œβ”€5809 /usr/lib/firefox/firefox -contentproc -childID 3 -isForBrowser -prefsLen 32539 -prefMapSize 238547 -jsInitLen 235124 -parentBuildID 20240219145322 -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appDir /usr/lib/firefox/browser {db8a9207-ec84-4ee5-b42f-bac6b2fc2a77} 5581 true tab
                 β”‚ β”‚ β”œβ”€5829 /usr/lib/firefox/firefox -contentproc -childID 4 -isForBrowser -prefsLen 32539 -prefMapSize 238547 -jsInitLen 235124 -parentBuildID 20240219145322 -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appDir /usr/lib/firefox/browser {03e29eb4-b16d-48ea-9dee-221ecd1707b9} 5581 true tab
                 β”‚ β”‚ β”œβ”€5833 /usr/lib/firefox/firefox -contentproc -childID 5 -isForBrowser -prefsLen 32539 -prefMapSize 238547 -jsInitLen 235124 -parentBuildID 20240219145322 -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appDir /usr/lib/firefox/browser {51f43ccb-6f45-44c5-8c9d-228767242fdd} 5581 true tab
                 β”‚ β”‚ β”œβ”€5919 /usr/lib/firefox/firefox -contentproc -childID 6 -isForBrowser -prefsLen 32539 -prefMapSize 238547 -jsInitLen 235124 -parentBuildID 20240219145322 -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appDir /usr/lib/firefox/browser {0301d5e7-5586-4e9c-a766-b309280fb966} 5581 true tab
                 β”‚ β”‚ └─5955 /usr/lib/firefox/firefox -contentproc -childID 7 -isForBrowser -prefsLen 32539 -prefMapSize 238547 -jsInitLen 235124 -parentBuildID 20240219145322 -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appDir /usr/lib/firefox/browser {b6ee375c-fe0f-45ef-8db8-f1e1a8ae356e} 5581 true tab
                 β”‚ β”œβ”€app-geoclue\x2ddemo\x2dagent@autostart.service
                 β”‚ β”‚ └─1712 /usr/lib/geoclue-2.0/demos/agent
                 β”‚ β”œβ”€app-jetbrains\x2dtoolbox@autostart.service
                 β”‚ β”‚ β”œβ”€1673 ./jetbrains-toolbox --minimize
                 β”‚ β”‚ └─1691 /home/chris/.local/share/JetBrains/Toolbox/bin/jetbrains-toolbox --minimize
                 β”‚ β”œβ”€app-kaccess@autostart.service
                 β”‚ β”‚ └─1713 /usr/bin/kaccess
                 β”‚ β”œβ”€app-msm_kde_notifier@autostart.service
                 β”‚ β”‚ └─1679 /usr/bin/msm_kde_notifier
                 β”‚ β”œβ”€app-org.kde.kdeconnect.daemon@autostart.service
                 β”‚ β”‚ └─1680 /usr/lib/kdeconnectd
                 β”‚ β”œβ”€app-org.kde.konsole-6034364a57e74a2c84efc59515607d29.scope
                 β”‚ β”‚ β”œβ”€4958 /usr/bin/konsole
                 β”‚ β”‚ β”œβ”€4966 /bin/bash
                 β”‚ β”‚ └─6075 systemctl status
                 β”‚ β”œβ”€app-pamac\x2dtray\x2dplasma@autostart.service
                 β”‚ β”‚ └─1716 /usr/bin/pamac-tray-plasma
                 β”‚ └─dconf.service
                 β”‚   └─1543 /usr/lib/dconf-service
                 β”‚ β”œβ”€kde-baloo.service
                 β”‚ β”‚ └─1455 /usr/lib/baloo_file
                 β”‚ β”œβ”€plasma-baloorunner.service
                 β”‚ β”‚ └─2078 /usr/lib/baloorunner
                 β”‚ β”œβ”€plasma-gmenudbusmenuproxy.service
                 β”‚ β”‚ └─1564 /usr/bin/gmenudbusmenuproxy
                 β”‚ β”œβ”€plasma-kactivitymanagerd.service
                 β”‚ β”‚ └─1560 /usr/lib/kactivitymanagerd
                 β”‚ β”œβ”€plasma-kglobalaccel.service
                 β”‚ β”‚ └─1513 /usr/bin/kglobalaccel5
                 β”‚ β”œβ”€plasma-kscreen.service
                 β”‚ β”‚ └─1561 /usr/lib/kf5/kscreen_backend_launcher
                 β”‚ β”œβ”€plasma-polkit-agent.service
                 β”‚ β”‚ └─1566 /usr/lib/polkit-kde-authentication-agent-1
                 β”‚ β”œβ”€plasma-powerdevil.service
                 β”‚ β”‚ └─1567 /usr/lib/org_kde_powerdevil
                 β”‚ └─plasma-xembedsniproxy.service
                 β”‚   └─1569 /usr/bin/xembedsniproxy
                 β”‚ β”œβ”€1409 /usr/lib/systemd/systemd --user
                 β”‚ └─1411 "(sd-pam)"
                   β”‚ β”œβ”€2045 /usr/lib/at-spi-bus-launcher
                   β”‚ β”œβ”€2051 /usr/bin/dbus-broker-launch --config-file=/usr/share/defaults/at-spi2/accessibility.conf --scope user
                   β”‚ └─2052 dbus-broker --log 4 --controller 9 --machine-id 51e6aae056ed433e9f46134ad97ebb73 --max-bytes 100000000000000 --max-fds 6400000 --max-matches 5000000000
                   β”‚ β”œβ”€1437 /usr/bin/dbus-broker-launch --scope user
                   β”‚ └─1438 dbus-broker --log 4 --controller 10 --machine-id 51e6aae056ed433e9f46134ad97ebb73 --max-bytes 100000000000000 --max-fds 25000000000000 --max-matches 5000000000
                   β”‚ └─1616 /usr/bin/pipewire-media-session
                   β”‚ └─1615 /usr/bin/pipewire
                   β”‚ └─1495 /usr/bin/kded5
                   β”‚ └─1493 /usr/bin/ksmserver
                   β”‚ └─1496 /usr/bin/kwin_x11 --replace
                   β”‚ └─1533 /usr/bin/plasmashell --no-respawn
                   β”‚ └─1568 /usr/lib/xdg-desktop-portal-kde
                   β”‚ β”œβ”€1725 /usr/bin/pulseaudio --daemonize=no --log-target=journal
                   β”‚ └─1777 /usr/lib/pulse/gsettings-helper
                   β”‚ └─1458 /usr/lib/xdg-desktop-portal
                   β”‚ β”œβ”€1465 /usr/lib/xdg-document-portal
                   β”‚ └─1481 fusermount3 -o rw,nosuid,nodev,fsname=portal,auto_unmount,subtype=portal -- /run/user/1000/doc
                     └─1470 /usr/lib/xdg-permission-store

Cant see anything out of the ordinary from this

I am not sure too, but at least when i look at the uuids, it seems like the hard drive is the culprit.

Does that drive even exist?

lsblk -f

for instance …

Yes, the drive does exist

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=2210-1829                            /boot/efi      vfat    umask=0077 0 2
UUID=596ccf09-452e-4d9f-ae91-0bee75c40a13 /              ext4    defaults,noatime 0 1
UUID=cc1265a1-3a30-4626-8605-ccf1db077266 /data          ext4    defaults 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

Its a 2tb HDD (probabbly should have posted this at the start, but o well)

[chris@chris ~]$ lsblk -f
NAME        FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
sda         ext4   1.0         cc1265a1-3a30-4626-8605-ccf1db077266    1.2T    26% /data
β”œβ”€nvme0n1p1 vfat   FAT32       2210-1829                             273.8M     9% /boot/efi
β”œβ”€nvme0n1p2 ext4   1.0         596ccf09-452e-4d9f-ae91-0bee75c40a13                
β”œβ”€nvme0n1p3 ntfs               A4FC5C6CFC5C3B2E                                    
└─nvme0n1p4 ext4   1.0         7979a6d6-d005-47e1-ad73-56e8f5bef7ab  552.4G    28% /

… a drive without a partition? The whole drive? with a ext4 file system on it?

Honestly I dont remember how I set it up, it was quite a while ago, is there a command I should be aware of to see this info?

… to me, the command shows that there is no partition on the drive
but it is formatted as ext4

I really don’t know what to make of it - how to process that information. :person_shrugging:

Can you access the data?
In that case I’d back it up …

Yep, can access, write to it and use it fine, havent had any issues with it for the year or so ive been using it :person_shrugging:

… it looks odd - and it certainly isn’t β€œstandard” to have a whole device hold a file system
instead of the device, holding a partition, holding a file system.
That may be the reason for the check taking so long or even eventually failing or just being aborted.
But that is speculation.

it was this:
lsblk -f

[chris@chris ~]$ lsblk -f
NAME        FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
sda         ext4   1.0         cc1265a1-3a30-4626-8605-ccf1db077266    1.2T    26% /data

compare with the other drive (an nvme)
there are several partitions on it, a file system on each one (ext4, ntfs, vfat)

A thought occured, something important to note is that the startup time does varey alot, sometimes its basically instant, other times its like 10 minutes.

So the drive in question I do have a timeshift backup making daily backups to. Im not exactly sure how timeshift works. but is it possible when it hasnt made a backup today it makes one when I turn my pc on, hence the 5 min delay? Again I have no idea how the backups work under the hood

The (error)message is from systemd-fsck
So, no:
nothing to do with timeshift - not at this early stage of boot for sure

You should probably use your backup to restore the data
after you created a partition (and a file system on it) on that drive.

adapt /etc/fstab after this

There is the program tune2fs
With it, you can set, for example, max. nr. of mounts before a file system check is forced.
(it’s a feature of the file system, not of some external service …)

The systemd service will just check the file system (and attempt to repair it) when it is β€œdirty”.

It is not entirely impossible that is just a misconfiguration. I mean, that somewhere is set a config or a service to check the drive every boot, instead only if there is a problem, or every 20th boot for example. But i am not sure how to check that.

You should probably use your backup to restore the data
after you created a partition (and a file system on it) on that drive.

Ive been using this drive for like a year, I dont have backups that far back.

… you just need a recent one - who wants to restore from an ancient backup :wink:
… create one now, for instance

Sorry, I think I misunderstood, you were saying to repartition (or in this case just partition) the drive, and then restore the data from a backup.

I thought you were saying I should restore my manjaro pc from before I was using the drive, which in retrospect doesnt make much sence.

Ill give this a go tomorrow, and see what happens

… I was just saying/noticing that a file system directly on a device,
instead of on a partition on a device,
is not common practice and something I have never seen.

I know that I accidentally tried to do that - and that I was warned about it by the program I tried to do it with …
after all - you yourself would have to have created the ext4 file system on the device
you’d for sure have gotten a warning at that point

It obviously works anyway - but this uncommon thing might be the reason for this delay.

Honestly I dont remember having any warnings or any issues at all, iirc I just formatted it via cli, and it just worked fine from there :person_shrugging:

You are correct - I just tested it in a VM
There was no warning - it just created the file system on the device with no partition,
no question asked, no warning, nothing

I remembered that differently.