Manjaro Sway Installation doesn't recognize default username and password in setup

I was able to easily install Manjaro Sway onto my Raspberry Pi 400, but when I tried to create a VM of it on Oracle, the Manjaro Setup brings me to a screen that asks for me to authenticate into manjaro sway.

I enter the default username and password, both ‘manjaro’ and it keeps on recursively bringing me back to the same authentication prompt.

I’ve been searching all over the github and the forums here trying to see if there’s a different default username and password, but I’m getting nothing.

Any insights? Thanks in advance.

The default passwords are

  • root:manjaro
  • manjaro:manjaro

Sway is based on the Wayland so the first that comes to mind is some kind of issue with the graphics.

One option you could try is to edit the kernel arguments and for the kernel add the digit 3 to boot the console only. Then login and run startx.

Another option you could try is a tip I read for vmware products editing the boot arguments for the display driver used - replacing driver=free with driver=mesa.


the arm team said the images are not made for vm in a another thread.

off topic:
on your pi400 install, have you been able to change the theme?
i don’t like dark themes & tried to edit the gtk# files, but something changes it back.

never mind, just found it. lol

1 Like

Yes, I figured the ARM version wouldn’t work in a VM, although I’ve heard of some being able to run raspbian in a VM…

Anywho, it could be some problem with the graphics as the Sysadmin said above, thanks for the insight.

And yes, you can change the theme through a GUI, just hit ALT + D, and take a look around, you’ll find the settings.

yeah, tried all. even the user config. it’s just unstable. I’ll probably blow it away & start from scratch.

right now i’m using i3+xfce4-panel & it’s solid, just works.

You absolutely got that right :grin:

There is an effort to create community build using sway - after all you are not posting in the ARM category - so I figured you were trying the real ISO hence my comments.

1 Like

Thank you for the extensive answer, although I’ll admit I’m not exactly sure how to get to those kernel arguments, etc… or how to run startx.

I’m assuming I must somehow exit the setup? Every time I try and do that, it also recursively brings me back to the setup page…

I’ve been having alot of trouble with these community builds in vms. I also tried to install i3 prebuilt manjaro and while I did get to the GUI TWM, it wouldn’t allow me to save any preferences, every time I rebooted the VM after completing the installation setup, it would just bring me back to the setup, having saved nothing…

Is there a thread that you could point me to to possibly setting up a TWM like i3 in conjunction with my current xfce environment?

I’ve heard there are issues with installing a twm on top of a de, and am very reluctant to change what already works, but I was just very impressed with the workflow of sway and am getting into more vim like commands across my systems and would like to integrate a more “mouse free” style of workflow wherever possible.

This is possible with xfce, but my assumption would be that a twm like i3 or sway is better as it is designed to get away from using the mouse more or less entirely…

I know that was long, but I hope anyone can give me some insight into this.

Thanks in advance, and sorry for the long post.

Editing the kernel command line is easy - just press e on the line in GRUB when editing is done press F10 to continue booting.

1 Like

Thank you…I’ve got to grab some zs now, but will continue this installation attempt when I wake up.

Seriously, great community here. Thank you.