Manjaro suddenly not found as bootable OS after BIOS problem

Hey everone :slight_smile:

After accidentally entering the BIOS password wrong 3 times I seemingly can’t boot into Manjaro anymore (dual boot Acer laptop, UEFI, with windows originally). I managed to get an access code to enter into BIOS and once again enable “F12 on startup to enter boot selection” (or similar sounding option).

When entering the boot selector menu before windows boots only the windows boot manager is available as an option. When I originally installed Manjaro another boot manager was automatically selected as the default startup option (don’t remember what it is called) but I can no longer find it.

Windows diskmgmt utility can see the 100GB partition I use for storage with the Manjaro instance, one 1GB recovery partition I think is a Windows thing and a 4GB unallocated partition which migh be from when I tried making a swap partition.

I’m at a loss to why UEFI suddenly can’t find the Linux OS. Any help is appreciated

Hi @AxBaEn, and welcome!

I’d suggest you boot into a live, environment, enter a chroot environment from there, and follow this:

How to chroot

  1. Ensure you’ve got a relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot encironment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart.

but before using @Mirdarthos tip check your bios settings. maybe this procedure caused a reset of the bios settings. make sure that “fast boot / secure boot” is disabled and the bios settings match to the previous values .


This did the trick temporarily!

I found that the boot manager from a USB drive with an ISO live environment on it could find and boot the EFI.

  • “manjaro-chroot -a” didn’t find the Linux system
  • I followed the guide you sent, “lsblk -o PATH,PTTYPE,PARTTYPE,FSTYPE,PARTTYPENAME” found the EFI partition as /dev/sda2
  • did the “Chroot enironment > Manual chroot” steps to mount the EFI partition on temporary mount point
    *did the “Reinstall Grub > EFI System” steps but nothing came up with command “modprobe efivarfs” so I didn’t try to mount that filesystem in later step

After this the Grub bootloader were recognized in the BIOS as and could be selected. I booted successfully without USB. After then trying to enter the BIOS boot selector to go into Windows it was no longer an option. At that point the default behavior was to launch Manjaro straight away without the option to choose Windows with a timer.

Can you from this understand where I went wrong?

Sadly, no.

I had dual boot a long time ago, now I only have Linux, so don’t know what’s going on, where.

You need to tell GRUB what to do

You find these infos at:

Pretty sure the modprobe efivarfs command doesn’t return anything on success.

So after running that command you should have then followed the last steps to the guide.