Manjaro Stuck after clean installation

Hi, so I have been using Linux from a while and today wanted to try Manjaro, download with gnome de but at first it didn’t boot at all I tried MBR, GPT both but it wouldn’t boot I tried separate and combined boot, root partition but nothing then I enable UEFI but still nothing the installation completed fine but didn’t boot into Manjaro now I tried auto partitioning it did boot but after after filling the details i.e password and timezones etc when I click on start using manjaro it’s just stuck here.!

I even restarted and it asked me the same details again.

Please take a look at the forum articles about how to supply information about your particular environment and the specific procedure you are using to build an installation. Also, take a look at this guide:
I suggest the guide because you mention trying what seems to be a single partition installation. That will not work for ARM architecture and maybe not for others, too. The guide does not mention the possibility of a single partition solution. It is hard to offer specific advice without being supplied greater detail.