Manjaro refusing to boot due to an incorrect UUID

Hey everyone,

I’ve been using Manjaro on my laptop consistently for about a year and a half now with no issues, and suddenly about a week ago I turned the computer on and it refused to boot, giving the following error:

ERROR: resume: hibernation device ‘UUID=XXX’ not found
ERROR: device ‘UUID=XXX’ not found. Skipping fsck.
mount: /new_root: can’t find UUID=XXX.
You are now being dropped into an emergency shell.
sh: can’t access tty: job control turned off

None of the fixes I’ve found from other people with the same issue seem to work for me. I’m able to boot from a USB perfectly fine, and my SSD is detected; however, when I try to mount it from the live installation, there are no accessible files in there. It’s just a recycle bin and some empty config folders. I’ve also tried chrooting into the drive, and that doesn’t work either. It’s always some sort of error.

The strange thing is that when I put my drive in another computer, it works perfectly fine as if there were never any issue, and I can access all my files. It’s only my specific laptop that seems to have the issue. I mess around with computers as a hobby but am far from an expert, and feel like there might be something simple I’m missing, since I don’t entirely understand how the whole boot process works or what files I should try to change. /etc/fstab and /etc/default/grub don’t seem to contain anything pointing to these incorrect UUID’s, so I’m not sure where it’s getting them from.

Would anyone be able to provide some advice or recommendations as to how I should approach this? From my testing so far I’m almost certain it has to be some sort of problem with grub or the bios since it worked perfectly fine when I tested my ssd in a friend’s laptop.


maybe a messed up update?..
also what errors do you get when you try to chroot?
post the output here…

is it a dual boot? maybe windows changed some bios/uefi settings after some update?

I had the same error using the LTS kernel 6.1.38 after the last updates, the fallback option for it in grub booted fine though.
Never figured out how to use the default option for it again, I installed 6.3.13 and that has been booting and running fine since.

One thing I did see but never got round to trying was related to an option in the UEFI settings, changing the XHCI mode seemed to fix the problem for some people. I don’t remember the details but it might be worth a search for the error and XHCI mode to see if that sounds promising.