Manjaro Plasma KDE is laggy

Hello everyone,

While there’s hundreds of similar topics to the forum, I wasn’t able to find any solution to my problem. I’ve been using Manjaro daily for the last few years without any problems. A few months ago I builded my own desktop PC (system specs bellow) and from that moment until this day, I am still unable to make it run smoother and faster.

When opening/closing any windows, the KDE menu, or even a browser, everything’s lagging. It’s just not a smooth experience compared to Windows 10/11 and Manjaro Gnome & XFCE - they all run smooth.

PC Specs:

  • Intel Core i5-9600K
  • Nvidia GeForce 650 Ti (2GB)
  • Corsair Vengeance LPX 16GB DDR4 RAM
  • Samsung 970 Evo Plus SSD 500GB M.2 NVMe PCI Express 3.0
  • Xiaomi Mi Curved 34" 4K (Screen)

Besides the graphics card which is pretty old, anything else should provide me with a smooth experience, and the same I get from other distros or operating systems. Any ideas what should I do to make KDE run smoother?

Btw that happens to any new and fresh installations. I haven’t changed anything. Running KDE from a live USB is also smoother than running it installed from my PC. And even videos with high-resolution are lagging (both from saved videos and YouTube videos - none of the players/browsers I’ve used worked).

Hi there. Sorry to hear you are experiencing a laggy KDE experience at the moment. With that set-up, it should be snappy. Can you provide some further information, like whether you are using open source or proprietary drivers, kernel etc. The more information you provide, the more people will be able to assist you. I’m not a techie but I would expect your Live USB experience to mirror what you would get installed. Also, have you tried reinstalling? You have plenty of RAM also. Hopefully someone can assist you. Thanks, Ruziel :slight_smile:

1 Like

Are you using the proprietary driver? NVIDIA - ArchWiki check your Xorg config and try the suggested modifications. do you have options nvidia_drm modeset=1 set? You can also use the options as seen below without the monitor section obviously (note it’s very old now, but the flags should be the same). The parameters shown under sections Device and Screen:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 396.54  (buildmeister@swio-display-x64-rhel04-14)  Wed Aug 15 00:21:19 PDT 2018

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    Modeline "1920x1080_143.85"  452.00  1920 2088 2296 2672  1080 1083 1088 1177 -hsync +vsync
    ModelName      "Acer ED242QR"
    HorizSync       30.0 - 160.0
    VertRefresh     56.0 - 144.0
    Option         "DPMS"


Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce RTX 2060"
    Option "UseEDIDFreqs" "FALSE"
    Option "NoBandWidthTest" "TRUE"
    Option "ExactModeTimingsDVI" "TRUE"
    Option "ModeValidation" "AllowNonEdidModes, NoMaxPClkCheck, NoVertRefreshCheck, NoHorizSyncCheck, NoEdidMaxPClkCheck"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On}"
    Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
1 Like

I tend to think the video card not the video driver. Personally I wouldn’t run any 4k monitor on anything lower than a 750 with 4gigs GDDR.

If the same GPU runs well in Windows, Gnome and XFCE, then it’s not the issue.

1 Like

I use Plasma 5 since 5.3, so almost 8 years and I don’t have this issue, although I run the same, old gaming laptop (Alienware R17).

There has to be something in your configuration.

The first thing I would do is to run system manager and observe system resources. Is CPU overly busy? If so, which process? Or maybe this is a periodic occurrence? Again, what is the cause?

If the issue isn’t findable in system resources, there is a high chance it is something with graphical setup.

Also, 4K monitor for such old GPU? This doesn’t sound reasonable and could be the main source of the problem. Change the monitor (or lower resolution) and see if lagging persists or not.

Ah, one more thing. Create a new, test user. Log in and see if the problem occurs there as well. If not, the issue is with configs (user settings). If you can still see it, it’s the hardware and main system setup.

Are you keeping the same user configurations across OS installations? Do you keep them under a separated partition in /home? That could explain why a live USB is smoother.

If this is an issue with too weak GPU for the screen (4K), than it will be present for all new installs.

By changing the options for nvidia_drm modeset=1 actually help the smoothness of the operating system a lot. But it was still a bit laggy, so I changed the open source drivers with the proprietary drivers and things are looking way better now.

I’ve also upgraded my RAM to 48GB (but I didn’t do it before making the changes described above) and it got even faster (expected). I think that was the final solution to my problem, thank you everyone for helping me solve it!

1 Like

While I provided the solution, changing the drivers from open source to proprietary helped a lot. Thank you for taking the time to help!


Hey @meymigrou - I’m glad to hear you found a solution. Hopefully you enjoy the Manjaro flavour for a while. More power to you. R :slight_smile:


Its is widely understood that the only way to get the most out of an nvidia card is to use the proprietary drivers. The open driver (nouveau) is reverse-engineered, and simply cant measure up. The only real situation in which it would be useful/preferred is when your card is no longer supported by nvidia.
(dont worry … it wont be long … they usually only support them for ~3 to ~5 years maximum :sweat_smile:)

1 Like

Thank you for providing more insights about the topic! I wonder; why is Manjaro using by default the open-source drivers if the proprietary drivers work better?

mhwd will happilly install non-free drivers pretty automagically … but its never, as far as I recall, been made to work and apply itself automatically (maybe there was an exception with that one broadcom driver).
And of course, assuming there is no magic application, nouveau will work on far more hardware setups than even the last 3 nvidia major release cycles combined.

Lets try that again Manjaro was using the Proprietary drivers then chose to leave it up to the end user.

Don’t worry, KDE has been laggy on my 4090 since installing it as well.

Where do you get that info? Everything I’ve read and based on my own experience, it’s more like 8 - 10 years.

Its what I remember from one of the last great purges … when 345 was discontinued?

Then again … looking at Support timeframes for Unix legacy GPU releases | NVIDIA it appears they eventually did fix up some of the old drivers for the newer xorg and kernels … so maybe its a low ball and folks could have squeezed ~8 years out of their quadro card if they refused to upgrade nvidia or xorg for a while, then did a pkg-ignore along with partial upgrades.

That doesnt sound attractive, and I dont suggest it. But it really does appear they at least nominally support more cards for longer … I wonder if thats in relation to any other market news :thinking:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.