Manjaro only starting in emergency mode (dual boot, "dependency failed for /home")

Hey all,
I am a newbie more or less. But have been having lots of fun with manjaro, which I managed to dual boot on a windows 10 asus laptop many months ago.
The thing is, I can’t boot into manjaro after installing the latest kernel update.

I’ve tried a few commands to see what’s up, but seeing as I am a mindless newbie, I don’t see what to do based on that. I can’t post images nor links, so I cant really share what it all looks like.

I’ve also tried to use manjaro-chroot -a from a boot usb, but that didn’t go well at all.

Any idea what to do? how to fix that?

not enough information :wink:
It could be that a filesystem check will remedy the situation.

  • boot your USB system
  • know which filesystem is on which partition
    lsblk -f
    sudo blkid
    should help
  • run
    e2fsck -v /dev/sdxX
    on your home partition - and on the other ext4 partitions as well, for good measure and while you are at it
  • reboot and see whether that helped
    If e2sfck found and fixed errors then that was the likely reason.
1 Like

Thank you, I’ll make a windows image just in case ad will try out everything you’ve mentioned + report back ASAP. :slight_smile: appreciate your help.

Windows will not be affected by this - it’s just a filesystem check that will not even run on a windows partition, even if you accidentally tried.

what did you get on this message ?
you can repair for USB live manjaro

Did it still just in case for the future.

Used the Konsole in the usb system. Did e2fsck on a ext4 partition, and got this:

sudo e2fsck -v /dev/sda4

/dev/sda4 contains a file system with errors, check forced.
Pass 1: Checking inodes, blocks, and sizes
Inode 787409 seems to contain garbage. Clear?

the other ext4 seems alright: /dev/sda5: clean, 422756/2564096 files, 6983353/10240000 blocks

Rebooted, still emergency mode. Says “failed to start system5…
Dependency failed for /home
Dependency failed for Local File Systems”


… well:
did you say yes? or no?
If you said no - or did nothing
the filesystem is still corrupted/dirty

run the command as:
sudo e2fsck -y /dev/sda4

It will repair it if it can be done, no questions asked.

Question - because it wasn’t clear:
is /dev/sda4 your /home partition?


Ohhh :o it worked, I said yes to all, and now my system is back! You are a (very patient) wizard! Thank you so so much!

… not a wizard - just some experience :wink:


Now - when you are back in your now up and running system
it’s time to take some measures to keep this from happening again:

sudo tune2fs -c 20 /dev/sdaX

on every partition that is a Linux ext4 filesystem, where X denominates your partition number.
It will have the filesystem force-checked after it has been mounted 20 times without a check.
This check is quick, as you noticed - just a few seconds every 20 boots …


Thank you, will do. e2fsck and tunef2s man pages go completely over my head, wouldn’t know what to do without your help. Thank you again.

they can be quite arcane, especially if none of what they (very accurately) try to explain bears no context whatsoever to you as the reader
… experience / time - and context and understanding will build, the dot’s will start to connect :wink:
as is the case with every skill, with everything new

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.