Manjaro on VirtualBox, installer closes

Hello everyone, i need your help please, i’m having a problem installing “Manjaro 22.0.4 Sikaris” on VirtualBox, after i add Manjaro to VirtualBox i run it and begin the installation, as soon as i click the “install now” button the installer window closes and nothing happens, i’ve tried both KDE and Gnome, can anyone please help me.

Increase the ram allocation to 4G.

It is a known issue with the installer rocket lauincher slideshow and the size of the ISO.

The ISO is > 3GB and is unpacked to RAM so if there is not enough the OOM killer steps in.

You may find the following topic helpful

1 Like


You should check how the VM is configured. Works perfect every time on my end with this settings:

  • Operating System: Arch Linux (64-bit)
  • Base Memory: 4096 MB minimum
  • Graphics Controller: VBoxSVGA and more than the default Video Memory
  • Virtual HDD at least 20,00 GB

Thank you guys for answering, yes it was a RAM issue i gave it 3Gb and now it’s installing for both KDe and GNOME, but i’ve seen people on YouTube doing it with only 2Gb RAM that’s why i did not suspect it at the beginning, Thanks again :slight_smile:

One more question please, is it ok to change those 3Gb RAM back to 2Gb after the installation is done ?

stick to the advise that was given in this topic. If only opening a browser like firefox you can see the increasing amount of consumed memory. When you open a few other apps perhaps there will be no memory left :wink: