Manjaro on VirtualBox 7.0.6

newbee: I installed manjaro 22.0.3 with XFCE on VBox 7.0.6. lsmod tells, Guest Additions were installed automatically. Can I expect resizing of the XFCE screen as I resize the VM window?

Install virtualbox-guest-utils on the Guest OS to achieve proper scaling on guest OS

Some reading:

Thank you jrichard325 - I read the VirtualBox article, chapter Selecting a Display Controller. Led me to experiment.
It works now for me, but not as described.
In the VM settings, when I select VboxVGA it will not resize. When I select VMSVGA instead, manjaro does not start up, displaying the 3 waiting points all the time. (not selecting 3D acceleration in either trial.)
The solution I found by experiment is: Start manjaro with the display VBoxVGA, open a terminal window and enter “sudo VBoxClient --vmsvga” as described here.
Strange - isn’t it?

What about VboxSVGA? It just work by default, you don’t need to do anything.

Something in your setup isn’t right. There should be no reason to have to enter sudo VBoxClient–vmsvga to make VMSVGA work. I don’t have Manjaro installed as a guest, but I do have Arch and EndeavourOS installed as guests. Both are set at VMSVGA in display settings and in both instances the setting persists. On both the Enable 3D Acceleration are unchecked. All the other display options for the two Arch based distros result in “Invalid Settings Detected”. In both Arch-centric VM’s, virtualbox-guest-utils is installed (on guest) otherwise scaling via Ctrl-F does not work. VboxSVGA is what works here on a Windows VM.

Did you install the distribution version of virtualbox? (N/A -windows host)
Is virtualbox-ext-oracle installed? (nevermind, turns out it is a Windows host)
Are the appropriate virtualbox-host-modules installed?( N/A windows host)
Are you a member of the vboxusers group? (nevermind, turns out it is a windows host)

I guess it should have been mentioned that WINDOWS is the HOST!

The warning is just because you change the default video adapter. This is not actually a real “invalid settings error” warning. It tells you you shouldn’t need to change it, but you changed it.

I noticed random boot/noboot with the default video adapter since recently. However on multiple reboot/start I can confirm that on my side the VboxSVGA doesn’t have this random noboot (or two minutes before desktop is reached) issue.

For the Virtualbox Guest Utils it is already included in the Manjaro ISO.

1 Like

Thanks for the reply. I am hesitant to play around too much with Vbox settings (same with Samba) as I have it working the way I want on multiple units. Changing to VboxSVGA does seem like a worthwhile option to try, indeed. On my old xfce install guest-utils may not have been installed by default. It sure doesn’t look that way from looking at desktopfs-pkgs.txt and rootfs-pkgs.txt.


If it works, don’t fix it :slight_smile:

@omano: manjaro behaves the same for VBoxSVGA or VBoxVGA: I have to VBoxClient --vmsvga for resizing

  • I’ve installed from manjaro-xfce 22.0.3-230213-linux61.iso (1),
  • updated extpacks to 7.0.6 as well (2),
  • VBox host is Win10. Ubuntu, Mint and Win10 as guests running fine for long, therefore I guess, it is not about VBox installation (3), and
  • yes, my user is part of vboxsf group (4).

Note that manjaro runs in an endless loop waiting for initialization to finish, when I start it with VMSVGA. I have to ACPI Shutdown or to power down the VM.

I have put VBoxClient --vmsvga in my .profile. Works now automatically at restart.

There is something off with your host installation.

Manjaro as guest works OOB using VirtualBox with vmsvga - there is no need to implement such command to get guest resizing.

What is your host os?


It is Win10.
Note that manjaro starts with VMSVGA. But it runs in an endless loop waiting for initialization to finish. It shows a black screen with 3 points flashing. I guess, if I overcome that problem, it would solve the resizing problem as well.

This must be a Windows 10 quirk.

It works without issues with Manjaro host system.

It is not normal behaviour - I cannot say what or why - if your quirk works - great :+1:

For the record - I have tested on a Windows host running Microsoft Server 2022.

Using VirtualBox 7.0.6.r155176 and current Xfce ISO (manjaro-xfce-22.0.3-minimal-230213-linux61.iso) - the default VMSVGA (16MB VRAM) works OOB - guest resizing and all - no quirks or tweaks applied.

My initial conclusion - it is something local to your system - but I have no idea what or why.

1 Like

Thank you so far, linux-aarhus.
I have re-installed VirtualBox and its extentions on Win10 as the host, than re-installed manjaro as a VM.
Now, it resizes fine, but only if I select VBoxSVGA or VBoxVGA as the Graphics Controller for the VM and add VBoxClient vmsvga to .profile.

I am a t loss here - one side it is great you can work around it - on the other side it is a really strange issue.

Several years ago - there was huff&puff with virtualbox where one had to use vboxsvga to get guest resizing - but upstream virtualbox stated very clearly that vboxsvga and vboxvga was intended for windows guests and vmsvga was for linux guests.

They even went as far as making it impossible to save the vm if you had your guest os as linux and graphics set to vboxsvga - in that regard they changed it upon save so it reverted to vmsvga.

You could trick the virtualbox service to load using vboxsvga by using the overview pane and modifying the graphics directly - which would than save the wrong graphics. The next time you openend the vm properties it would be set back to what the vbox devs.meanit it to be.

So - yes - over time there has been various quirks to get vbox working correctly on Arch and by inheritance Manjaro - but now it works.

Back then there was also some functionality which was moved to be included in the kernel - but frankly I don’t remember specifically - perhaps it was around 2018-19 roughly…

What is sure is that my recent VM installation of Manjaro, on Manjaro, has issues, might be related to that Plymouth thing you recently added, I don’t know. Sometimes it doesn’t boot, sometimes it boots after a couple minutes. I switched to VBoxSVGA it just works. If needed I can spend time to collect relevant info, do deeper tests.

//EDIT: yeah, I switched my VM back to VMSVGA, it started to look it was gonna boot properly, the Plymouth thing appeared, but it is stuck on the Plymouth thingy since 3 minutes, the animation is playing it is not frozen. I closed the VM window, chose send extinction signal, the animation stopped, the VM closed properly. Tried a second boot with VMSVGA, still not booting, I then switched to VBoxSVGA it just works for me.

sudo journalctl -xb-2 -p3

févr. 24 23:51:11 aa-virtualbox systemd[1]: Invalid DMI field header.
févr. 24 23:51:12 aa-virtualbox kernel: [drm:vmw_host_printf [vmwgfx]] *ERROR* Failed to send host log message.
févr. 24 23:51:12 aa-virtualbox kernel: vboxsf: Unknown parameter 'tag'
févr. 24 23:51:12 aa-virtualbox systemd[1]: Failed to start pkgfile database update.
░░ Subject: L'unité (unit) pkgfile-update.service a échoué
░░ Defined-By: systemd
░░ Support:
░░ L'unité (unit) pkgfile-update.service a échoué, avec le résultat failed.
févr. 24 23:51:32 aa-virtualbox systemd[1]: Failed to start Terminate Plymouth Boot Screen.
░░ Subject: L'unité (unit) plymouth-quit.service a échoué
░░ Defined-By: systemd
░░ Support:
░░ L'unité (unit) plymouth-quit.service a échoué, avec le résultat failed.
févr. 24 23:51:33 aa-virtualbox sddm[435]: Failed to read display number from pipe
févr. 24 23:51:35 aa-virtualbox sddm[435]: Failed to read display number from pipe
févr. 24 23:51:37 aa-virtualbox sddm[435]: Failed to read display number from pipe
févr. 24 23:51:37 aa-virtualbox sddm[435]: Could not start Display server on vt 1


févr. 24 23:54:40 aa-virtualbox systemd-journald[252]: Journal stopped