Manjaro on Razer Blade 14 2022 - What works and what doesn't, August 2023


I recently installed Manjaro (first-time user, coming from Linux Mint / Cinnamon) on my 2022 Razer Blade 14, and wanted to give a report of how things went, what works and what doesn’t, and maybe get some pointers / direction on where to look to fix the outstanding issues. It’s my first post here, so apologies if I’m missing any information that needs to be provided.

Installation went pretty smoothly booting from USB (the bootable Manjaro full ISO USB from unetbootin didn’t work, but the one made with Balena Etcher did. The installer resized my partition for me to install alongside Windows without a hitch, and the bootloader seems to be working well.

What worked out of the box:

  • WiFi
  • Bluetooth [mostly, more on that later] speakers worked
  • Display with full resolution and 165Hz refresh

What needed attention to work:

  • I installed the latest Kernel and nvidia+amd drivers through the hardware configuration + kernel GUIs, but I still have no idea if it’s actually using the iGPU during regular use and the 3080 during load. In Linux Mint, I had a little applet in the taskbar that could switch between them. To do a test, in Lutis, I enabled render offload, and that seems to be working with most games I’ve tested (this won’t be a gaming machine but Lutris is a good way for me to test the GPU). ie Alien Isolation works perfectly, but Doom Eternal is incredibly slow, yet they are both set to offload render.

What doesn’t yet work / issues I’ve been unable to solve:

  • Possibly related to the above problem, battery life is atrocious in Manjaro vs Windows. I got about 6 hours under load in Windows, whereby I can only squeeze about 90 minutes out in Manjaro. I suspect this is related to either CPU management and/or GPU management, and being
  • Plugging in my wired headset provides sound, but it is incredibly low-volume and low-quality (all bass is absent) to the point of being unusable. A headset via bluetooth works fine. I’ve tried going into Alsactl but everything seems normal there.
  • I still haven’t figured out my way around installing Apps from AUR yet. For example, I tried installing Aftershot3Pro to manage my raw images, but it refuses at gstreamer dependency even though I have gstreamer. Same is true for most ofther apps I tried installing, even using Pamac or Pacman. I’ll have to do more reading on this.
  • I switch between languages often, but cannot get the language icon to show up in the status / notification area. So I can switch between languages using the keyboard shortcut, but not see what the current language I have selected is, which is more of an annoyance than a problem but would be nice to fix.

I consider myself an average-advanced user on Mint, but I’m a beginner on Manjaro (and Arch-based distros in general). The system is about where I expected Linux support for it to be (almost usable, minus the battery, GPU and headphone uncertainty).

I hope I can help anyone who is trying to get things running on a similar laptop, and if you can point me in the right direction to solve the headphones and battery issues, I’d be very grateful.

It should, as you are using prime drivers. To check it’s actually pretty easy:

$ glxinfo | grep - i vendor

this is on iGPU:

server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
    Vendor: AMD (0x1002)
OpenGL vendor string: AMD

and this is on dGPU:

server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

I still use optimus-manager hybrid solution (because I don’t want to logout everytime I switch GPU, besides the overhead is not that big for me as I don’t play super competitively, a 5 fps difference is negligible to me), so to get that dGPU output, I simply prefix the command with prime-run.

1 Like

Thank you!

However, when I run $ glxinfo | grep - i vendor, I get

server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
    Vendor: AMD (0x1002)
OpenGL vendor string: AMD

even when I know for a fact that the 3080 card is running (ie, I’ll load Atomic Heart using prime-run, which wouldn’t even start without it on the iGPU). So because the system is always reporting the iGPU even when the dGPU is clearly being used, I wonder if the dGPU is just on all the time - which would go a long way to explaining my battery woes.

Yes, you need to prime-run it as well to get Nvidia.

If you don’t config anything, that’s what happened by default. But indeed it doesn’t always work given any random optimus laptop, more like a gamble. You can try using optimus-manager and turn the iGPU only mode. Do note that you must not have any widget, service or anything else that monitors the dGPU (such as temperature widget with the dGPU temperature as one of the sources). Otherwise, the query to get the dGPU temperature will “wake” the dGPU.