Manjaro On Raspberry Pi 4: HDMI Not Displaying After Manjaro Logo

Hi Community,

I hope I am asking the right forum and if there is someone that can help me on this issue as I have been scrounging around the forums on the rpi foundation and manjaro forums to get my Raspberry Pi 4 working on HDMI with my monitor.

To list what I have:

  • I am using/testing Manjaro XFCE and KDE 21.04 on Raspberry Pi 4
  • I am using a 24inch Desktop monitor, a LG Flatron IPS235 (ancient I know)
    • This monitor has DVI, VGA and HDMI. I am trying to get 1080p or 1920x1080 to work but it seems that only 1080i works…temporarily
  • I made sure I am using proper HDMI cable, as I have tested 2 different types, and one of them is bad(thrown away).

What I have done:

  1. Flash the manjaro XFCE/KDE onto a sandisk 32gb microSD using balenaEtcher
  2. When done flashing, open the config file to make some modifications
  3. I save the config file and put the microSD to the PI and power it up with a proper power brick (using Canakit power supply)
  4. I see it boots up and goes to the settings where I input the keyboard, user info, password, etc.
  5. Once done setting up, the RPI goes the the sequence of setting things up and then Reboots
  6. It reboots, and I see that there is activity and pops up the Manjaro Logo, but after that, it just goes to black screen

I have been racking my brains on this for 3 days so far and in need help of how to solve this issue. Please let me know what else I need to provide to have more clarity and ease of troubleshooting. Below is the config I have set that has helped me get past the “boot up” and manjaro logo before it goes black.

** NOTE**
I am able to get it going on 1080i for some reason, but anything on 1080P or even 720P is tough to get past.
I also was able to get to a certain point when i enable hdmi_safe=1 and ACTUALLY LOG IN. However, after entering my credentials, it just goes back to black screen.

gpu_mem=64
initramfs initramfs-linux.img followkernel
kernel=kernel8.img
arm_64bit=1
disable_overscan:0=1

#enable sound
dtparam=audio=on

##### monitor/tv options 
hdmi_drive:0=2
hdmi_group:0=1
hdmi_mode:0=5
hdmi_force_hotplug:0=1
hdmi_ignore_edid:1=0xa5000080

#enable vc4
dtoverlay=vc4-fkms-v3d
max_framebuffers=2
disable_splash=1

try a different image writer.
if rpi-imager, down load image & choose custom on the bottom of rpi-imager.
don’t make no changes, just try & boot.

1 Like

Hey there, thanks for the reply! I’ll do that later tonight and give an update on your recommendation. I wanted to ask why would using rpi-imager be a possible solution? How is the rpi-imager different from the balenaEtcher program?

Try this:

##### monitor/tv options
hdmi_mode:0=16
hdmi_drive:0=2
hdmi_group:0=1
hdmi_force_mode:0=1
hdmi_ignore_edid:0=0xa5000080

If this works but you still can not go into the graphic mode then it appears it can not get the correct edid info from your monitor. Try ssh to the pi4 and install xf86-video-fbturbo-git and reboot to see if it works.

1 Like
##### monitor/tv options
hdmi_mode:0=16
hdmi_drive:0=2
hdmi_group:0=1
hdmi_force_mode:0=1
hdmi_ignore_edid:0=0xa5000080

Hi there, thanks for the reply! I believe I have tried this option before and it would not display properly, but I will give it a go again. If first option fails, I will SSH into my RPI4 and do the necessary install and try that out.

To confirm, the command to install xf86-video-fbturbo-git is this ?
sudo -Syu xf86-video-fbturbo-git

Is that the correct way of doing so? Thanks for the help and reply!

Edit:

I see mesa has updated so yes:

sudo pacman -Syu xf86-video-fbturbo-git

1 Like

If you are running the linux-raspberrypi4 kernel, your problem may be related to this: kms/RPi4: 4096x2160-30 output broken since clock request changes · Issue #4339 · raspberrypi/linux · GitHub

Does adding force_turbo=1 in config.txt help?

1 Like

Hi there, I have not used force_turbo=1 in my config, as I didn’t think I needed to boost my CPU at that time. I will add this to my config, but to clarify, should I use my current config or use Darksky config recommendation along with force_turbo=1 ?

#my current config, and including force_turbo
hdmi_drive:0=2
hdmi_group:0=1
hdmi_mode:0=5
hdmi_force_hotplug:0=1
hdmi_ignore_edid:1=0xa5000080
force_turbo=1

Or use the recommended settings from Darksky

#using Darksky recommendation, with force_turbo
hdmi_mode:0=16
hdmi_drive:0=2
hdmi_group:0=1
hdmi_force_mode:0=1
hdmi_ignore_edid:0=0xa5000080
force_turbo=1

I will attempt this later tonight, along with other things posters have told me to do.

I do not believe I had force_turbo=1 in my config example. I do not use it here.

Sorry, I meant to say “use Darksky’s recommendation, and then add force_turbo=1 after his config”.
I added force_turbo=1 after your recommendation in my example.

I have seen in the past force_turbo=1 result in corruption before sometimes and preventing the boot up process.

The config used in config.txt is used during the boot process but when it gets to loading in graphics mode then other forces take over. What it uses then is depending on what is configured for it to load up being using the kernel firmware or RPi’s and how mesa behaves. I was just having you to try the way the graphics loads by installing xf86-video-fbturbo-git.

1 Like

Understood. I guess I should hold off on using force_turbo=1 for the time being. I will go with your recommended process in:

  1. Using your recommended config(without force_turbo) and see if that makes any changes
  2. If that doesn’t work, will move onto SSH and applying the command to install the following software:
    • sudo pacman -Syu xf86-video-fbturbo-git
    • Send a reboot, and connect my HDMI cable from my desktop monitor
  3. If that does not fix anything, I’ll resort to using force_turbo=1 in my config and see if that makes any changes, or causes corruption.
  4. If all else fails, I guess I will be borrowing/purchasing a newer desktop monitor to see if that will fix the issue(hope it does not come to that yet).

Will give an update tonight once I tried the followings above.

Again, appreciate the help and the time for the support.

Adding force_turbo=1 to your config.txt is a workaround for the issue I have linked to above (which may be related to what you are experiencing) and should only be necessary if you are using Darksky’s raspberrypi4 kernel, not the mainline one (you can use pacman -Qs linux to find out which kernel you are running.) In that sense, switching to/from the raspberrypi4 kernel is also something you may want to try provided your proposed steps fail.

1 Like

All of the pi kernels in the repo is RPi tree based; No upstream.

MAJOR UPDATE!
With Darksky’s recommendation regarding SSH into the raspberry pi and entering the following command:
sudo pacman -Syu xf86-video-fbturbo-git

This allowed me to boot and go straight to the login page and now I am able to see my Desktop at 1920x1080.

The next issue for me is how to get Wifi 5Ghz to be shown and connected on my network, but I will post a seperate issue on that.

Thank you everyone that helped me! Appreciate the help and support!

Try installing crda and setting your country’s regdomain.

https://wiki.archlinux.org/title/Network_configuration/Wireless#Respecting_the_regulatory_domain