Manjaro on Orange Pi 800

Trying To understand how to Flash images with Manjaro Arm Flasher, i get these errors,

[tj@Tj-PC bin]$ ls
[tj@Tj-PC bin]$ ./manjaro-arm-flasher
27 -- exe=/usr/lib/kf5/kioslave5
13 -- platform=xcb
11 -- display=:0
18 -- appname=kioslave5
21 -- apppath=/usr/lib/kf5
10 -- signal=11
9 -- pid=6203
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kioslave5 path = /usr/lib/kf5 pid = 6203
KCrash: Arguments: /usr/lib/kf5/kioslave5 thumbnail  local:/run/user/1000/manjaro-arm-flasherKYKLqn.5.kioworker.socket 
KCrash: Attempting to start /usr/lib/drkonqi
Ready to flash: /run/media/tj/B4B2-1CBA/Manjaro-ARM-kde-plasma-opi-800-23.02.img.xz
Flashing /run/media/tj/B4B2-1CBA/Manjaro-ARM-kde-plasma-opi-800-23.02.img.xz to the /dev/mmcblk1boot0.
This process will take time..
Please wait patiently...
Compressed image size: 1.05 GiB (1125257312 B)

Exit code:   1
Exit status: 0
Unable to start Dr. Konqi
Re-raising signal for core dump handling.
Traceback (most recent call last):
  File "/usr/local/bin/./manjaro-arm-flasher", line 846, in showFlashComplete
NameError: name 'qApp' is not defined. Did you mean: 'app'?
Aborted (core dumped)
[tj@Tj-PC bin]$


I flash the arm images with balena-etcher (or etcher-bin), available on aur for x86, not tested on arm.

how to build your own Manjaro arm images

Please do not use images - they are useless - and the result of sheer lazyness and lack of respect as you do not care to express your question but post images for us to guess what you mean.

Please copy the output from the terminal then create a codefence

paste your text here

What do you mean?

Timeshift is not an image you can flash but a GUI application for backing up your OS files using rsync or btrfs.

When you write an image to a location - whether emmc, sd anything really - you completely overwrite the target - no need for formatting.

What do you think python have to do with it?

Do not ever abuse the forum with photos - it is rude

i am new to using the AUR and have only used git clone in the past of some repositories that were on the source WIKI, do you have a tutorial on installing PKGBUILD with the etcher-bin files?
i tried downloading the 64bit Appimage but i get a execvp exec format error at the header of the Dolphin File Manager, Thanks for your Recommendation.

Sorry Friend, i used Code instead and deleted the Spamful non-sense, not trying to violate any Terms of Service here, just using helpful things maybe possibly overly boasting a GUI i totally understand you just need the code to help with my situation now sorry for that.

NameError: name 'qApp' is not defined. Did you mean: 'app'?

This is Python code maybe it was qApplication in the QT5 Files on the system? no because that would be a breakage reinstalling QTCore and etc… anything that Qt5 has and it’s requirements. just brainstorming here…

I hope your downloading aarch64 appimage and not x86_64 based app image

This does not give any explanation on what you’re trying to do and where this error is coming from.

If you’re trying to fight against the Manjaro Arm Flasher app issue then it might need a new build.

I will try to look into it.


[tj@Tj-PC Downloads]$  chmod +x  balenaEtcher-1.18.11-x64.AppImage
[tj@Tj-PC Downloads]$ ./balenaEtcher-1.18.11-x64.AppImage
bash: ./balenaEtcher-1.18.11-x64.AppImage: cannot execute binary file: Exec format error
[tj@Tj-PC Downloads]$

Etcher for Linux x64 (64-bit) (AppImage)| Linux x64 |Download|
yes i downloaded this one, and received the same error as in the GUI of Dolphin.

also tried to understand how to use makepkg but says it lacks dependencies, how many electron-19 or electon-24 bin files could be like electron-16 and electron-12 if i downloaded every git hub thing on there, it wouldn’t be a correct way to solve the issue, and i cannot create this folder called '/usr/bin/balena-etcher-electron'

@itsgeno Try to install etcher with pamac

to enable aur with pamac, have a look in the pamac option (menu burger on the top right)
preference, third party, enable AUR support

Checking etcher-bin dependencies...
Warning: etcher-bin-1.18.11-1 is up to date -- reinstalling
Resolving dependencies...
Checking inter-conflicts...
Cloning etcher-bin build files...
Generating etcher-bin information...

Building etcher-bin...
==> ERROR: etcher-bin is not available for the 'aarch64' architecture.

Does this with Electron19 as well when i try to just install balena-etcher

However i did install cmake and installed raspberry pi imager with PKGBUILD but it does not show my EMMC drive when i want to flash it.

you try to install etcher on arm, I wrote to install etcher on x86_64

6.1.42-1-MANJARO-ARM (64-bit) is my Architecture, i do not know how to run 32 bit programs is there
you think if i install 32 bit libraries it will work?

sudo pacman -S lib32-glibc lib32-ncurses lib32-libstdc++5

I think you’re confused between architecture.

You have aarch64 aka arm64 architecture at 64bit while the binaries you’re trying to run are x64(64 bit) which is intel architecture and not ARM.

you need to look for arm architecture based binaries.

Try this

This is an old version as it not maintained anymore for arm by this developer.