Manjaro on gemibook pro

I have installed manjaro on my chuwi gemibook. And again like with any distro im having screen issues. I have tried different kernels but the problem remains the same. It stops when i close the laptop lid and open it again. Any help or suggestions? I posted on many different forums but no luck

Welcome to the forum! :wave:

Please post your system info as outlined here:

Thank you
Im not quite sure i understand but here is my system info:

CPU Intel Gemini Lake Refresh J4125
GPU Intel UHD Graphics 600, 250-750MHz
RAM (Memory) LPDDR4X 16GB, 2133MHZ

I haven’t run any commands as i dont know what should i input

What is it you don’t understand? Maybe there’s something in the tutorial we can improve?

If i should write anything else beside the info i just posted

Issues is often the case with hardware fitting the term winbook

It is obviously a hardware issue - which makes it even harder to suggest any solution

Please describe in detail (no pictures - thank you) what the screen issue is about and how it manifests.

Please describe how the power settings are configured for your system. (no pictures please)

Problem with graphics is the screen flickers and sometimes move from left to right, like tearing. I installed Windows again because i was frustrated but power settings i didnt change anything. Manjaro was installed and left it as is regarding power settings

Is the issue present when booted from a live ISO?

One possible option is to load the intel graphics as early as possible.

All actions - install and edit is executed on the root context (su or sudo)


Install the mesa package.

pacman -Syu mesa

Enable early kms

Edit /etc/mkinitcpio.conf


Then build initramfs

mkinitcpio -P

Xorg configuration

Edit /etc/X11/xorg.conf.d/20-intel.conf

Option 1 simple

Section "Device"
	Identifier  "Intel Graphics"
	Driver      "intel"
	Option      "TearFree" "true"

Option 2 advanced

Section "Device"
	Identifier  "Intel Graphics"
	Driver      "intel"
    Option      "AccelMethod"     "sna"
	Option      "TearFree"        "true"
    Option      "SwapbuffersWait" "true"
    Option      "DRI"             "2"

Save the file


No, it is only present when the system is installed and booted from hard drive. On virtual runs normally.
I’ll to install the OS again and run those commands to see if it helps

From the tutorial:

I tried those steps you provided. Unfortunately im too much of a newbie to do it, everything looks confusing and complicated at the moment. Managed to install drivers but the problem remains. Other steps i couldnt do properly. Looks like its back to windows for me until i get a better hardware. Thank you for your help and time

I have exactly the same issue with a Chuwi Hi 10 X, namely the annoying intermittent “movement” from left to right of the whole screen image. This machine is also a Gemini Lake Refresh J4125 system. Some more details:

  • I have also seen the issue after installing and not while installing. However, the issue is intermittent, so it may have just not happened in the installation timeframe;
  • Before installing manjaro I have also tried Opensuse Tumbleweed on this machine. I think that in the timeframe while I tested Tumbleweed (installed on the system, not from a live cd) I did not notice the issue either;
  • The issue is present both with 5.13 and 5.15 kernels;
  • The Hi 10 X is a convertible tablet with an attachable keyboard turning it into a netbook. It boots with the screen oriented in a vertical way, which is wrong for using it as a laptop. Hence, I need to work with the xrand screen rotation. In this condition, I see the screen image moving upwards, rather than left to right;
  • When I see the issue, the whole screen image moves by about 100-150 pixels upward. The bottom part of the screen ends up containing garbage (corrupted pieces of other parts of the screen image);
  • The issue comes and goes away by itself. All of a sudden, the screen image moves, stays in the wrong position for some time from 5 s to 50 s and then goes back to the correct place. I have an impression that doing something on the laptop that causes drawing on the screen makes the screen get restored to a correct display earlier, but this may just be an impression;
  • the issue is not that frequent. May happen every 3’-10’.
  • If you add an external screen to the system via HDMI, the external screen does not show the issue at all.

I’ll try to collect the diagnostics as soon as I am done with urgent stuff I need to deal with.

@linux-aarhus Incidentally… do machines with this hardware get sna rather than glamour in manjaro? I am not on the machine to make a check right now… but I see sna in some of the suggestions above…