Manjaro on external SSD - Your PC/Device needs to be repaired


I have two computers, lets call them A and B, with Windows installed on each, and an external SSD with Manjaro on it. I used Rufus to make bootable USB. Then I plugged bootable USB and external SSD in computer A and installed Manjaro on external SSD.

Manjaro works perfectly fine on computer A, but when I plug my SSD into computer B I get an error “Your PC/Device need to be repaired” with an error code 0xc0000225.
Can you give me a hint where problem is? I tried to google it and all I found that its EFI partition broken. But if EFI partition was broken, then why is it working on one computer, and doesn’t work on other? Wouldn’t it be broken on both computers? And I succeeded to boot my Manjaro on computer B with help of bootable USB. I booted USB and chose option “detect EFI bootloaders” and chose bootloader I needed.

Its not a real problem for me, its more like I want to understand how those bootloaders, BIOS works. Its shame, that this error message is so uninformative and I just dont know how to formulate my google question.

The error message and code is Windows - and the EFI is most likely as it should be.

Because FAT32 is a proprietary Microsoft filesystem and the Linux formatting tools are created after reverse engineering the filesystem - which may lead to that specific version of Windows thinking there is something wrong because of some bits being in an unexpected order or outright missing because they are not strictly needed.

The only partition Microsoft Windows can read on the device is the EFI partition which is formatted as FAT32 - so in most cases there is no harm done in letting Windows fix whatever it thinks needs fixing on the EFI partition - Linux won’t complain on the fix - so it is probably just cosmetic.

On top of what @linux-aarhus wrote, did you try to use the Boot Override option of Computer B to specifically select the manjaro EFI boot entry?

Here’s an idea of what that looks like:

I created a new boot option in BIOS (didnt knew thats possible to manually choose boot file path) and now it works, thanks.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.