Manjaro not showing in boot order menu

I recently installed manjaro gnaome desktop version. So installation all went smoothly, I then restarted my manjaro didn’t showed up but my windows aito repair started, i went to bios and checkd if my manjaro has been listed to boot order menu but i didnt get it there. So i then jumped to boot device option, so there i find my ssd boot device option and selected it, and my manjaro started. So whenever i have to start i have to go to bios menu and boot device option and start from there.
Can anybody help me how can i make it default. boot option

1 Like

Well, then make it a new entry in UEFI BOOT options following the hardware manufacturer guides of that motherboard PC or laptop … and set it as default.

I tried, but there seems to be nowhere i csn set it. I have to manually select the boot device which is my ssd to start manjaro, its default boot is windows boot

Seriously tho, you will not find to set it default in the Boot Menu, but you have to enter in Bios Settings > Boot and either set the default to another entry, or manually add an entry and then set it as default.

Some manufacturers sell computers that doesn’t fully comply with the UEFI specs and it’s quite difficult to install anything else than Windows there.

But before jumping into conclusions, have you checked that your system is prepared? For example, you can read this to get some points: [root tip] Dual boot Manjaro and Windows. Specially you have to be sure that Secure Boot is disabled.

In this case anyway, I would say that if you are unable to add a Manjaro entry (probably due to motherboard restrictions), and you have to rely on the device boot, then you have to modify the default boot order in your UEFI/Bios and make it the default. I can not give instructions, as UEFI/BIOS can be quite different between different computers.