Manjaro Not Recognizing Intel Wi-Fi 6 AX201

Hello, I have recently done a fresh install of Manjaro XFCE on a Samsung Galaxy Book Flex2. The Wi-Fi card is recognized by the system, but it does not show any connection options. I saw a few previous posts that said the similar issues they were having were solved by changing the kernel to 5.12. I have tested kernels 5.10-5.13 now and none of them have recognized my Wi-Fi card. I am using a USB Wi-Fi adapter and that is working flawlessly, but I would really appreciate being able to use the internal card. Bluetooth seems to be working with no issues.


An inxi output would be of help to us:
inxi --full --verbosity=7 --filter --no-host

Can you post the results of:
rfkill list

Please read:

A forum search will do wonders to help with your issue. For instance:

Okay so that post you linked to involves a Dell Dock that provides ethernet connection to a laptop and I guess that screwed up the rest of the user’s connections, so that’s unfortunately not relevant I don’t think.

Here is the output I got:

  Kernel: 5.10.42-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Convertible System: SAMSUNG product: 730QDA v: P02RGB 
  serial: <filter> Chassis: type: 31 serial: <filter> 
  Mobo: SAMSUNG model: NP730QDA-KB1US 
  v: SGLA879A07-C01-G001-S0001+10.0.19042 serial: <filter> 
  UEFI: American Megatrends LLC. v: P02RGB.014.210406.ZW date: 04/06/2021 
  ID-1: BAT1 charge: 53.9 Wh (100.0%) condition: 53.9/54.4 Wh (99.2%) 
  volts: 17.1 min: 15.4 model: SAMSUNG Electronics SR Real Battery 
  type: Li-ion serial: <filter> status: Discharging 
  Device-1: hid-0018:04F3:2AC3.0002-battery model: ELAN902C:00 04F3:2AC3 
  serial: N/A charge: N/A status: N/A 
  RAM: total: 7.47 GiB used: 1.09 GiB (14.6%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP 
  arch: Tiger Lake rev: 1 cache: L2: 8 MiB bogomips: 38720 
  Speed: 674 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 674 2: 592 
  3: 577 4: 1158 5: 647 6: 664 7: 709 8: 1106 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat 
  arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2 
  avx512_vnni avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd 
  avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2 
  cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 
  cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority 
  flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp 
  hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid 
  invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b 
  movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm 
  pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed 
  rdt_a rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect ss ssbd 
  sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc 
  tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi 
  vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
  Device-1: Intel Iris Xe Graphics vendor: Samsung Co driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300 
  Device-2: Generic 720p HD Camera type: USB driver: uvcvideo bus-ID: 3-6:4 
  chip-ID: 2b7e:0134 class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.11 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa s-res: 1920x1080 s-dpi: 96 
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.1.2 
  direct render: Yes 
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Samsung Co 
  driver: sof-audio-pci bus-ID: 00:1f.3 chip-ID: 8086:a0c8 class-ID: 0401 
  Sound Server-1: ALSA v: k5.10.42-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Device-1: Intel Wi-Fi 6 AX201 driver: N/A port: 3000 bus-ID: 00:14.3 
  chip-ID: 8086:a0f0 class-ID: 0280 
  Device-2: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u 
  bus-ID: 3-2:6 chip-ID: 148f:7601 class-ID: 0000 serial: <filter> 
  IF: wlp0s20f0u2 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:5 
  chip-ID: 8087:0026 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Permissions: Unable to run lvs. Root privileges required. 
  Message: No RAID data found. 
  Local Storage: total: 238.47 GiB used: 6.47 GiB (2.7%) 
  ID-1: /dev/nvme0n1 model: SN530 SDBPNPZ-256G-1004 size: 238.47 GiB 
  speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: 21112004 
  temp: 28.9 C scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / size: 233.38 GiB used: 6.47 GiB (2.8%) fs: ext4 
  dev: /dev/nvme0n1p2 label: N/A uuid: 5de523f3-168b-42a5-8bc6-f5ae58396169 
  ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat 
  dev: /dev/nvme0n1p1 label: NO_LABEL uuid: AC52-07D6 
  Alert: No swap data was found. 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 1 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 
  speed: 10 Gb/s chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-2:6 info: Ralink MT7601U Wireless Adapter type: Network 
  driver: mt7601u interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 160mA 
  chip-ID: 148f:7601 class-ID: 0000 serial: <filter> 
  Device-2: 3-5:3 info: Samsung Fingerprint Sensor Device - 730B 
  type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  power: 500mA chip-ID: 04e8:730b class-ID: 0000 
  Device-3: 3-6:4 info: Generic 720p HD Camera type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 2b7e:0134 
  class-ID: 0e02 serial: <filter> 
  Device-4: 3-10:5 info: Intel type: Bluetooth driver: btusb interfaces: 2 
  rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026 class-ID: e001 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 
  speed: 10 Gb/s chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 30.0 C mobo: 30.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 208 Uptime: 24m wakeups: 580 Init: systemd v: 248 Compilers: 
  gcc: N/A Packages: pacman: 889 Shell: Bash v: 5.1.8 
  running-in: xfce4-terminal inxi: 3.3.04

Thank you very much!

This wifi card should work out of box since 5.2 kernel. But your system don’t see any drivers – maybe something block loading :thinking: Try load drivers manually:

sudo modprobe iwlwifi

and check if you have this module blacklisted in /etc/modprobe.d/ or /usr/lib/modprobe.d/.

When I go into /usr/lib/modprobe.d/ I see:

  1. bluetooth-usb.conf
  2. nvdimm-security.conf
  4. systemd.conf
  5. uvesafb.conf

Am I missing a conf file for the wifi card? I attempted to do

sudo modprobe iwlwifi

but nothing happened.

What about content, is somewhere in this files this line:

blacklist iwlwifi

So, module is successfully loaded – you should see a difference in inxi output. Unplug external card and see if wifi now work.

There doesn’t seem to be a blacklist anywhere in these files.

I ran that, unplugged my external card, restarted the machine, and it still shows an “X” saying “no network devices available”. Any further ideas?

Do not restart, modprobe load module only for current boot.

If you want permanent solution without checking with modprobe you need add iwlwifi module to file in /etc/modules-load.d/

Okay so I ran

sudo modprobe iwlwifi

without the wifi card in. I type in my password. No output is shown on the terminal. The Wi-Fi does not come on. I still have the “X” over the area where the network usually is. What would you do from there?

You still have not provided the output for rfkill list. This command will indicate whether the internal wifi card is blocked. Many laptops have a physical switch or Fn keyboard combination to turn wifi on and off. Is there a setting in UEFI/BIOS? Have you tried another kernel? In the xfce panel when you right click on the network icon is Enable Wi-Fi checked?

Right. Sorry about that. Here it is:

0: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no
4: phy3: Wireless LAN
	Soft blocked: no
	Hard blocked: no

As far as I can tell, there is no hardware kill switch on this device of any kind.

I can check this again, but I haven’t found anything so far.

I have tried kernels 5.10-5.13 to no avail. Do you suggest going any lower than that?

It only has this option when my USB Wi-Fi device is plugged in.


The only other kernel worth checking is 5.4 LTS as earlier LTS kernel does not have driver in the kernel according to an earlier post here. Are the kernel headers installed? Is the system fully updated? There have been several firmware updates on unstable branch lately.

How do I ensure the headers are installed? I will try 5.4 LTS

Easiest is on pamac search e.g. linux510-headers

I just installed them for 5.10 and it doesn’t appear anything has changed.

Are you dual booting Windows? If so, make certain that fastboot is disabled in Windows and that Windows is totally shutdown(no sleep, no hibernation).

So this might have been the wrong thing to do, but I erased the Windows 10 partition without ever booting into Windows 10 upon buying the machine new. Do you think that could be what the issue is?

I doubt it. I am out of things to try other than seeing if it works with a Manjaro live disk, Mint xfce live disk or the like.

I have the same issue! Did you solve it @bugger2 ?

I’m having a very similar problem. Computer came with Windows preloaded, I installed Manjaro after and wifi is not even showing up. Have you been able to fix it @bugger2 @Tarquinius ?