Manjaro not listed in UEFI Boot Order menu

When i power on my laptop (hp 250 g3). I go into startup menu pressing esc

My HP Startup Menu look like this:

  • f9 : Boot device options
  • f10 : BIOS Setup
  • f11 : System Recovery

I’ve to open Boot device options menu then select EFI Hard Drive 1 to boot into Manjaro

Up until yesterday i didn’t have to do this I can simply change the boot order permanently by going to BIOS setup then it will automatically boot into Manjaro

But since yesterday, Manjaro not listed in Boot Order Menu (look at picture below), but efi file is listed in boot device options (look at first picture)

I’ve two drives which contains the following OS

SSD (CT500MX…)

  • Manjaro (the OS i want to boot into)

HDD (HGST HTS545… : placed in place of CD Drive)

  • Linux Mint
  • Manjaro
  • Windows

Everything was working fine till yesterday.
I’ve neither updated the system nor made any changes to any system file

I’ve done 3 things yesterday :

  • Installed transmission-gtk
  • Downloaded a torrent file (.mkv) form eztv
  • Downloaded tor browswer

I hope to get some answers

  • Can .mkv file downloaded from torrent be a cause for it ?
  • How can i list Manajro in UEFI boot order ?

Suppse i booted into Manjaro (SSD) and then restart my laptop, it’ll go into grub (installed with linux mint) and i’ve to select Manjaro by going into Boot Device Options again

its not clear what is the problem;

  1. are you unable to boot into manjaro
  2. is this list label issue

if you can boot into manjaro, give the results of;

$ efibootmgr

Hey @koshikas I’m able to boot into Manjaro but I’ve to select Manjaro EFI file each time to boot into it

The output of efibootmgr :

BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 0005,3005,0001,0002,0004,2001,2002,2004
Boot0001* Windows Boot Manager	HD(2,GPT,66c24189-c5c6-4b4c-adc1-63eda997adb3,0x145800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000000000100000010000000040000007fff0400
Boot0002* EFI Hard Drive (HGST HTS545050A7E680)	PciRoot(0x0)/Pci(0x13,0x0)/Sata(1,0,0)/HD(7,GPT,235d5cae-93a0-f642-afa2-e81d206648d2,0xa7b3000,0xfa000)RC
Boot0004* EFI Hard Drive 1 (CT500MX500SSD1)	PciRoot(0x0)/Pci(0x13,0x0)/Sata(0,0,0)/HD(1,GPT,66f093cc-3d95-9e47-ad34-2675e4fdf86a,0x1000,0x96000)RC
Boot0005* ubuntu	HD(2,GPT,66c24189-c5c6-4b4c-adc1-63eda997adb3,0x145800,0x82000)/File(\EFI\ubuntu\shimx64.efi)
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot3005* Internal Hard Disk or Solid State Disk	RC

these issue never arise with no interference, the ones listed by you has nothing got to do with EFI or the boot process. you will have to start with BIOS settings first, disable all setting that could lead to BIOS opting to boot the drive in CD-ROM bay(caddy), since it is the OSs in your HDD that is preventing manjaro’s GRUB from loading. from the ones visible i would start by disabling “CD_ROM Boot” and see.

from you bootloader list, BootCurrent: 0004 indicates that EFI Hard Drive 1 (CT500MX500SSD1) is set to boot if nothing else interferes

i have same problem, if you solved this problem please let me know

Looks like Windows and Ubuntu share one efi partition: 66c24189-c5c6-4b4c-adc1-63eda997adb3. Normally there would be a Manjaro entry as usual.

Try reinstalling grub:

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck 
sudo grub-mkconfig -o /boot/grub/grub.cfg 

and check again if there is an Manjaro entry:

efibootmgr -v

Also keep sure that the efi partition is flagged with boot, esp or boot,esp :wink:

1 Like

Thanks for the help but it didn’t work

@megavolt It worked like a charm

I just reinstalled grub using those two commands

Opened the boot menu: manjaro was listed :smile:

@RamakantBot you can try this

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.