Manjaro not booting with Linux Kernel 518


I wanted to try Apple’s magic keyboard support that comes with recent Linux Kernels. I was on the stable branch of Manjaro (KDE Plasma) and tried switching to Linux Kernel 518.7-1. Through the GUI, I was unable to install the kernel (had conflicts with the existing nvidia-utils library), so I installed it through terminal:

sudo pacman -Syyu linux518 linux518-nvidia

Once done, I rebooted, but the shutdown was stuck after some logs. I forced shutdown using the power button, and tried rebooting, it is stuck on the log:

// ...
mc: Linux media interface: v0.10

Every time I reboot, it gets stuck at a different log message. I understand that I might have installed the kernel incorrectly, is there any way to fix this? (I can boot into my system using Linux Kernel 515 though, but not 518). Can anyone help with this?


The way to check that is via Manjaro Kernels - Manjaro

So, you have to boot in your working kernel and then run

sudo mhwd-kernel -i linux518

That will take care of modules too, for your Nvidia GPU, and if there is a conflict then you can share the output with us.
Please make sure your system is fully updated, and if you need to use the Legacy GPU Drivers like 470xx then check if during the new kernel install is actually installing the linux518-nvidia-470xx