Manjaro not booting past loading screen

So, today, manjaro doesnt go past login screen, i have tried multiple guides here, none of them seem to work, im just stuck on that screen and only can see the cursor, i can wait up to 2 hours and nothing happens, switching to tty and log in with root, i just type startx and i can finally use it, sadly it is the root user and most of my settings arent here, if i log with my normal account in another tty, typing startx gives some random errors which i will later paste here (i have to do force shutdown which i dont like to do)

/home/.Xauthority not writable is the error, and i later get
xauth timeout in /home/.Xauthority not readable
(i noticed that after waiting a while, the de finally boots but it takes more than 10 mins and you cant shutdown, which will give some random errors)

Already solved the problem, if you or someone else get in this exact problem, this may fix it:
Go to the home folder of the user with the conflict
In dolphin or in the file explorer you use, enable show hidden files
you will find a bunch of files, search for .Xauthority, rename it to .Xauthorityback in case something goes wrong.
Now you just need to restart
This solved the problem for me, and i hope it did for you too!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.