Manjaro not booting after messing with fstab

I was investigating slow boot times and tried disabling fsck check for my disks (others than root). I changed contents of the file according to arch wiki, after which system didn’t boot. I tried changing fstab back with my installation medium, but it didn’t help

I got access to my files from home directory and thought I could reinstall system now, but installer doesn’t have an option to erase my SSD

That is not possible. Maybe you forgot to chroot?

Probably. How should I do that?

My bad actually you do not really need chroot for that.

Here is a reference how an fstab can look like with default options

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>

UUID=xxxxxxxxxxxxxxxxxxxxxx                            /boot/efi      vfat    umask=0077 0 2
UUID=xxxxxxxxxxxxxxxxxxxxxx /              ext4    defaults,noatime 0 1
UUID=xxxxxxxxxxxxxxxxxxxxxx none           swap    defaults 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

No, my changes really didn’t save. I probably did something wrong.
Last digits in these disks entries are 0, that skips the file system check. To revert this change I set it to 2, but it didn’t save when i tried to reboot. Now these are zeros again
Have to note that my root is btrfs, arch wiki says that needs to be considered

no idea about btrfs, sorry, i do not use it.

Don’t know what I did wrong first time, but system has booted successfully

No, it doesn’t.
That is not what this means.

If the file system is unclean - it needs to be checked.
This “number” will neither allow or prevent this.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.