Manjaro not booting after hard poweroff

I have KDE Manjaro installed on my laptop, and it was running smoothly this morning. However, when I tried to shut it down, it froze. I had to do a hard power off, and now it’s not booting up properly - it’s getting stuck on the manufacturer’s logo screen. I’ve tried accessing the boot menu and testing different kernels, but nothing seems to work. I would really appreciate any help as I need to resolve this issue quickly, but I’m new to Linux! I would like to keep my files.

Welcome to the forum. Here are some starting points:

Restore from Timeshift snapshot from grub menu if you have.

Sounds serious. In case I should find myself in this kind of situation, I would do the following:
1.) connect live-USB to laptop and boot the laptop from this live-usb, after this
2.) copy all your documents to external drive (usb stick, external ssd or hdd), after this
3.) reinstall Manjaro.

1.) and 2.) seem all right
having a backup is always good
but before 3.) one should be allowed for a little troubleshooting before just leveling everything and starting from scratch. :wink:

Your files are still there.
Be assured of that.

If really nothing works:

boot a live system ( like the one you installed from)
and use it to access your files and recover them

Then you can also use it to chroot into your system and try to assess what caused the failure.

1 Like

I had to do a clean install of manjaro, but I managed to grab my files. Thanks all!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.