Manjaro not booting after battery change

error
failed to get canonical path of overlay

addendum
realized I have missed the chroot bit, currently working on the laptop next to the pc, have a look a bit later… if not too tired

I guess you mean these instructions here
https://wiki.manjaro.org/index.php?title=Restore_the_GRUB_Bootloader
I will try tomorrow…
Many thanks in the meantime :slightly_smiling_face:

1 Like

Okay, understand. But that is unusual. But I think we can bring back your computer system.
Need to have some information to do so.
Boot up to Manjaro, at terminal,provide

test -d /sys/firmware/efi && echo UEFI || echo BIOS
sudo parted -l
cat /etc/fstab
sudo blkid
cat /proc/cmdline

Suggest (apologies to all responders) you do not try anything in the meantime.
Cheers.

[edit] - I read following

If I then deselect UEFI and choose legacy as boot mode, the ssd with Manjaro jumps to the top of the boot devices list, and the same in the hard disk drivers list.

as though you can boot Manjaro (that is the unusual part), if you cannot (and that actually makes better sense if you cannot), as per this

if I’m in legacy nothing seems to boot, not even Manjaro!

Boot up to livecd and provide the information needed above, but without 'cat /proc/cmdline’
and information ‘/etc/fstab’ from Manjaro OS partition.

test -d /sys/firmware/efi && echo UEFI || echo BIOS
sudo parted -l
sudo blkid

and look into Manjaro OS partition from livecd file manager, contents of

/etc/fstab

1 Like

many thanks gohlip, just read your post, something to do now, I’ll follow your instructions a bit later this morning and then report here :slight_smile:

Hope you enjoyed your mountain hike. Good to get away sometimes.

It is always best to try to boot to the OS directly, if that is possible (and I think it is possible in your case), rather than through livecd OS, and here’s how. And boot this livecd media through UEFI (almost certain your Manjaro is UEFI). Through this livecd (17.0.1 and above) grub (do not need to boot to livecd OS), you can boot Manjaro through all these 3 methods. configfile, chainload or use grub menu’s “Detect EFI bootloader”.

When booted to actual Manjaro OS partition (not livecd), verify that /boot/efi is mounted.

findmnt /boot/efi

It should show something. If not stop and provide details required in previous post.

Then verify that OS is booted in uefi

test -d /sys/firmware/efi && echo UEFI || echo BIOS

It should show “UEFI”. If not stop and provide details required in previous post.

Then proceed with

sudo grub-install
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo update-grub

Done. Reboot without live media.

Good luck.

2 Likes

hi gohlip,
I’ll go to the mountains tomorrow, I need to sort this issue first otherwise it will stay this way until the 23rd or later…
Now, I’m trying to follow your instructions here:
https://forum.manjaro.org/t/restore-manjaro-boot/3350
However after

sudo mount /dev/sdxy /mnt

with sdb (where Manjaro is) instead of sdxy what I get is

mount: /dev/sdb is already mounted or /mnt busy

Should I go on with the following command (sudo grub-install etc.) or not?

I am unsure where (livecd or Manjaaro OS) or what (which partition) you tried to mount. [1]
But see my earlier post (to boot from livecd grub menu) and let us know if this makes any progress.
Let us know if you can boot to manjaro OS (not livecd)
If still unsure, you can always provide the information we need and we’ll work out the commands and we’ll a;lso work out if you should boot to Manjaro OS or livecd.

I’m still quite confident it will work out.

[1] - Anyway this link applies only to bios-legacy/msdos which I think your system (gpt/uefi) is not.

And all the following applies only to bios-legacy/msdos.

Also “sudo mount /dev/sdxy /mnt” is mounting the partition, not the device disk (sdb).
“sdxy” - ‘x’ is either ‘a’ ‘b’… and ‘y’ is ‘1’, ‘2’, ‘3’…
and for gpt/uefi, you also need to mount the /boot/efi partition as /mnt/boot/efi before doing the command.
But never mind, provide the info (all the info, please - all are needed) we need. We’’’ sort this out.

1 Like

I was on the livecd, sorry but as I stayed home I’m also working on the other pc… try to stay more focused on this issue asap, and I’ll come back with news :wink:

I should have specifed sdb1, then if I understand this properly:

Model: ATA Crucial_CT128M55 (scsi)
Disk /dev/sdb: 128GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:
Number Start End Size File system Name Flags
1 1049kB 3146kB 2097kB BIOS_GRUB bios_grub
2 3146kB 108MB 105MB fat32 UEFI_SYSTEM boot, esp
3 108MB 376MB 268MB ext2 MANJARO_BOOT legacy_boot
4 376MB 120GB 119GB ext4 MANJARO_ROOT
5 120GB 128GB 8290MB linux-swap(v1) MANJARO_SWAP

right?
Back to work and then here agai a bit later (can’t really do 2 things at the same time…).
Thanks again (not writing this every single time as it will wear the keyboard away…)

Ok, still need
test -d /sys/firmware/efi && echo UEFI || echo BIOS
sudo blkid

and manjaro OS partition /etc/fstab.

Ah… you have bios_grub (sdb1), /boot (sdb3) and an $esp (sdb2) partition!!

Heh heh heh… let’s look at your fstab.

ps: now we need another command output, (just to verify if windows is really uefi).

Need another output from livecd (or manjaro OS) booted in uefi mode

efibootmgr -v

Cheers.

[edit] your windows disk data is not there.
Need all informattion - do not omit windows disk information either.
All needed.

as they say in good journalism, omission of facts is like disinformation.

1 Like

i only get:
UEFI

/dev/sda1: LABEL=“ESP” UUID=“4ADD-9FE1” TYPE=“vfat” PARTLABEL=“EFI system partition” PARTUUID=“b4a45e8a-9b9e-4846-92ad-2302e318b5e2”
/dev/sda2: LABEL=“DIAGS” UUID=“1202-3C5B” TYPE=“vfat” PARTLABEL=“Basic data partition” PARTUUID=“1dd8742b-b862-4101-9d01-c77156a0a27b”
/dev/sda4: LABEL=“WINRETOOLS” UUID=“8E3403DC3403C5E5” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“6a9c54ea-ea11-46aa-bbc4-addcb31624b7”
/dev/sda5: LABEL=“OS” UUID=“98280861280840AC” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“e5a0bd11-e7bf-4012-b537-3a6f35334d67”
/dev/sda6: LABEL=“VolumeInComune” UUID=“C29A8E0D9A8DFDE3” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“f67af698-968d-4d74-87d7-5d1f8d70960a”
/dev/sda7: LABEL=“PBR Image” UUID=“4C04746104745046” TYPE=“ntfs” PARTLABEL=“Microsoft recovery partition” PARTUUID=“58bf3d34-1e7d-46b5-8d10-aa9988c4119a”
/dev/sdb2: LABEL=“UEFI_SYSTEM” UUID=“C515-DE65” TYPE=“vfat” PARTLABEL=“UEFI_SYSTEM” PARTUUID=“7d62e065-9601-4be2-9695-90843d69b3e0”
/dev/sdb3: LABEL=“ManjaroBoot” UUID=“dc0b1339-7a3a-4796-95cf-eccb1ad1a697” TYPE=“ext2” PARTLABEL=“MANJARO_BOOT” PARTUUID=“28a29785-acfb-4233-859e-9a8f68b4e6ba”
/dev/sdb4: LABEL=“ManjaroRoot” UUID=“27f1aecb-7a9c-4ea1-828a-287d21bf6c98” TYPE=“ext4” PARTLABEL=“MANJARO_ROOT” PARTUUID=“7ca4c34c-656c-4434-83be-b2d334a6b446”
/dev/sdb5: LABEL=“ManjaroSwap” UUID=“01e8ad03-a4d6-4f5a-b5a2-d6cdd7f706f3” TYPE=“swap” PARTLABEL=“MANJARO_SWAP” PARTUUID=“f6a8139a-5fff-45aa-a81e-1732993a7dcc”
/dev/sdc1: LABEL=“UUI” UUID=“1116-3F59” TYPE=“vfat” PARTUUID=“00023a39-01”
/dev/loop0: TYPE=“squashfs”

yes, I was wondering about that!

sorry, how do I look at that?
I get a “Not a Directory” message…

DONE IT

-rw-r–r-- 1 root root 204 Feb 1 2017 /etc/fstab

BootCurrent: 000C
Timeout: 1 seconds
BootOrder: 000C,0003,0007,0000,0001,0002
Boot0000* P5: Crucial_CT128M550SSD1 BBS(17,0x0)
Boot0001* TDKMediaTrans-It Drive PMAP BBS(18,0x0)
Boot0002* P4: HL-DT-ST DVD+/-RW GHB0N BBS(19,0x0)
Boot0003* Windows Boot Manager HD(1,GPT,b4a45e8a-9b9e-4846-92ad-2302e318b5e2,0x800,0xfa000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}…7…
Boot0007* Windows Boot Manager HD(2,GPT,7d62e065-9601-4be2-9695-90843d69b3e0,0x1800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)
Boot000C* UEFI: TDKMediaTrans-It Drive PMAP PciRoot(0x0)/Pci(0x14,0x0)/USB(8,0)/HD(1,MBR,0x57,0x800,0x76d800)…BO

I wonder if this is enough… Leaving for lunch and back here a bit later

Model: ATA WDC WD10EZEX-75M (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:
Number Start End Size File system Name Flags
1 1049kB 525MB 524MB fat32 EFI system partition boot, esp
2 525MB 567MB 41.9MB fat32 Basic data partition hidden
3 567MB 701MB 134MB Microsoft reserved partition msftres
4 701MB 2849MB 2147MB ntfs Basic data partition hidden, diag
5 2849MB 498GB 495GB ntfs Basic data partition msftdata
6 498GB 987GB 489GB ntfs Basic data partition msftdata
7 987GB 1000GB 13.6GB ntfs Microsoft recovery partition hidden, diag

Model: ATA Crucial_CT128M55 (scsi)
Disk /dev/sdb: 128GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:
Number Start End Size File system Name Flags
1 1049kB 3146kB 2097kB BIOS_GRUB bios_grub
2 3146kB 108MB 105MB fat32 UEFI_SYSTEM boot, esp
3 108MB 376MB 268MB ext2 MANJARO_BOOT legacy_boot
4 376MB 120GB 119GB ext4 MANJARO_ROOT
5 120GB 128GB 8290MB linux-swap(v1) MANJARO_SWAP

Model: TDKMedia Trans-It Drive (scsi)
Disk /dev/sdc: 3995MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Disk Flags:
Number Start End Size Type File system Flags
1 1049kB 3989MB 3988MB primary fat32 boot, lba

Well, it was just a suggestion, not a request :grin:

@Finrod

It seems you installed Manjaro in UEFI mode after all, no need to format then :sweat_smile:

After reinstalling the grub bootloader on the SSD, make sure it works and then, before booting anything, get into UEFI, disable the disk where Windows is and make sure the only bootable drive enabled is the SSD. Don’t forget to disable legacy-related stuff.

I did this and I’ve never had a problem with Windows messing up anything. And if you reinstall Windows, just disconnect your SSD. Once installed, reconnect the SSD and make sure the disk where Windows is remains disabled.

2 Likes

I think @gohlip was looking for:
cat /etc/fstab

Cheers man!!! :smiley:

1 Like

Yes. We will need that. Without that we cannot proceed.
Ww need /etc/fstab of sdb4, the root partition of Manjaro OS.

2 Likes

ok, but exactly how should I word the command, if it’s

cat /etc/fstab

I get:

# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
/dev/mapper/root-image /             auto      defaults           0      0

If it’s

cat /etc/fstab /sdb4

(I’m guessing the command) is:

# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
/dev/mapper/root-image /             auto      defaults           0      0
cat: /sdb4: No such file or directory

Forum kindly sponsored by Bytemark