Manjaro not able to boot after interrupted update

I am using Manjaro with KDE on a LUKS encrypted partition with EFI (not ecrypted). Unfortunately i interrupted a recent system update and ended up with the error “vmlinuz not found”.

I followed the insctructions from this post: [HowTo] Recovering from an interrupted update/upgrade

However, after finishing that, i end up with the following screen when trying to boot.

I booted into Live again and tried reinstalling a kernel which worked but it did not help. Now i am out of ideas and not even sure what the problem is.

Help would be very much appreciated. Thanks a lot!

In chroot:

mkinitcpio -P && update-grub
1 Like

I did that successfully but i get the same results when trying to boot.

Of course you should also rerun the update to make sure it finishes ok. So best in this order:

  • refresh mirrors
  • rerun update
  • reinstall kernels
  • fix bootloader (reinstall grub or use the commands above)
1 Like

Yes i did that before:

sudo pacman-mirros -f && sudo pacman -Syu

gives “there is nothing todo”

Then i reinstalled the kernels and did mkinitcpio -P && update-grub

But still i cannot boot.

I am wondering if my crypt setup is the problem. Before i chroot i use

cryptsetup luksOpen /dev/sda1 crypt
mount /dev/mapper/crypt /mnt
manjaro-chroot /mnt

Then in chroot i run everyhing above. Is this correct?


Grub should list the found “init images”. If not, then there is something wrong.

Is sda1 really your root partition? Usually the first partition would the efi partition, if it is EFI.

1 Like

Sorry apparently i was a bit sloppy when typing it up (written on another computer). The pacman-mirrors command was spelled correctly when executing it.

Yes you are right, the root partition is sda2 (which is the one i opened and mounted).

I mean yes obviously there is something wrong. I was hoping that someone here could help me out since i don’t know what it is. Is the procedure i executed generally correct?

Open the root partition, mount it as /mnt and then chroot into it. Update system and install kernels then mkinitcpio?

In some tutorials about similar issues i saw the separate mounting of /boot and /boot/efi. Is that something i need to do and could be the reason why it fails?

Thanks a lot so far!

If you have a separate /boot partition or you use your efi partition for your initcpio images, then of course, you have to mount it as well. But that is something we could not know. The default is that /boot is part of the root partition and not separated partition. So we assume that. EFI partition is always separated and non-encrypted due UEFI needs to read it.