Manjaro no longer detects my intel igpu monitor

I have triple monitors, 2 are connected to the nVidia GPU and they work flawlessly now, but my igpu monitor won’t work.
At the fresh installation, the intel gpu worked and the nvidia didn’t but i kept missing around with mhwd and tried to install a couple of drivers to get my nvidia gpu to work until it finally did, but now my intel gpu display won’t work.

here are some specs:

[hegz@hegzaro ~]$ mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
    video-nvidia-450xx            2019.10.25               false            PCI
           video-linux            2018.05.04                true            PCI

hegz@hegzaro ~]$ inxi -G
Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel
           Device-2: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 450.66
           Display: x11 server: X.Org 1.20.8 driver: nvidia resolution: 1: 1600x900~60Hz 2: 1920x1080~60Hz
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66

[hegz@hegzaro ~]$ xrandr
Screen 0: minimum 8 x 8, current 3520 x 1080, maximum 32767 x 32767
DVI-D-0 connected primary 1600x900+1920+180 (normal left inverted right x axis y axis) 443mm x 249mm
   1600x900      60.00*+
   1440x900      74.98    59.89
   1280x800      74.93    59.81
   1280x720      60.00    50.00
   1152x864      75.00
   1024x768      75.03    70.07    60.00
   800x600       75.00    72.19    60.32    56.25
   720x576       50.00
   720x480       59.94
   640x480       75.00    72.81    59.94
HDMI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
   1920x1080     60.00*+  59.94    50.00
   1680x1050     59.95
   1600x900      60.00
   1440x900      59.89
   1280x1024     60.02
   1280x800      59.81
   1280x720      60.00    59.94    50.00
   1024x768      70.07    60.00
   800x600       72.19    60.32    56.25
   720x576       50.00
   720x480       59.94
   640x480       72.81    59.94
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)

i’m using i3 community image


you are using

driver: nvidia

that means it is the proprietary driver of nvidia. With this driver you can only use nvidia gpus. If you want to use the intel gpu also, then you have to stick with the free driver.
nouveau is for example the reverse-engineered open source driver.

how about the hybrid drivers, aren’t these supposed to work?
i have also tried removing the nvidia driver and only left intel’s video-linux but the igpu didn’t work neither the nvidia and i had to fix it through tty.

sure they work with prime, but it will offload gpu tasks to the nvidia one in specific applications and you have to use the intel driver for your screens. nvidia card screen outputs will not work.

Could you post the output of:

xrandr --listproviders

Have look also here: PRIME - ArchWiki

Did you change in the UEFI from PCIE to IGD or similar?

here is my xrandr result:

[hegz@hegzaro ~]$ xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x1b8 cap: 0x1, Source Output crtcs: 4 outputs: 4 associated providers: 0 name:NVIDIA-0

and yeah i have it set to IGPU instead of the PCI in my UEFI bios settings.