Manjaro no longer boots all of a sudden?

Hey guys. I’ve been using Manjaro KDE on an old Dell Inspiron 1501 for several months now, without any real problems. Last Saturday I tried to start the computer up, and I couldn’t boot into Manjaro for some reason. I hadn’t changed anything or done any updates that I recall since it had been working correctly. The error screen that comes up says:

[FAILED] Failed to start File System7-7461-4521-bbd3-0c4bf8a56ebd
[FAILED] Dependency failed for /home
[FAILED] Dependency failed for Local File Systems

If the fix for this is super involved, I’ll just reinstall, but I’d really like to know what’s going on and what caused this. I’m using Mint on the same laptop right now, but I preferred Manjaro.

When it first happened last week, I looked online for some help, but I didn’t come up with anything helpful. I’ve been on the road all week, and now I have time to deal with it.

Thanks a lot for any advice, I really appreciate your time.


/home is a partition ?
if yes manjaro not found this partition
you can read with mint if partiton with this uuid exists


Yes, /home is a partition. Mint doesn’t use this /home partition (I didn’t know enough to set it up like that when I first installed Mint). When I look at my partitions in Mint, I can see and access Manjaro’s /home partition without any trouble.

So when I use the command you included above, it shows the mountpoint for that partition as “/media/adr”, but that’s where Mint has it mounted, I assume?

Thanks for the help,

here is not a valid UUID (typo problem?), with my command you can view all uuid in pc
you can paste here result
is not allways home partition, can swap partition or other in /etc/fstab ?
You can also paste /etc/fstab in manjaro partion ?

maybe the /home is full?

The output of that command is copied and pasted here:

sda 465.8G disk 0
├─sda1 f5778abe-b8c1-4232-b3a6-bab72bded3bd 93.1G part 0 ext4 0x83 /
├─sda2 1K part 0 0x5
├─sda5 4cd13384-dea0-432d-9071-30d5f28b8356 136.5G part 0 ext4 0x83 /media/adrian/4cd13384-dea0-432d-9071-30d5f28b8356
└─sda6 c3afe077-7461-4521-bbd3-0c4bf8a56ebd 236.1G part 0 ext4 0x83 /media/adrian/c3afe077-7461-4521-bbd3-0c4bf8a56ebd
sr0 1024M rom 1

Thank you,

I used a different terminal when I just did that, apparently the one I used the first time truncated the mount points.


Thanks, but no, /home isn’t full.


The fix for this is likely not super involved.
Could you please post the content of the fstab file in /etc/ on your manjaro partition?

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a device; this may

be used with UUID= as a more robust way to name devices that works even if

disks are added and removed. See fstab(5).

UUID=4cd13384-dea0-432d-9071-30d5f28b8356 / ext4 defaults,noatime,discard 0 1
UUID=c3afe077-7461-4521-bbd3-0c4bf8a56ebd /home ext4 defaults,noatime,discard 0 2
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0
/swapfile none swap defaults 0 0

Hmmm. Let’s check the filesystem.
First you need make sure to have the partition unmounted. You can do that with sudo umount /dev/sda5 and then you can check it with sudo fsck /dev/sda5.

The results:

fsck from util-linux 2.31.1
e2fsck 1.44.1 (24-Mar-2018)
/dev/sda5: clean, 326901/8945664 files, 6395787/35778560 blocks

As your /home partition is sda6 repeat that for sda6 after unmounting it:

fsck /dev/sda6

It is advisable to avoid continuous trim as set with this parameter in your fstab file. Better use periodic trim by the fstrim timer of systemd to trim your sdd once a week. After you have removed “discard” from all entries in your fstab file you only need to execute one command to enable the timer:

systemctl enable fstrim.timer

Last but not least: You have a rarely used partition type for your extended partition:

Acc. to wikipedia this “0x5” correspond to CHS addressing and it must reside within the first physical 8 GB of the disk, else “0xf” should have been used. As it’s most likely not within the first 8 GB of your disk you have an inconsistency here.

1 Like

I think the problem is that Arch/Manjaro use a grub configuration at boot that is different and incompatible from rest of Linuxes. So if you happen to update grub from Mint, it’s going to break Manjaro.

I think you have to boot from a Manjaro liveUSB, chroot to your Manjaro and update-grub to solve the issue. There some more detailed instructions here:

boot with USB iso manjaro
give return

sudo parted -l

is /home on any external disk as USB ( for example )

That did it. It fixed a bunch of stuff on the /home partition, and I’m now posting from Manjaro. Thank you so much!

As for the continuous trim thing you mentioned, it set itself that way, I didn’t do it. Do I really need to be screwing with it?

And for the other partition you mention, that’s not a real partition, I guess it’s just some dregs left over after partitioning that got left out for whatever reason? Likely because I didn’t know what I was doing.

Thank all y’all who helped me out, you really don’t know how much I appreciate it!


1 Like

I’m so glad to hear that! :hugs:

It’s true, the installer does it. Mostly, because it’s donoe for long time. It’s commonly accepted not be be ideal as it causes more trim operation on your sdd than needed and this could cause wear, means it results in lower life span of your sdd. For that reason I would like to encourage you to remove the “discard” flag from your /etc/fstab file and to run once the command I mentinded. That’s all!

Here I would say, never change a running system, if it’s working you can certainly keep it.

Please, mark the post with the helpful information as solution. (It’s appearing behind the three dots.)