Manjaro LXDE/LXQt on RPi4

Is there a way to install the Manjaro Community Edition LXDE theme on aarch64?
The wiki points to running:

sudo pacman -S manjaro-lxde-logout-banner manjaro-lxde-xfce4-notifyd manjaro-lxde-xfce4-volumed-pulse manjaro-settings-manager manjaro-settings-manager-notifier manjaro-lxde-settings arc-maia-icon-theme kvantum-manjaro

But unfortunately most do not exist in the arm repo.

1 Like

LXDE is “dead”, so it probably won’t get added. Sorry.

Would you know what Raspi OS will be moving to? I think they currently use a themed and slightly modified version of LXDE.

They use a forked LXDE for their “Pixel” desktop as far as I know.

No idea if they will rebase it on something else, or just keep updating the ancient code. :wink:

The same for LXQt?

$ sudo pacman -S manjaro-lxqt-extra-settings manjaro-openbox-adapta-maia papirus-maia-icon-theme
error: target not found: manjaro-lxqt-extra-settings
error: target not found: manjaro-openbox-adapta-maia

are you on manjaro now?
if so you can install manjaro-arm-installer & use that to create your system.
sudo manjaro-arm-installer to run

1 Like

Yes, but I use plasma currently.

I would think the required packages must exist, but have different names in the ARM repo, if LXQt is available via the installer.

LXQT is available in the Installer. But it’s a different setup, than the x86_64 one is. All of our editions are.

sudo pacman -S manjaro-arm-installer

sudo manjaro-arm-installer

select rpi4 then it will show you the choices, then the rest is like a standard install, just press the first letter to jump down the menus to select locale, keyboard, time zone, etc…

I used the lxqt profile used by the installer to install alongside Plasma. So far, they seem to co-exist without interference.

Edit: Eh, they do fight over icons. Not sure why it take multiple reboots to show up. So make a new user to run multiple desktops.

After working with LXQt, I decided to remove KDE Plasma.

And after adding xscreensaver, xsettingsd, screengrab, lightdm-slick-greeter and fiddling with the settings, I think I have the Manjaro Theme properly applied. Maybe the icons are not correct?.. breeze-dark. But anyway, here it is:

Edit: I also commented out the hard coded QT_QPA_PLATFORMTHEME=lxqt in the /usr/bin/startlxqt script. I then placed it in /etc/environment, and changed it to QT_QPA_PLATFORMTHEME=qt5ct

Edit 2: Installed the correct icons, breath2-icon-themes and changed the various icon theme settings to breath2-dark.

Edit 3: Installed pipewire-alsa, pipewire-pulse and the optionals for pipewire to bring audio up to the new standard.

Edit 4: Installed libstatgrab, libsysstat, and lm_sensors as they are optional for lxqt-panel. Adding them allows a couple panel widget plugins to funtion. I did not care for them theme-wise, but noted here for completeness.

Edit 5: I switched to the “Papirus-Dark-Maia” icons and font size 11 as those are the Manjaro theme settings for LXQt. Below is my xsettingsd configuration. Installation does not provide a working config, you need something to get it going. This helps gtk apps to load a matching theme.

$ cat ~/.config/xsettingsd/xsettingsd.conf

Gtk/CursorThemeName "xcursor-breeze"
Gtk/CursorThemeSize 22
Gtk/FontName "Noto Sans Medium 11"
Net/IconThemeName "Papirus-Dark-Maia"
Net/ThemeName "Matcha-dark-sea"
Xft/Antialias 1
Xft/HintStyle "hintslight"
Xft/Hinting 1
Xft/RGBA "rgb"
1 Like

i liked the apps, pcmanfm-qt, qterminal, featherpad.
featherpad is a keeper removed gedit from my current install for it.
not really big on lxde, so didn’t really care for lxqt.

i’m running a fresh install of the sway release.

Sway is something I plan to investigate soon, glad it made it as an official edition.

it’s the best if you like to do things your own way.
every part is editable, you just have to edit the right text file. you can literally have a button that calls you a fricken monkey, tells you the key combination, then launches the app.

1 Like

@Strit Concerning the QT_QPA_PLATFORMTHEME environment variable. Am I correct to assume this is not a resolvable matter, since /usr/bin/startlxqt specifically overrides a system setting? Are you aware of any LXQt operational issue if QT_QPA_PLATFORM=qt5ct is forced?

I don’t really use LXQT, but I would assume it’s enforced by upstream, since the startlxqt file comes directly from them.
And regarding issues using qt5ct, I don’t know either, since I haven’t used LXQT extensively in a long time. But if you encounter any, please let us know. :slight_smile:

No issues so far and the results have been solid so far. I opened an issue, maybe it will be informative.

That got closed quickly…

lol, yes it did. Interesting. I guess there is more for me to learn about this.

Ah, he is exactly correct. If qt5ct is installed (in the lxqt profile) and no config (~/.config/qt5ct/), panel theme is incorrect. Uninstall qt5ct, the panel theme is correct.

If you do as I did, and force qt5ct, it works, but is evidently the wrong thing to do.

Edit: And without qt5ct, QT_QPA_PLATFORMTHEME=qt5ct should be removed from /etc/environment