Manjaro live usb does not start after GRUB

Nomodeset does not work. I add it before quiet option in boot options. I don’t know where to add because boot option editor is different than in instructions.

Yes, because acpi=off i can’t use internal keyboard and mouse.
Laptop is old, bios control is very limited. It has option to turn UEFI on or off. There is not option for secure boot. Loading with UEFI is very slow and stops at systemd… freezing execusions.

on the line that starts with “linux /boot/vmlinuz”, remove “nouveau.modeset=1 i915.modeset=1 radeon.modeset=1” replace them with nomodeset.
linux /boot/vmlinuz-$2 driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
linux /boot/vmlinuz-$2 driver=free nomodeset

also, remove quiet from the options as this removes debug output when you boot which might tell us what’s going wrong

I did it and it does not work, same black screen.
Also if i leave on this blank screen some time, USB device (Kingston datatraveler 3.0, when in using reading or writing data it gets hot very easy) is cold, as it is in idle state.
Now i think load live usb with acpi=off and install system, it is interesting what happens then. :grin:

when you’re at the black screen, can you try pressing Ctrl+Alt+F3
this should get you to a TTY prompt where we may be able to debug the system further.
Is there any output after grub, or is it as you say, just completely blank

No, tty does not open. There is not any output, it is only blank screen.

May be you are write about GPU, because with acpi=off in uefi mode minimal xfce installer started, it was too slow and cannot start all services but last tty screen opened. As opposed to normal xfce installer, which stopped at
failed to start up manager systemd [1]: freezing execution

a quick google of that error seems to suggest a bad HDD, however since you’re booting from a USB drive, perhaps it is the USB drive that has failed?

If you have access to another computer, could you please try downloading a new copy of the manjaro ISO (old copy may be corrupted) and flash it to a new/different USB drive?

Boot freezes If booting gets stuck without any error message after GRUB loading the kernel and the initial ramdisk, try removing the add_efi_memmap kernel parameter.
What do you think about this?

Yes, it is loading without any problem on another laptop. but i am going to try different usb.

have you also followed the instructions at [HowTo] Resolve an unbootable Manjaro (black screen, login failed, cant boot, etc)

this is not relevant as you’re not booting with the “add_efi_memmap” parameter

Yes, i tried that

Can someone help with to enable acpi debug. I think this can help

Can someone tell me, does this tells about the ACPI problem? I set acpi=off

$ sudo dmesg | grep -i acpi
[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=manjaro misolabel=MANJARO_XFCE_2122 acpi=off systemd.show_status=1 apparmor=1 security=apparmor driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
[    0.000000] BIOS-e820: [mem 0x00000000afcc1000-0x00000000afd0bfff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000afd1d000-0x00000000afd24fff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000afd38000-0x00000000afd38fff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000afd3c000-0x00000000afd49fff] ACPI data
[    0.000000] BIOS-e820: [mem 0x00000000afd4a000-0x00000000afd4ffff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000afd70000-0x00000000afd70fff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000afd86000-0x00000000afd8cfff] ACPI NVS
[    0.044664] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=manjaro misolabel=MANJARO_XFCE_2122 acpi=off systemd.show_status=1 apparmor=1 security=apparmor driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
[    0.152806] APIC: ACPI MADT or MP tables are not detected
[    0.167586] ACPI: PM: Registering ACPI NVS region [mem 0xafcc1000-0xafd0bfff] (307200 bytes)
[    0.167601] ACPI: PM: Registering ACPI NVS region [mem 0xafd1d000-0xafd24fff] (32768 bytes)
[    0.167607] ACPI: PM: Registering ACPI NVS region [mem 0xafd38000-0xafd38fff] (4096 bytes)
[    0.167609] ACPI: PM: Registering ACPI NVS region [mem 0xafd4a000-0xafd4ffff] (24576 bytes)
[    0.167612] ACPI: PM: Registering ACPI NVS region [mem 0xafd70000-0xafd70fff] (4096 bytes)
[    0.167614] ACPI: PM: Registering ACPI NVS region [mem 0xafd86000-0xafd8cfff] (28672 bytes)
[    0.174569] ACPI: Interpreter disabled.
[    0.196651] pnp: PnP ACPI: disabled

Might help: acpi=noirq or noapic Bootparameters??
Shure there is no newer BIOS-Version to flash?

noirq and noapic

does not work

This is boot parameters, i add other options here.

No, there is not newer BIOS version. Last BIOS update was in 2012.
I can’t figure out what exactly acpi has problem.
Also i got this error while booting, with acpi=off

[ 0.010232 ] ACPI BIOS error (bug): Invalid table length 0x24 in RSDT/XSDT (20210730/tbutils-289


In addition, same thing happens with Architect. Loading Architect stopped there.

Now i will install with acpi=off to see what error messages cached when system freeze.

Hello everyone again. As i said earlier i installed system with acpi=off kernel parameter, then problem was same black screen after grub. Now i will tell you about :smile: happy end. I found solution, disabling legacy usb support. Now system loads and i have only one problem when gui appears, first few seconds, as in image. Now i try to find solution for that.

1 Like


You may try early kms (/etc/mkinitcpio.conf)

1 Like

This may also help you. I remember that you had same problem.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.