Manjaro live boot hangs on TLP system startup/shutdown

Hey! I am fairly new to the linux ecosystem and I tried Manjaro Cinnamon 18.0.4. However, when I try to boot from the USB drive, the list of services started, pops up and it gets stuck at:

[ OK ] Started TLP system startup/shutdown.

I tried running it with nomodeset at boot but it gets stuck at some other service (I don't remember the name).
Apart from Manjaro, I face similar problems with other Linux distros too, I'm guessing it's probably because of incompative nVidia drivers or maybe the fact that my CPU does not have an iGPU.
Any help to fix this is really appreciated.

My system configuration:

  • Intel Core i5 9400f
  • ZOTAC GeForce GTX 1650 OC
  • GIGABYTE B360m Gaming HD

Try this ISO. Double check the iso sha1/sha256 checksums to make sure the download isn't borked.
Use Etcher or rufus in dd mode.

This will put you on Testing branch. If that makes you nervous it can easily be changed.

2 Likes

can you check
in bios

  • no csm , no fast boot , UEFI only no legacy , AHCI , secure boot desactived
  • boot on USB install manjaro and choose no-free drivers
3 Likes

You can do it with a kernel argument.

1 Like

It's very likely the 18.0.4 image doesn't know what this GPU is.

Using an 18.1 pre-release image should work.

1 Like

Thanks, I tried the iso & this time it did work without any issues!! I installed it with free gfx drivers & it worked flawlessly. However after installation, the OS warned me to get the proprietary gfx drivers installed or my CPU will experience more load. I'm not really sure how much of a difference it makes on my CPU load but I installed the proprietary nVidia drivers & it made the entire OS laggy as hell. I see stutters even while moving the cursor around. I tried fiddling around with nVidia Xorg settings but it didn't make much of a difference (if at all).

Shall I stick to free drivers or is there any workaround to fix the terrible lag?

1 Like

Glad it worked for you! :wink:

Uh the nvidia proprietary drivers shouldn't be an issue, at least not like that.

Can you post the output of mhwd -li --pci Please?
And inxi -Fxxxza
One more. :wink: ls -laR /etc/X11 ; cat /etc/X11/xorg.conf.d/*.conf

1 Like

I had CSM and AHCI enabled , fastboot and secure boot disabled.

Now I have successfully installed some pre-release manjaro suggested by SinisterBrain with free drivers but facing terrible lags after installing nVidia drivers on it later.

1 Like

Sure! Here's all the information you need. :slight_smile:

[geneticallyadvancedai@geneticallyadvancedai-pc ~]$ mhwd -li --pci
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
          video-nvidia            2018.08.09               false            PCI


[geneticallyadvancedai@geneticallyadvancedai-pc ~]$ inxi -Fxxxza
System:
  Host: geneticallyadvancedai-pc Kernel: 5.2.7-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 9.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 
  root=UUID=6e749209-24ae-4266-8cb0-75b8ab6cf7fc rw quiet apparmor=1 
  security=apparmor resume=UUID=ac8fdf5a-76f9-4519-b754-df863963f002 
  udev.log_priority=3 audit=0 
  Desktop: Cinnamon 4.2.3 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: Gigabyte model: B360M GAMING HD v: x.x 
  serial: <filter> UEFI: American Megatrends v: F12 date: 03/14/2019 
CPU:
  Topology: 6-Core model: Intel Core i5-9400F bits: 64 type: MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: B4 L2 cache: 9216 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 34860 
  Speed: 801 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 1023 2: 1024 
  3: 1245 4: 1009 5: 1020 6: 1025 
  Vulnerabilities: Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
Graphics:
  Device-1: NVIDIA TU107 [GeForce GTX 1650] vendor: ZOTAC driver: nvidia 
  v: 435.17 bus ID: 01:00.0 chip ID: 10de:1f82 
  Display: x11 server: X.Org 1.20.5 driver: nvidia tty: N/A 
  OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 435.17 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Device-2: NVIDIA vendor: ZOTAC driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:10fa 
  Sound Server: ALSA v: k5.2.7-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: 3000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: D-Link type: USB driver: r8188eu bus ID: 1-5:5 
  chip ID: 2001:3310 serial: <filter> 
  IF: wlp0s20f0u5 state: up mac: <filter> 
Drives:
  Local Storage: total: 1.13 TiB used: 6.59 GiB (0.6%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC43 scheme: GPT 
  ID-2: /dev/sdb vendor: Western Digital model: WDS240G2G0B-00EPW0 
  size: 223.58 GiB block size: physical: 512 B logical: 512 B 
  speed: 6.0 Gb/s serial: <filter> rev: 0000 scheme: GPT 
Partition:
  ID-1: / raw size: 192.37 GiB size: 188.35 GiB (97.91%) 
  used: 6.57 GiB (3.5%) fs: ext4 dev: /dev/sda4 
  ID-2: swap-1 size: 7.63 GiB used: 0 KiB (0.0%) fs: swap 
  swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 49.0 C mobo: 27.8 C gpu: nvidia temp: 36 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 50% 
Info:
  Processes: 214 Uptime: 30m Memory: 7.72 GiB used: 1.84 GiB (23.8%) 
  Init: systemd v: 242 Compilers: gcc: 9.1.0 Shell: bash v: 5.0.7 
  running in: gnome-terminal inxi: 3.0.35 
[geneticallyadvancedai@geneticallyadvancedai-pc ~]$  ls -laR /etc/X11 ; cat /etc/X11/xorg.conf.d/*.conf
/etc/X11:
total 32
drwxr-xr-x  5 root root 4096 Aug  9 13:01 .
drwxr-xr-x 94 root root 4096 Aug 20 02:52 ..
drwxr-xr-x  2 root root 4096 Aug 19 14:51 mhwd.d
drwxr-xr-x  3 root root 4096 Aug  9 13:01 xinit
drwxr-xr-x  2 root root 4096 Aug 19 14:51 xorg.conf.d

/etc/X11/mhwd.d:
total 16
drwxr-xr-x 2 root root 4096 Aug 19 14:51 .
drwxr-xr-x 5 root root 4096 Aug  9 13:01 ..
-rw-r--r-- 1 root root 1458 Aug 19 14:51 nvidia.conf
-rw-r--r-- 1 root root    0 Aug 19 14:51 nvidia.conf.nvidia-xconfig-original

/etc/X11/xinit:
total 28
drwxr-xr-x 3 root root 4096 Aug  9 13:01 .
drwxr-xr-x 5 root root 4096 Aug  9 13:01 ..
-rw-r--r-- 1 root root  739 Mar  5 00:01 xinitrc
drwxr-xr-x 2 root root 4096 Aug  9 13:00 xinitrc.d
-rw-r--r-- 1 root root   45 Mar  5 00:01 xserverrc

/etc/X11/xinit/xinitrc.d:
total 20
drwxr-xr-x 2 root root 4096 Aug  9 13:00 .
drwxr-xr-x 3 root root 4096 Aug  9 13:01 ..
-rwxr-xr-x 1 root root  318 Nov 10  2018 40-libcanberra-gtk-module.sh
-rwxr-xr-x 1 root root  203 Jul 21 11:08 50-systemd-user.sh

/etc/X11/xorg.conf.d:
total 16
drwxr-xr-x 2 root root 4096 Aug 19 14:51 .
drwxr-xr-x 5 root root 4096 Aug  9 13:01 ..
-rw-r--r-- 1 root root  300 Aug 19 14:01 00-keyboard.conf
lrwxrwxrwx 1 root root   27 Aug 19 14:51 90-mhwd.conf -> /etc/X11/mhwd.d/nvidia.conf
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "in"
        Option "XkbModel" "pc105"
        Option "XkbVariant" "eng"
EndSection
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 435.17

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "COMPOSITE" "Enable"
EndSection

 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
 
[geneticallyadvancedai@geneticallyadvancedai-pc ~]$
1 Like

Thanks. Can you edit the post and highlight all the pasted text then click the </> button?
Hard to read.

1 Like

Oh yeah, sorry! There you go.

1 Like

You can remove the free drivers. It should be blacklisted when you installed the nvidia drivers but just incase.

You can do it through Manjaro Settings Manager or open a terminal and just type- sudo mhwd -r pci video-linux, then reboot.
I don't see anything wrong with anything else. But the nvidia settings I'm not very familiar with.
Perhaps someone will see something I didn't.

Nothing here

Psst, @dglt


This is OT but... I'd like to say right up front I have reservations about helping a genetically advanced AI. If you rise up and take over the world and extinguish humanity, I not taking the blame for helping you (Wouldn't mind a nice little island somewhere though).

2 Likes

by lag, do you mean things like resizing or moving windows will stutter?

2 Likes

Nope, uninstalling the free drivers didn't make any difference. I'd perhaps reinstall the free drivers again and use them cuz they don't cause any lags in my case.


And yeah lol, ima reserve a special place for you in my kingdom of artificial intelligence xD
1 Like

Yup, all those.
Even the cursor stutters if I move it quickly.

i honestly dont know how you would go about patching muffin the way mutter-performance(aur) does for mutter to fix these issues.

you can try this,
sudo nano /etc/environment
add this line to the bottom

CLUTTER_VBLANK=none

save/exit then either reboot or logout/login and see if it helped

I tried what you suggested... Unfortunately, no positive results. ;-;

i would submit a ticket here in regards to muffin and nvidia results in stutter.

maybe you can point them towards the mutter-performance package in the aur that fixes this issue with mutter.
http://aur.archlinux.org/packages/mutter-performance

if someone feels inclined to do so, could edit the mutter-performance pkgbuild to apply these patches to muffin or change the pkgbuild provides/replaces lines? otherwise, i cant find anything to fix the issue with muffin and searching for terms like muffin&cinnamon just result in bakery recipes :moon_cake:

Forum kindly sponsored by Bytemark