Manjaro Linux problem with Philips Monitor USB Hub

Hi guys,

unfortunately I have a problem with Manjaro on my Setup. I hope Iḿ in the correct Sub Forum.

I have a Huawei Matebook D14 (with the Ryzen 3500u CPU ) and a Philips PHL346B1C Monitor.
The Monitor is connected to the Laptop with HDMI at 2560x1080 (stupid, I know. But the HDMI port on the Huawei Laptop does not support a higher resolution with more than 30fps) and USB C for charging (no vieo output through USB C on this Laptop…)

So long anything works just fine.
The only thing which annoys me is the USB Hub. On Windows, I had my mice and keyboard pluged into the USB Hub of the monitor. So when I come home, I only have to connect HDMI and USB C and everything is fine. On Linux the Hub does not work.

So, what can I do? Install DisplayLink drivers? I dont want to output the screen through USB C (my Laptop does not support it anyway). I just want to use the Hub. Or is this related with a driver issue I have no hope of getting solved?

As said, Manjaro with the 5.10.41-1 LTS Kernel

Okay, I`ve solved the issue.
I had to set the screen under the USB settings the KVM value from Auto to USB C. Dont know why, but it worked.

1 Like

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.