Manjaro Linux Installer doesn't show my USB drive

I would like to install Manjaro on a USB drive (64 GB) so that I can test it on my PC without needing to partition its SSD (which is kind of full at the moment).

  • I created a bootable USB with the Manjaro KDE iso
  • I booted the PC from the live USB stick
  • I plugged in the other (empty) USB where I want to install Manjaro (which has been correctly recognized by Manjaro Live)
  • I launched the Manjaro Linux Installer

The problem is that when the installer asks me where I would like to install Manjaro, it only shows my PC’s SSD as an option (and not the empty USB stick, that had already been recognized by the system).

Why is it doing that? Am I doing something wrong?

(I already tried to use another USB stick: same problem
I already tried creating the USB from a Virtual Machine instead of booting my PC with Manjaro Live: same problem)

Some users have success with it - others don’t - but it boils down to: is the device listed as removable or not.

To my knowledge Calamares is designed avoid installing to removable devices - as it could create an issue where one accidently selects the device containing the installation source.

To check if that is the case - list the recognized devices and check the RM column of the output.

The number 1 designates a removable device - which Calamares won’t install to (even that seems not to be inconsistent - confused? Now I am [HowTo] Install Manjaro on USB drive (with and without VirtualBox) - #7 by Shirshendu).

Sample output from my system and as you can see it is quite arbitrary how the system see’s the devices.

  • sdd is USB connected backup device
  • sde is USB stick
  • mmcblk0 is SD-card
➜  ~ lsblk
sdd       8:48   0   1,8T  0 disk 
└─sdd1    8:49   0   1,8T  0 part
sde       8:64   1  14,4G  0 disk 
├─sde1    8:65   1   250M  0 part 
├─sde2    8:66   1     1M  0 part 
└─sde3    8:67   1  14,2G  0 part 
sr0      11:0    1  1024M  0 rom  
mmcblk0 179:0    0    15G  0 disk 
        179:1    0    15G  0 part 
nvme0n1 259:0    0 476,9G  0 disk 
│       259:1    0   300M  0 part 
│       259:2    0 467,8G  0 part /
        259:3    0   8,8G  0 part [SWAP]

Thank you, that was exactly my case: my USB is marked as removable (RM is 1).
So how can I change it and “make it seen” as a non-removable device?

It is possible - but you shouldn’t do it as you risk damaging your device

Warning: It is not possible to flip the Removable Medium Bit (RMB) on every USB mass storage device and attempting to use software that is incompatible with your device may damage it. Attempting to flip the RMB is not recommended. - Install Arch Linux on a removable medium - ArchWiki