Manjaro Linux 21.2.6 possible execution issues

Hi there. I’m not a C programmer, but I am a HTML, CSS, JavaScript, PHP, and MySQL programmer, with a good understanding of Object-oriented concepts. I’m really using the Manjaro layout, but upon running echo $XDG_CURRENT_DESKTOP I get GNOME. There is really little difference between the two, with the exception of the dash bar auto-hiding in Manjaro, the icons being smaller in regular Gnome, and the Show Applications buttons are on opposing sides. Anyways, I think it was between last Friday and Monday I received an update that made it so I got a black Activities screen with two unusable window looking buttons that should normally go to two separate activities. The strange thing was, once I started typing on the Activities page, the two little window looking activity buttons started working. This makes me think that you were assigning an EventListener on some kind of key action, which would be technologically less logical than if you were to assign the Listener when you just enter the Activities page, or better yet before you even enter the Activities page. Although, after a recent update, it seems to be working, it makes me wonder if you still have additional unnecessary processes happening on an EventListener. By the way, not that it’s a system breaker, but your Layouts Switcher images are off. You’ll notice when you switch to Traditional that you see the correct image. I’m guessing that you just didn’t put the correct image in there in the first place, then when the button is pushed the pushed image is being used, then when the button push is released the image that should be there when loaded appears.

Just trying to help the system be the best it can. Although I was angry about the problem and it almost gave Linux a bad name, I do appreciate all of your hard work. Thanks for your time.

Manjaro 21.2.6 shipped with Gnome 41 series. Now we pushed Gnome 42 series to our stable branch, which will be part of Manjaro 22.0.0. We have Daily builds to see if some is broken in Gnome. Also our development team for the Gnome Edition is working hard to make the transition of already installed systems more smoother.

What happens if you create a new user on your system and log in to that session?

1 Like


But Layout Switcher is written in python and some css for GTK3.

You will always get that when running Gnome Desktop, with or without Layout Switcher.
If you run that command in KDE Plasma, you guess it, it will show

If you run
it will either point to X11 or Wayland depending what you chose, but on Gnome, running echo $XDG_CURRENT_DESKTOP will always report GNOME.

We used to have 6 layouts as presented here

Due to Gnome 42 changes now there are only 4, but on my install there is no issue with the Layouts images regardless what i chose and click and is active.

1 Like

I’m pretty much a web guy using Manjaro Linux because I hate Windows driver issues, so thanks for taking the time to put up with me. Drivers are obviously not my issue here. So… I did create another user with a password. The user showed up upon reboot, but I just got a black screen when I logged. I tried again. Even moving my mouse did nothing on the black screen. Maybe I need to do more when creating a user. I assumed I should still be able to move the mouse if I followed the How to Create a New User in Linux at instructions, but alias I’m a Linux moron. Do I also need to create a home directory for the other?

This site isn’t letting me embed links or images. Is that normal?

Thanks for your response. I’m using Wayland. Does that matter? I’m unable to post images or links, otherwise I would show you my screen, but it’s just like I stated in my original post. I’m using gnome-layout-switcher 0.8.27-1 if that helps. I can live with the problem since I’m not really switching layouts. So… I guess I’ll just wait for an update. Thanks to all… and to all a GOOD NIGHT!

Some extensions still fail under wayland, but there should be no issue with those activated via layout-switcher.
On a different install i managed to reproduce the issue you described




@Chrysostomus - the first svg files seems to be the wrong one … Will check on gitlab.

1 Like

Thanks again.