Manjaro KDE taking long to boot

A noob here :grinning: before I post, I`ve read and searched through the forum for a solution but failed to find it.
P.S. before jumping to Linux my windows would boot up in about a 17 second

my laptop is Lenovo i7-6700HQ @2.60, 16GB RAM, 4GB NVidia GTX 960m, 1TB HDD

Startup finished in 8.656s (firmware) + 6.571s (loader) + 3.207s (kernel) + 29.684s (userspace) = 49.119s reached after 30.000s in userspace"

systemd-analyze blame
10.613s lvm2-monitor.service
10.505s polkit.service
6.320s dev-sda2.device
5.669s avahi-daemon.service
5.668s bluetooth.service
5.658s NetworkManager.service
5.637s systemd-journal-flush.service
4.994s systemd-logind.service
4.769s systemd-modules-load.service
2.289s cups.service
2.066s systemd-udevd.service
1.918s systemd-tmpfiles-setup-dev.service
1.468s systemd-fsck-root.service
1.293s apparmor.service
1.022s ModemManager.service
949ms systemd-tmpfiles-setup.service
824ms systemd-fsck@dev-disk-by\x2duuid-8730\x2d9314.service
678ms tlp.service
657ms linux-module-cleanup.service
558ms udisks2.service
550ms systemd-rfkill.service
538ms dev-hugepages.mount
536ms dev-mqueue.mount
535ms sys-kernel-debug.mount
534ms sys-kernel-tracing.mount
532ms kmod-static-nodes.service
529ms modprobe@configfs.service
529ms modprobe@drm.service
528ms modprobe@fuse.service
526ms systemd-random-seed.service
516ms user@1000.service
433ms wpa_supplicant.service

Do you have an encrypted partition?

If not then you could mask lvm2-monitor.service:

systemctl disable --now lvm2-monitor.service
systemctl mask lvm2-monitor.service

Faster boot can be achieved by using a SSD… :wink:

thank you for the quick replay, already did it, didn’t change anything :sweat_smile:

$ systemd-analyze
Startup finished in 8.519s (firmware) + 6.576s (loader) + 3.110s (kernel) + 31.729s (userspace) = 49.936s reached after 31.147s in userspace

also now I have a pop-up every few minutes asking for KDE wallet password by different apps (kded5, Vivaldi, but I don’t have any)

Please post

systemd-analyze critical-chain

$ systemd-analyze critical-chain
The time when unit became active or started is printed after the “@” characte>
The time the unit took to start is printed after the “+” character. @ 31.147s
└─ @ 31.147s
└─ModemManager.service @ 30.123s +1.022s
└─polkit.service @ 19.507s +10.611s
└─ @ 19.159s
└─ @ 19.159s
└─snapd.socket @ 19.157s +1ms
└─ @ 19.033s
└─systemd-update-done.service @ 18.988s +43ms
└─ldconfig.service @ 17.060s +1.925s
└─ @ 17.059s
└─boot-efi.mount @ 16.407s +651ms
└─dev-disk-by\x2duuid-8730\x2d9314.device @15.728s

I would think the duration is linked to the use of a HDD, a nameable improvement is only to be expected if you are going to use a SSD.

Thank you, for your time
I will order my self an SDD :grin:
have a good one.

1 Like

Yes, then your output may look something like this, sure makes a difference from a HD:

systemd-analyze critical-chain> @798ms
└─lightdm.service @1.267s +15ms