Manjaro KDE Stuck in Raspberry Pi 400 Rainbow Screen

Hello folks,
I’ve an annoying problem with Manjaro KDE booting on Raspberry Pi 400. I’ve installed Manjaro KDE following the official instructions with using Pi Imager on a SanDisk SSD Plus 120GB. For a long while there was no problem, it was working like a charm. But recently, I started experiencing boot problems: sometimes it was booting, but mostly it was sticking sometimes in a black screen, sometimes in the rainbow screen. From this morning, now, it’s just sticking on rainbow screen. There is no chance to boot anymore.

Just for curiosity, I replaced the kernel8.img on my boot partition with the one in Manjaro KDE image. At this case, boot could pass the rainbow screen, but of course eventually failed. So I though, maybe my kernel8.img is corrupted someway.

Some extra info:

  1. I use the internal power of the pi original power adapter for my ssd from day one.

  2. I did overclocking, but I did this long ago and there was no problem after doing this. Here is my config.txt:
    initramfs initramfs-linux.img followkernel

    #enable sound

    #enable vc4


I wanna try to repair my boot, if I can. Thanks all of you.

I would start by backing off the overclocking. It can cause corruption[ especially with large upgrades. Not all pi’s are equal. Some people can get away with higher settings. When you replace the kernel8.img you will also have to add it’s modules under /usr/lib/modules/:

1 Like

It only worked for a while (system booted, rebooted), then after unplugging power yesterday night, boot process stuck in rainbow again. I think maybe the problem is all about my ssd case and its connection. I’ll change it, then try again. Thank you very much @Darksky.

As I suspected, it was SATA adapter to blame. After I installed my SSD into Orico 2139U3 case, problem solved. Thanks again @Darksky . However, I’ve another issue (with uas), but it requires a little bit digging first.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.