Manjaro kde random freeze/crash

I love manjaro KDE, but after many attempts to identify the reason behind random freezes , i can finally say that konsole is the cause

with terminator I dont get random freezes

at random, the pc become irresponsive and the only way is to force shutdown by long press power button

I use the terminal app to run angular and expressjs projects and launch vscode with code .

Don’t do that to your machine, see

Check your logs for hints and your memory usage while working.

You appear like a coder padawan and you are mistaken. You may think you have found the culprit - most likely you have not.

You - as developer - should know how easy it is to create code which can leave enormous amount of garbage in system memory. Such garbage is usually hung processes left running without the promise ever returning or processes indefinately looping consuming more and more memory until system is exhausted and no more swap is available.

So your finding is in reality a bandaid and does not solve the real issue your code is causing.

1 Like

i tried but there is many instructions to follow and im lazy :smiley:

i forced shutdown many times and i did NOT encounter any filesystem error or corrupted/lost files

main disk is ssd nvme and second is hdd

i do exactly the same stuff using terminator for days with hibernation and no freeze so far

i suspected konsole because when im only browsing web (not working) i have no issues

so i started using terminator to check and so far no freezes for days , with konsole it happens at pure random time and random cpu usage , it hangs between 1 and 3 times a day

im nodejs developer , thank you manjaro kde team for making my job easier

to clarify more, these random frezzes nearly made me crazy as it happens at pure random

i love manjaro kde
i dont remmeber exactly but i think i never had random freezes with windows with this pc . only manjaro kde is installed now on ssd nvme

i tried many kernels
i tried disable compositing
i tried disable timeshif or reduce the frequency of backups
i tried also manjaro gnome, i like it but i cant use it much because it doesnt 100% supports hibernation like kde, with gnome i had freezes but i cant tell the reason. but now with terminator i had no single freeze lead to pc totally crash . i experience some times plasma lags but the pc does not totally crash like with konsole
i did not remove konsole, i only unpin it from the panel and i dont use it

I really don’t think konsole is your issue here.

Think about it - if there really was such issue with konsole - it would have been screamed out on a variety of forums including the apps source code repo.

From what you say the issue has been following you everywhere … across kernels, across various system settings - you even tried reducing your snapshots?

Instead of looking at your code you are looking at the system?

While system regressions certainly happens - I really don’t think a wildly used virtual console app like konsole is the cause of your intermittent freezes - it is more likely infinite looping deadlocks in your code.

With nodejs, angular every kind of javascript - even when you are using typescript - you are working with code which requires enormous amount of coding dicipline to avoid even the most elementary bugs.

I know - I have sometimes blamed systems - but to my own displease - I have always found it to be my code - so instead of gaffa taping your code - blaming the system - and using another terminal emulator - an emulator which is evidently better at handling deadlocks - you should implement logging and log everything until you pinpoint the issue.

To illustrate.

I have an issue bugging me at the moment - I have been blaming Firefox browser - until I stripped down my css and html and found the browser does it right - but for some reason - and only with Firefox - never chrome based browsers - my code fails to behave as expected when formatting the pages for printing.

I could blame the browser - but it is not there - it is my code somewhere - I just have to find it.


yes, i was confused because with terminator i have no issue for days with hibernation
but it happens yesterday with terminator. (with konsole it happens more frequent)

now i doubt that there is an issue with google-chrome or brave that spikes the cpu usage before total freeze and crash

some times it happens directly after receiving a notification in gogole-chrome

restarting my expressjs project sometimes spikes the cpu usage also

apps i used daily:
chrome: popular websites, nothing special, 5-30 tabs
brave: youtube + popular sites, 5-10 tabs
terminal app: angular project, expressjs project, rabbitmq with elasticsearch code , 3-5 tabs
vscode launched from terminal with code .
bluetooth speaker
elasticsearch and java

system disk 512gb ssd nvme m.2 EXT4
second disk hdd 1tb EXT4
24gb ram | 25.5gb swap with hibernation, no problem with hibernation

  Host: manjaro Kernel: 5.15.50-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.24.5 Distro: Manjaro Linux
  Type: Laptop System: ASUSTeK product: TUF Gaming FX505DY_TUF505 v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: FX505DY v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: FX505DY.315 date: 03/09/2020
  ID-1: BAT0 charge: 36.5 Wh (100.0%) condition: 36.5/48.0 Wh (76.1%)
    volts: 11.7 min: 11.7
  Info: quad core AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx [MT MCP]
    speed (MHz): avg: 1857 min/max: 1400/2100
  Device-1: AMD Baffin [Radeon RX 460/560D / Pro
    driver: amdgpu v: kernel
  Device-2: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.3 driver: X: loaded: amdgpu
    unloaded: modesetting gpu: amdgpu resolution: 1: 1920x1080~60Hz
    2: 1920x1080~60Hz
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (raven LLVM 13.0.1 DRM 3.42
    v: 4.6 Mesa 22.1.2
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    driver: rtw_8821ce
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  Local Storage: total: 1.38 TiB used: 161.66 GiB (11.5%)
  Processes: 388 Uptime: 4h 2m Memory: 23.17 GiB used: 12.41 GiB (53.6%)
  Shell: Bash inxi: 3.3.19

im disabling hardware acceleration in chrome and brave and i will report back

i got

zsh input/output error

i can not execute any commands

this happens right after cpu spikes for 5 seconds. im not 100% sure but i think chrome or brave is to blame for cpu 100% usage of a cpu core

plasma crashed too

before cpu spikes, nothing disk intensive was running

after force shudown by long pressing power button, everything works, no file/disk errors

create a new user and test with it

thank you, i read this solution once but i think that if creating a new user is a solution, plasma is not stable enough
i like gnome but i need 100% support of hibernation like kde plasma do

Not so long ago I was involved in a discussion on stability.

I don’t think an efficient system exist - unless you build it ground up the Arch way.

If you choose any distribution you are presented with an initial layout defined by the philosophy driving the developers.

Stability has a different meaning dependinng on who you ask.

Plasma has never been stable for me - perhaps because I didn’t knew enough.

A couple of months ago I started experimenting - adding kwin to lxqt.

The experiment went well - and I thought - let me try the plasma desktop and I added the necessary components - and that went well too.

The key to a somewhat stable system is to have just enough components to achieve your workflow as adding more increases complexity and with increased complexity comes a degree of instability as there’s more components in play.

The amount of pressure you put on your desktop also adds a degree of instablility - especially with browsers - on a developer machine - if you are not very careful in coding your web apps - you can create a service worker which will crash your system without warning.

You mention several browsers with numerous tabs open - how many of them is running a worker service script in the background?

I see you changed the title of the topic - I am pleased I made you think - keep thinking.

In my experience - It is rarely the system itself that fails - but how it is used - perhaps strained - which makes it misbehave or crash.

Instead of hard reset You can use SysReq like described here [HowTo] reboot / turn off your frozen computer: REISUB/REISUO


Did you tried to downgrade the firmware ?

Steps from hans12 :

Here are your steps:

  1. pacman -S yay #(or install similar AUR-tool if not already installed)
  2. optional: yay -Syu #(will update your system)
  3. yay -S downgrade #(install downgrade)
  4. sudo downgrade --ala-only linux-firmware
  5. select option from march (36) or earlier
  6. optional: [Y] set linux-firmware on ignore list, to prevent future updates
  7. optional: reboot to immediately apply changes
1 Like

thank you for replies

after long hours googling “input/output error” i think that the problem is related to power management because i remember i got freezes many times directly or a couple minutes after waking from idle ( screen off). waking from hibernation works for hours though

i loaded defaults values in bios, maybe i changed something and i forget about it

in archlinux formum, some user had random freezes issue and fixed it by replacing wireless card


i have


before kernel 5.0, i had to install


to be able to use wifi and bluetooth, but after 5.0 i dont have to install that package because wifi and bluetooth work after clean install of manjaro with kernel +5.0

do i have to install that package even wifi and bluetooth work without issues ?

i restarted default values in bios for now

if i got freeze i will apply new kernel and report back

it happened again with kernel panic (cap locks led blinking)

im installing kernel 5.18.7-1

for now , using kernel 5.18.7-1 seems to fix the problem.

if problem occurs again, i will create new thread with much more informations because now i think its related to kernel and power management.

i also installed
and disabled fastboot in bios
and updated to latest stable yesterday

but im not sure if they are part of the fix

thank you

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.