Manjaro KDE Plasma, the system is very slow

I have installed Manjaro KDE Plasma, but the system is very slow. To open dolphin file manager takes 30-40 seconds.
So I have downloaded the latest Manjaro KDE plasma ISO file and used a different USB drive to make bootable drive. I can tell just from running the usb live session that it’s very slow.
I decided to try different distro and I picked Solus KDE & Fedora KDE It’s the same, from live session very slow. It seems that my PC dosn’t like KDE plasma. Is it the bios settings ???
Manjaro XFCE is running fine, very responsive.

My PC spec:
Gigabyte GA-H77N WiFi
CPU Intel i5 3570K
GPU Nvidia GTX 650
16GB Kingston Hyper X DDR3 1600Mhz Ram
Samsung 500GB Evo 860 SSD

Bootable drive: I used Sandisk Ultra Flair 32GB USB3 drive

Any suggestions ???

Welcome to the forum! :slight_smile:

More likely would be that your PC doesn’t like OpenGL, but in order to know that for certain, we’d need more information on your hardware.

Please read this informative post below… :arrow_down:

Hi @patrick797, and welcome!

The slow-ness can be caused by misconfigurations, as well as hardware. Considering you tried Fedora and Solus as well and it’s the same with them, it points to hardware. Quite possibly old/insufficient hardware.

To be certain, we need more information. Please see How to provide good information

Also, you might benefit from a more lightweight desktop environment, seeing as KDE is quite resource hungry. Try Xfce (although I’ve heard it uses quite a lot nowadays, it might still make a difference) or Lxqt

KDE Plasma and XFCE are about on par in terms of their memory footprint and resource usage nowadays. Back when Plasma was still in its 4.x generation, there was indeed quite a difference, but Plasma 5 is very lean by comparison. :wink:

One crucial difference however ─ which I’ve addressed in post #2 ─ is that Plasma heavily leans upon compositing. This can of course be switched off, or another form of compositing could be used ─ e.g. XRender ─ when the hardware cannot handle OpenGL 3.1 or later. And that might be the OP’s problem.

1 Like

Interesting. In that case, it might indeed be OpenGL…

1 Like

What storage type are you using? KDE Plasma has a lot of tiny I/O operations that’s not HDD friendly, especially Baloo when its indexing is in progress. At least you will need 7200RPM HDD but I guess it will still feel slow. SATA SSD is the bare minimum to have a blazing fast KDE Plasma experience. Or you can try stopping Baloo, which should be installed and run by default.

All in all, install htop and see for yourself which process is eating which resources. Check if I’m correct.

1 Like

I doubt that it would be Baloo, given that the problem also exists in the live session. Baloo would normally not be enabled there, because there wouldn’t be any point ─ it’s a read-only medium. :thinking:

Anyway, we won’t know for certain what’s wrong until the OP comes back with information about their hardware. For all we know, it could be some old single- or dual-core machine with only 1 or 2 GiB of RAM. :man_shrugging:

Make sense, but I never really try the live medium myself. My current system was installed from a now gone Manjaro CLI ISO (architect didn’t exist back then).

1 Like

are you using a 3.0 flash drive in a usb 3.0 port.
flash drives make a difference, there are an array of specs.
you want at least a 100mb read speed, 30mb write.

It’s not just the live session, because the OP stated… :arrow_down:


Yes I used Sandisk Ultra Flair 32GB USB3 derive

The fresh install is very slow, also the USB live session is very slow. I don’t know why
My PC is not very old (I think)

My PC spec:
Gigabyte GA-H77N WiFi
CPU Intel i5 3570K
GPU Nvidia GTX 650
16GB Kingston Hyper X DDR3 1600Mhz Ram
Samsung 500GB Evo 860 SSD

:rofl: :rofl: :rofl: :rofl: :rofl: :rofl: :rofl: :rofl: :rofl: :rofl: :rofl:

Onboard video or discrete graphics adapter? And have you tried… :arrow_down:

  • using OpenGL 2.0 instead of 3.1?
  • using XRender instead of OpenGL?
  • disabling the compositor altogether?

System Settings → Hardware → Display and Monitor → Compositor

Thank you for your reply

I have tried to change it to
XRender instead of OpenGL
I have tried OpenGL 2.0 & 3.1
No difference, everything is slow boot, logout, shutdown, opening applications
when I click on something nothing happens and 30-45 seconds later it opens

The strange thing is it happens from live session as well

What about disabling the compositor? It’s in the same settings page.

Enable compositor on startup (not checked)
Restarted my PC, no difference

Have you looked in htop or ksysguard for any stuck processes?

Memory usage 1.8GB (16GB installed)
CPU usage low under 8%

Well, I’m out of ideas on account of what to check. :frowning_face: But if XFCE works for you, then I guess it’s best if you stick to that. :man_shrugging: