Manjaro KDE Plasma not showing taskbar or desktop after update

After I updated manjaro a couple of day before I lost the taskbar and desktop.
Let me tell the whole story:
The thing is that I made a mistake, I changed the files ownership for the folder “/usr/bin/” to my user , of course this was a problem, I couldn’t use sudo and such, but I fixed that using the light CD of manjaro and changed the ownership to root and changed the rights of the files using the light CD as reference. That fixed all the problems of login and use of sudo. I worked fine for several days without any problem.
A couple of day ago I started an update of the system. The update failed because some existing files of one of the applications. I deleted the conflicted files and cancelled the update for that day.
But some apps stopped open and I restarted the system.
This was the “beginning of the end”.
The system didn’t boot again because lost the “vmlinuz-5.15-x86_64” file in the “/boot/” folder. I used the light CD to make “manjaro-chroot”, and installed the kernel and completed the failed update. My system can boot again :partying_face:
But when I logged in there it was not taskbar, not desktop. I’m searching for the taskbar issue but none of the question/answer I found help me fix the problem.

Can someone help me with this? I can’t reinstall manjaro right now so that isn’t a solution.

Thank you

There’s that, never used it, may break everything, or not work:


Hi @elvis.crego,

I think you will be able to do it from a chroot environment:

To enter a chroot environment

  1. Ensure you’ve got a relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot environment:

manjaro-chroot -a

If you have more than one Linux installation, select the correct one to use from the list provided.

If sucessfully done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart and can cause damage.

After that you need to re-sync the system. But this is the part I’m not :100: % certain about, so I’ll give you the safer and the more dangerous option.

Resync your system completely, from within the chroot environment:

sudo pacman-mirrors -f 5 && sudo pacman -Syyu && pamac upgrade --enable-downgrade --aur --devel

Wait for it to finish and if successful, exit the chroot environment:


And reboot.

If it isn’t OK after rebooting, enter the chroot environment as described above again, and use this command for the resync instead:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu && pamac upgrade --enable-downgrade --aur --devel --overwrite='*'

If it worked, feel free to heap on the praise. If it didn’t, welp, then I’m officially MIA.

Good luck!

1 Like

If this actually works, perhaps it should be included in the live system…

I tried this app but when it was installing all the packages get some errors in one of them and I end up uninstalling all KDE realted packages and installing them again.
That solve the problem with the desktop environment.

Thank you.

Thanks for the reply.
I end up doing sort of the same as you say, before reading this post.
But to ensure that KDE plasma works I uninstalled and installed again from scratch.
I will mark this as the solution because is close to what I did.
I used this link Install KDE plasma as reference for the package to uninstall.
I used pacman -R -c to uninstall the same package the post say and then run the steps to installed again.
I hope this help anyone with the same problem.

Probably a silly question, but why did you do that?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.