Manjaro KDE Plasma issues

EDIT:

I have gone and reinstalled Manjaro and while annoying that I lost few days worth of configuration, I learned my lesson.

Thank you all for the help and I wish you all a kickass week.


I was troubleshooting vscodium related issue where the work around was to copy 3 lines into .xinitrc using source command.

*When I opened the file it complained that monitor has already plasma installed and all I could do in was to close the window. *

I managed to get vscodium up and running but after restart my whole environment change from your basic breath theme to this blue theme: imgurDOTcom/unvF32nDOTpng

Programs barely open and when I tried to change themes and styles, nothing would change.

Any idea what is causing this and how to swap it back to Manjaro’s default KDE plasma?

I appreciate any help.

system settings/ global theme/ defaults, click apply
system settings/appearance/ configure gnome/gtk… select gtk theme to breeze, click apply

Thank you for your reply.

Per you instructions I opened system settings/ global theme/ defaults, and applied but nothing changed.

and the configure gnome/gtk ?

Apologies as I forgot to address that. I have application style and plasma style under the /appearance/ not configure gnome?

its in application style, click on configure gtk and select breeze and click apply

System Settings → Appearance → Application Style

Did you also log out and back in after making the changes? This is often needed.

Thank you for the clarification. I did log out and back in but nothing changed. Also there is no such thing at the lower end of my window as you can see:

imgurDOTcom/13db64a8-46f2-49b7-9648-9e3c88a5386e

did you configure the gnome/gtk settings in application style? … if yes then try deleting cache with:
rm -rf ~/.cache/*
reboot

I did not because I could not find it gnome/gtk in the application style and the strangest thing was that before restarting my system - I had Manjaro KDE Plasma and now when I ran

echo $DESKTOP_SESSION

it spit out gnome.

How have I gone from KDE Plasma to gnome ? :smile:

Could it be that you have both Plasma and Gnome desktop installed? If so you should be able to choose Plasma from the logon screen (I think at the lower right corner, depending on your SDDM theme).

Otherwise check your xinitrc and probably undo the changes you may have made, although you mentioned vaguely that you weren’t able to save your changes.

Log out and test with TTY (CTRL+ALT+F2 ). Run the following command:

startx /usr/bin/startplasma-x11 

This should bring up Plasma for that specific graphical session. If it doesn’t, then come back here and report results. You exit the session by a normal logout and then exit TTY with ALT+F1. (You can also try startx alone without /usr/bin/startplasma-x11).

I think in the process of addressing vscodium related issues, I have done something that had installed gnome on top of my Plasma. I have gone and reinstalled Manjaro and while annoying that I lost few days worth of configuration, I learned my lesson.

Thank you all for the help and I wish you all a kickass week.

It’s all part of learning. Removing the Gnome DE with it’s dependencies would have been another option to resolve it.
Thanks and have a great week ahead!