Manjaro KDE Plasma is very laggy

Hello All, I am using manjaro KDE Plasma 5.22.4 . Initially, I tested it in a virtual machine allocating 3 gb of ram and 100 gb of hard disk space and it ran almost fine. After that, I ran manjaro from a 16gb Sandisk USB and I got the snappy performance as one would get from a linux distro. After, I installed manjaro on hard disk , however the performance is not at all great. The problems I face

  1. Booting takes about 3 minutes , time from starting the machine to the desktop screen.
    2.Clicking on the menu launcher takes time to open which was never the case in case of live boot. Also typing into the search bar of the menu launcher is also extremely laggy.
  2. It takes a lot of time to launch every application.
  3. When I run the QT design studio, the system works ok for some time and then completely hangs.I have to force shutdown the entire machine by holding the power button.

I have gone through several posts in the forum but things not seem to work for me. I have turned off compositing but without any improvement. My nvidia.conf file is blank --I do not know why.

I would be really grateful if the community can help me to solve the problem.

Output of inxi -Fx

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "en_IN",
        LC_NAME = "en_IN",
        LC_MONETARY = "en_IN",
        LC_PAPER = "en_IN",
        LC_IDENTIFICATION = "en_IN",
        LC_TELEPHONE = "en_IN",
        LC_MEASUREMENT = "en_IN",
        LC_TIME = "en_IN",
        LC_NUMERIC = "en_IN",
        LANG = "en_IN.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_IN.UTF-8").
System:    Host: sayanc Kernel: 5.10.60-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.22.4 
           Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: INVA v: 330-15ICH serial: <superuser required> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0Q55722 WIN serial: <superuser required> UEFI-[Legacy]: LENOVO v: 7ZCN37WW 
           date: 11/27/2020 
Battery:   ID-1: BAT0 charge: 36.5 Wh (96.1%) condition: 38.0/45.0 Wh (84.3%) volts: 12.6 min: 11.3 model: SMP L17M3PB1 
           status: Unknown 
CPU:       Info: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP arch: Kaby Lake note: check rev: A cache: 
           L2: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36812 
           Speed: 800 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 801 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Lenovo driver: nvidia v: 470.63.01 bus-ID: 01:00.0 
           Device-3: Realtek EasyCamera type: USB driver: uvcvideo bus-ID: 1-8:2 
           Display: x11 server: X.Org 1.20.13 driver: loaded: modesetting,nvidia unloaded: nouveau resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.2.1 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
           Sound Server-1: ALSA v: k5.10.60-1-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.33 running: yes 
Network:   Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lenovo driver: ath10k_pci v: kernel 
           port: 4000 bus-ID: 07:00.0 
           IF: wlp7s0 state: up mac: 3c:91:80:22:17:67 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 3000 
           bus-ID: 08:00.0 
           IF: enp8s0 state: down mac: e8:6a:64:00:b5:19 
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-14:3 
           Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends 
Drives:    Local Storage: total: 931.51 GiB used: 68.75 GiB (7.4%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-24Z10 size: 931.51 GiB 
Partition: ID-1: / size: 907.15 GiB used: 68.09 GiB (7.5%) fs: ext4 dev: /dev/sda1 
Swap:      ID-1: swap-1 type: partition size: 8.8 GiB used: 674.7 MiB (7.5%) dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 46.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 238 Uptime: 1h 1m Memory: 7.65 GiB used: 2.19 GiB (28.6%) Init: systemd Compilers: gcc: 11.1.0 
           Packages: 1349 Shell: Bash v: 5.1.8 inxi: 3.3.06 
1 Like

watch sudo journalctl -f output, when freeze or hangs happens, eventually there will be something spitted there.

Boot times of 2-3 mins is to be expected from an HDD.

Some of the errors that I found by using your command
kwin_x11[866] : kwin_core XCB error : 3 (BadWindow) , sequence : 47362 , resource id : 14747426 major code : 129 (SHAPE) , minor code : 8 (GetRectangles)
qt.qpa.xcb:QXcbConnection : XCB error : 3 (BadWindow), sequence: 55478, resource id:5872067, major code: 18 (ChangeProperty), minor code : 0
plasmashell[900]: file /usr/share/plasma/shells/org.kde.plasma.desktop/contents/views/Panel.qml : 27:1 : QML Panel : Binding loop detected for property 'state'
plasmashell[900]: libpng warning: iCCP: known incorrect sRGB profile

On starting Dolphin File Manager, the following errors were found
kf.coreaddons: no metadata found in "/usr/lib/qt/plugins/kf5/kio/" "Failed to extract plugin meta data from '/usr/lib/qt/plugins/kf5/kio/' "
kf.coreaddons: no metadata found in "/usr/lib/qt/plugins/kf5/kio/" "Failed to extract plugin meta data from '/usr/lib/qt/plugins/kf5/kio/' "

However, on launching the qt design studio, the system totally hangs and I am unable to do anything…unable to open a terminal…no keys work. The only thing I could see (because I am launching qt design studio from command line) is as below
qt.qpa.xcb:QXcbConnection : XCB error : 3 (BadWindow), sequence: 55478, resource id:5872067, major code: 18 (ChangeProperty), minor code : 0
qt.gui.icc : from IccProfile: failed size sanity 1

Okkk…then that part is not a headache anymore.Thank you.

You have HDD drive and swap – when swap is in use system may be very slow and laggy. Disable swap or if you need it set:

sudo sysctl vm.swappiness=1

to say your system use swap only when it’s absolutely needed.

For faster startup times you can follow some tips

That it very slow even for a hard drive, KDE on HDD needs at max 1 minute or 2 minutes if ur very unlucky.

I am less worried about the boot timings and more worried about these things that I have posted. I would request everyone to kindly look into these and kindly guide me

Is this a laptop right? Are you using external monitor only? if so there is a bug in the nvidia driver where external display is laggy but on the laptop monitor everything is fluid,the workaround for now is this

Install optimus-manager from the official repositories

pamac install optimus-manager

Since you are using KDE,make sure to do this too.

Manjaro ships with a default configuration for SDDM (the default login manager for KDE) which overrides some keys needed by optimus-manager. To use optimus-manager, you need to edit the file /etc/sddm.conf and simply put a # before the line starting with DisplayCommand and the one starting with DisplayStopCommand .

When finished,reboot the computer,now you can switch between integrated (use intel card only),hybrid (intel + nvidia) (the one you are currently using) and nvidia mode (the one you want for external monitor)

optimus-manager --switch integrated
optimus-manager --switch hybrid
optimus-manager --switch nvidia

Then,logout and login again,you should be now using the nvidia mode,connect to the external monitor and everything should be fluid.

Sorry,but I am not using an external monitor.

Manjaro KDE Plasma is very responsive comparing to other distros if you have SSD in your computer. So, if you need more speed, I suggest upgrade to SSD if possible.

1 Like

Ok…maybe that’s the reason…

1 Like