Manjaro KDE Plasma can't detect my second monitor

Hi everyone,
I’m very new here. I’ve installed Manjaro because ZorinOS and other Ubuntu variants that used GNOME were painfully slow and I had mixed experience with Kubuntu (it was still a massive improvement but I still had problems). I’d tried Manjaro for a few weeks on a VM and liked what it offered so I decided to try it out.

So I go and download and flash the latest Manjaro KDE ISO to my USB drive. I try the open source drivers and after I hit enter and launch Manjaro it’s at this point the monitor that’s connected via HDMI doesn’t work while the one connected over VGA does. I just figure it’s because I’m in LiveCD mode and that this problem will go away when I install the OS. After waiting a bit and installing to my hard drive I reset and see that Manjaro still doesn’t detect my second monitor. I’m a bit annoyed and think “how about I try the propietary drivers, even though I’m on an AMD card (rx 560)”. I reinstall and the same thing happens, only one monitor works. Now I’ve gone back and reinstalled the open source version because what good is proprietary if it’s not gonna magically perform better? I’ve browsed some of the threads on this subject before and all I saw was some mention of -xrandr but I don’t know much about that command other than running it to get the output to see if it sees my monitors or not. Here we see it only detects one of the monitors. I’d like to state that when I’m in Windows there’s no problem and when I’m in BIOS there’s no problem with the monitor connected over HDMI. In fact I’ve used ZorinOS and some other distros (like vanilla Ubuntu) with this monitor+GPU and had no problems. Can anybody give some suggestions? Also sorry in advance if I haven’t included some other commands and their outputs but I couldn’t find a list on what all those things are supposed to be.

My specs are:
Ryzen 5 3600
32GB DDR4 3200MHz
Gigabyte A320m
Gigabyte RX 560
Seagate Barracuda 4TB HDD
Some random Hyundai 4:3 monitor connected over VGA with a DVI converter (this monitor works)
Some random LG 1080p 16:9 60Hz monitor connected over HDMI (this doesn’t work)

Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
HDMI-A-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 connected primary 1280x1024+0+0 (normal left inverted right x axis y axis) 337mm x 270mm
   1280x1024     60.02*+  75.02  
   1920x1080     60.00    50.00    59.94  
   1280x800      60.02  
   1280x720      60.00    59.94  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    60.32  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08    70.08 

Try to do the solution for RX 560.

When I entered in “amdgpu.dc=0” and then updated grub I got “/etc/default/grub: line 64: amdgpu.dc=0: command not found”.

What is the output of modinfo amdgpu | grep dc ?

The output is:
parm: dc:Display Core driver (1 = enable, 0 = disable, -1 = auto (default)) (int)
parm: dcfeaturemask:all stable DC features enabled (default)) (uint)
parm: dcdebugmask:all debug options disabled (default)) (uint)

What did you do to your grub config file? Post it.

I did what Zesko said. I added “amdgpu.dc=0” to /etc/default/grub.
I don’t see an option to directly upload files so please excuse the text spam.

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=7afbb40b-a381-4797-83bc-d14d845de6f4 udev.log_priority=3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Uncomment to disable submenus in boot menu

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki:


As you can see at the very end I added “amdgpu.dc=0”.

You didn’t read the instruction in the link, did you?

Nobody said to add this to the end of the file. Add it to where it says to add it, nowhere else.

Well sorry, this is new to me and I didn’t notice the arrow that expands the message he wrote so it was kind of mushed together. Alright I changed the line to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=7afbb40b-a381-4797-83bc-d14d845de6f4 udev.log_priority=3 amdgpu.dc=0"

And yeah that worked. Anyways, don’t be a jerk. The only time in my life I’ve ever updated a grubfile was to dual-boot Linux Mint and ZealOS because ZealOS’s bootloader at the time was very basic. Why the hell do you expect the average Linux noob to know about this stuff and not misread the instructions? If I was anymore inexperienced this thread would go on for way longer and probably wouldn’t get resolved. Be a bit more respectful.
Regardless, thanks to Zesko and thank you for your help.

The usual… can’t read a freaking post, and now I’m a jerk, I’m disrespectful? Are you out of your mind?

They didn’t have forums in your previous distribution? You never learned to click links people post to you in your support request threads? Seriously? You’re trying to put that on me now?

Because it was 3 lines of instructions (you didn’t read), that anyone could follow. Also, the average noob shouldn’t use a distribution that requires user maintenance like all Arch derivatives. You’re up for a ride when you’ll have to merge .pacnew files or to chroot after a bad update (this is not a IF, this is a WHEN).