Manjaro KDE extremely high CPU usage caused by VMware workstation

I’m having problem with very high CPU usage when I run virtual machines on VMware Workstation 16 Pro, like Windows7, 10, 11… I’m with kernel 5.15.65-1. The CPU usage goes up to 400%

  Host: buzdrev Kernel: 5.15.65-1-MANJARO arch: x86_64 bits: 64
    Console: pty pts/1 Distro: Manjaro Linux
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X421IA_M433IA
    v: 1.0 serial: LCN0CX02J083492
  Mobo: ASUSTeK model: X421IA v: 1.0 serial: LB48NBCX00LYV2MB
    UEFI: American Megatrends v: X421IA.312 date: 10/26/2021
  ID-1: BAT0 charge: 30.6 Wh (70.7%) condition: 43.3/50.0 Wh (86.5%)
    volts: 11.9 min: 11.9
  Info: 8-core model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64
    type: MCP cache: L2: 4 MiB
  Speed (MHz): avg: 1475 min/max: 1400/2000 cores: 1: 1400 2: 1400 3: 2000
    4: 1400 5: 1400 6: 1400 7: 1400 8: 1400
  Device-1: AMD Renoir driver: amdgpu v: kernel
  Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: amdgpu
    unloaded: modesetting gpu: amdgpu resolution: 1920x1080~60Hz
  OpenGL: renderer: AMD RENOIR (LLVM 14.0.6 DRM 3.42 5.15.65-1-MANJARO)
    v: 4.6 Mesa 22.1.7
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
  Device-2: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.15.65-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.57 running: yes
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi
  IF: wlp1s0 state: up mac: 78:2b:46:4a:7d:fb
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 200.5 GiB (42.0%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLQ512HALU-00000
    size: 476.94 GiB
  ID-1: / size: 460.08 GiB used: 200.47 GiB (43.6%) fs: btrfs
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 608 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 460.08 GiB used: 200.47 GiB (43.6%) fs: btrfs
    dev: /dev/nvme0n1p2
  ID-4: /var/log size: 460.08 GiB used: 200.47 GiB (43.6%) fs: btrfs
    dev: /dev/nvme0n1p2
  ID-1: swap-1 type: partition size: 16.56 GiB used: 26.2 MiB (0.2%)
    dev: /dev/nvme0n1p3
  System Temperatures: cpu: 41.8 C mobo: N/A gpu: amdgpu temp: 40.0 C
  Fan Speeds (RPM): cpu: 0
  Processes: 314 Uptime: 3h 17m Memory: 15.05 GiB used: 7.97 GiB (53.0%)
  Shell: Bash inxi: 3.3.21

Ok. I figured that by using QEMU instead of VMWare and VirtualBox.

Hello @buzdrev , I have the same problem with KVM. Did you solved this problem?