Manjaro KDE dolphin ROOT

Hi. Please help me. How do I open dolphin file explorer with root permission? I tried terminal command: su dolphin ; sudo dolphin - Doesn’t work.

I suppose you have been lectured on the dangers of running applications as root or with root permissions - if not consider yourself warned - there be dragons hiding - accidents waiting to happen - broken system waiting to happen …


pkexec dolphin

This. :point_up: :point_up: :point_up:

But I couldn’t find a way to do it, anyway. Got errors both when I tried with sudo as well as pkexec. Then I stopped worrying.

The once or twice I’ve done it, I used Midnight Commander from the terminal. So that’s what I’d recommend rather than Dolphin.

Unfortunately the command does not work here is a statement from the terminal:

pkexec dolphin
qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though
it was found.
This application failed to start because no Qt platform plugin could be init
ialized. Reinstalling the application may fix this problem.

Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, linuxfb, mi
nimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-
egl, wayland-xcomposite-glx, xcb.

Neúspěšně ukončen (SIGABRT) (core dumped [obraz paměti uložen])
1 Like

This is the error, or one of them I mentioned here

I’ve also given up on this, Krusader works well enough.

Dolphin will not run as root regardless the method/command used. Is so by design.
If you want to edit system config files, then you can do it with Kate and Kate will ask for your password to save the modified file.
To deal with folders you can use “root actions” plugin, but not all of them work, so you have to test. Copy, Delete will work with dialog popups and password.

1 Like

I have a folder: /home/mkey/hhd2
It now belongs to root users. I need to change permissions for mkey users. How to do this in the terminal? Thank you

It’s simple. This hasn’t been implemented yet by KDE devs. Might be a new feature this year. Or not. Use Krusader or Konsole for the time being.

sudo chown mkey:mkey /home/mkey/hhd2


sudo chown -R mkey:mkey /home/mkey/hhd2

Thank you very much, now the folder is in my possession. That’s what I needed. I no longer need Dolphin as root and I will use another browser for the root file explorer.

Open a new user session, log in as root, fix or damage to your heart’s content. Unlike Ubuntu, Manjaro allows this.



@wirefox Thanks for this. I had a broken link on my desktop since moving from Kubuntu. This fixed it for me.

If you want to make a desktop link, take out the sudo, pkexec will ask for password.

glad it helped :slightly_smiling_face:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.