Manjaro KDE cannot find my soundcard and ethernet

  1. After updating to Manjaro KDE 5.23, pulseaudio cannot find my sound card and my computer has no sound ever since unless I use a earphone. This is the output of sudo --upload
      Installed - Yes (/usr/bin/pipewire)
      Running - No

      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

      Installed - Yes (/usr/bin/jackd)
      Running - No

!!Soundcards recognised by ALSA

--- no soundcards ---

!!ALSA/HDA dmesg

[    0.169730] ACPI: Added _OSI(Linux-Dell-Video)
[    0.169730] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[    0.169730] ACPI: Added _OSI(Linux-HPI-Hybrid-Graphics)
[    2.234276] caller tgl_uncore_imc_freerunning_init_box 0xbf/0x100 [intel_uncore] mapping multiple BARs
[    2.240336] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[    2.240358] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake  platform, using SOF driver
[    2.240419] cryptd: max_cpu_qlen set to 1000
[    2.669591] mousedev: PS/2 mouse device common for all mice
[    2.677448] sof-audio-pci-intel-tgl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[    2.677469] sof-audio-pci-intel-tgl 0000:00:1f.3: Digital mics found on Skylake  platform, using SOF driver
[    2.677656] sof-audio-pci-intel-tgl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040380
[    2.677731] sof-audio-pci-intel-tgl 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    2.684115] sof-audio-pci-intel-tgl 0000:00:1f.3: use msi interrupt mode
[    2.730874] usb 3-10: New USB device found, idVendor=8087, idProduct=0032, bcdDevice= 0.00
[    2.730878] usb 3-10: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    2.760920] sof-audio-pci-intel-tgl 0000:00:1f.3: hda codecs found, mask 5
[    2.760924] sof-audio-pci-intel-tgl 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
[    2.760928] sof-audio-pci-intel-tgl 0000:00:1f.3: DMICs detected in NHLT tables: 2
[    2.761063] sof-audio-pci-intel-tgl 0000:00:1f.3: Direct firmware load for intel/sof/sof-tgl.ri failed with error -2
[    2.761065] sof-audio-pci-intel-tgl 0000:00:1f.3: error: sof firmware file is missing, you might need to
[    2.761066] sof-audio-pci-intel-tgl 0000:00:1f.3:        download it from
[    2.761066] sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed to load DSP firmware -2
[    2.761372] sof-audio-pci-intel-tgl 0000:00:1f.3: error: sof_probe_work failed err: -2
[    2.811821] ucsi_acpi USBC000:00: UCSI_GET_PDOS returned 0 bytes
  1. I have plugged in a 1000Mbps ethernet line but Manjaro cannot recognise it. This never happened before 2021.11.1, I have enabled wire network.
(base) [firestar@ThinkPad ~]$ inxi -Fazy
  Kernel: 5.15.0-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
  root=UUID=d6480b5b-8ab4-4c38-89d4-1177143caef0 rw quiet loglevel=3
  Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
  Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 20WKA000CD v: ThinkPad X13 Gen 2i
  serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: LENOVO model: 20WKA000CD v: SDK0L77769 WIN serial: <filter>
  UEFI: LENOVO v: N35ET34W (1.34 ) date: 04/22/2021
  ID-1: BAT0 charge: 54.7 Wh (100.0%) condition: 54.7/54.7 Wh (100.0%)
  volts: 17.3 min: 15.4 model: Sunwoda 5B10W51820 type: Li-poly
  serial: <filter> status: Full cycles: 28
  Info: Quad Core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
  arch: Tiger Lake family: 6 model-id: 8C (140) stepping: 1 microcode: 8A
  cache: L2: 12 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 44864
  Speed: 1086 MHz min/max: 400/4700 MHz Core speeds (MHz): 1: 1086 2: 628
  3: 566 4: 565 5: 1186 6: 503 7: 578 8: 568
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
  Device-2: IMC Networks Integrated RGB Camera type: USB driver: uvcvideo
  bus-ID: 3-4:4 chip-ID: 13d3:5271 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver:
  loaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1600 s-dpi: 192 s-size: 338x211mm (13.3x8.3")
  s-diag: 398mm (15.7")
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.2.4
  direct render: Yes
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo
  driver: sof-audio-pci-intel-tgl
  alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
  chip-ID: 8086:a0c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.0-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.39 running: no
  Device-1: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: kernel
  port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15fc class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
  bus-ID: 09:00.0 chip-ID: 8086:2725 class-ID: 0280
  IF: wlp9s0 state: up mac: <filter>
  IF-ID-1: wwp0s20f0u2i1 state: down mac: <filter>
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
  bus-ID: 3-10:6 chip-ID: 8087:0032 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Local Storage: total: 953.87 GiB used: 136.28 GiB (14.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVL21T0HCLR-00BL7
  size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
  lanes: 4 type: SSD serial: <filter> rev: 7L2QGXA7 temp: 41.9 C scheme: GPT
  ID-1: / raw-size: 313.45 GiB size: 307.46 GiB (98.09%)
  used: 29.64 GiB (9.6%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
  used: 31.2 MiB (12.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 43.0 C mobo: N/A
  Fan Speeds (RPM): fan-1: 2586
  Processes: 232 Uptime: 1m wakeups: 101 Memory: 15.36 GiB
  used: 1.38 GiB (9.0%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1146 lib: 329 Shell: Bash v: 5.1.8
  running-in: yakuake inxi: 3.3.08

Seems recognized, but not enabled.

The ethernet issue has solved by downgrading kernel from 5.15 to 5.13

the soundcard does not work with either pulseaudio or pipewire.

This is recognized also … but not working?
Try adding to boot options:


(note: if this works, it will likely break laptop microphone)

1 Like

where is boot options, /etc/default/grub?

do you mean: GRUB_CMDLINE_LINUX_DEFAULT="quiet loglevel=3 udev.log_priority=3 snd_intel_dspcfg.dsp_driver=1"

yes like that (though I leave ‘forever’ or ‘system’ ones on the DEFAULT line, and add mine to the other, but both work)
then run

sudo update-grub

and reboot

so what should I add to enable ethernet? Is this a bug when compiling kernels to Manjaro?

You stated it was fixed by using a different kernel … namely by not using the absolute newest one (it is not yet labeled ‘stable’), so I considered it well, fixed.

But 5.14 does not work either, 5.13 has marked EOL now.

5.10 is LTS, does that work ?
Also … you may make sure you have linux-firmware installed.

I have installed linux-firmware

5.10 has no wifi ethernet sound

I can only use 5.13 now

My ALSA information is located at

after following:

sudo pacman -Rdd pulseaudio pulseaudio-bluetooth pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf
sudo pacman -S manjaro-pipewire gst-plugin-pipewire pulseeffects pipewire-pulse

It has sound and I can use alsamixer to change volume now, but there is still no volume-control on my system tray

Partial ALSA data in post#1 shows an error message which may explain why no audio devices were detected

sof-audio-pci-intel-tgl 0000:00:1f.3: error: sof firmware file is missing

If package sof-firmware was not installed, kernel v5.14 would not be able to support use of Sound Open Firmware driver sof-audio-pci-intel-tgl for the “Dual far-field microphones”

But since the modprobe option has been added to force use of the legacy driver snd_hda_intel and disable the internal microphones, package sof-firmware is not needed

1 Like

I have found that if I go to the testing branch and update my kernel from 5.14-10 to 5.14-14, it will occur this 2 problems.

I’m umcertian what you meant to say but hopeful that it fixed those 2 problems…

Maybe something in the 10.27 Testing Branch Update is responsible for these problems.

If you get ALSA data again with sudo --upload the data for the new kernel version can be compared to previous working state with kernel v5.13

You could also edit GRUB before OS boot and temporarily remove option snd_intel_dspcfg.dsp_driver=1
to check if the SOF driver snd_sof_pci_intel_tgl is working better than the legacy driver

as for the sound, I solve it by installing sof-firmware

but the ethernet issue has not been fixed

I return to kernel 5.14-10 now which has no issues about ethernet

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.